diff options
author | Jens Rehsack <rehsack@gmail.com> | 2015-10-14 20:51:38 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-10-23 12:53:23 +0200 |
commit | c56ad520295692ba883f3d079ba835b252b2e144 (patch) | |
tree | cb4a66bfd7b9e37a868f7eb3e5ece15e4f654a4c /meta-webserver | |
parent | 67e0959f332937e70c9766caab6104e13ddd0619 (diff) | |
download | meta-openembedded-c56ad520295692ba883f3d079ba835b252b2e144.tar.gz |
nginx: update to 1.9.5
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-httpd/nginx/files/nginx-cross.patch | 17 | ||||
-rw-r--r-- | meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb (renamed from meta-webserver/recipes-httpd/nginx/nginx_1.4.4.bb) | 6 |
2 files changed, 12 insertions, 11 deletions
diff --git a/meta-webserver/recipes-httpd/nginx/files/nginx-cross.patch b/meta-webserver/recipes-httpd/nginx/files/nginx-cross.patch index 5f899a1d8..46792ba06 100644 --- a/meta-webserver/recipes-httpd/nginx/files/nginx-cross.patch +++ b/meta-webserver/recipes-httpd/nginx/files/nginx-cross.patch | |||
@@ -122,7 +122,7 @@ diff -uraN nginx-1.0.11.orig/auto/options nginx-1.0.11/auto/options | |||
122 | diff -uraN nginx-1.0.11.orig/auto/types/sizeof nginx-1.0.11/auto/types/sizeof | 122 | diff -uraN nginx-1.0.11.orig/auto/types/sizeof nginx-1.0.11/auto/types/sizeof |
123 | --- nginx-1.0.11.orig/auto/types/sizeof 2006-06-28 11:00:26.000000000 -0500 | 123 | --- nginx-1.0.11.orig/auto/types/sizeof 2006-06-28 11:00:26.000000000 -0500 |
124 | +++ nginx-1.0.11/auto/types/sizeof 2011-12-27 13:56:42.323370040 -0600 | 124 | +++ nginx-1.0.11/auto/types/sizeof 2011-12-27 13:56:42.323370040 -0600 |
125 | @@ -11,9 +11,12 @@ | 125 | @@ -12,9 +12,12 @@ |
126 | 126 | ||
127 | END | 127 | END |
128 | 128 | ||
@@ -137,14 +137,14 @@ diff -uraN nginx-1.0.11.orig/auto/types/sizeof nginx-1.0.11/auto/types/sizeof | |||
137 | 137 | ||
138 | #include <sys/types.h> | 138 | #include <sys/types.h> |
139 | #include <sys/time.h> | 139 | #include <sys/time.h> |
140 | @@ -31,19 +34,20 @@ | 140 | @@ -33,20 +36,20 @@ |
141 | END | 141 | END |
142 | 142 | ||
143 | 143 | ||
144 | -ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \ | 144 | -ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \ |
145 | - -o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs" | 145 | - -o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs" |
146 | + ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \ | 146 | + ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \ |
147 | + -o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs" | 147 | + -o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs" |
148 | 148 | ||
149 | -eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1" | 149 | -eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1" |
150 | + eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1" | 150 | + eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1" |
@@ -155,17 +155,18 @@ diff -uraN nginx-1.0.11.orig/auto/types/sizeof nginx-1.0.11/auto/types/sizeof | |||
155 | - echo " $ngx_size bytes" | 155 | - echo " $ngx_size bytes" |
156 | -fi | 156 | -fi |
157 | + if [ -x $NGX_AUTOTEST ]; then | 157 | + if [ -x $NGX_AUTOTEST ]; then |
158 | + ngx_size=`$NGX_AUTOTEST` | 158 | + ngx_size=`$NGX_AUTOTEST` |
159 | + echo " $ngx_size bytes" | 159 | + echo " $ngx_size bytes" |
160 | + fi | 160 | + fi |
161 | 161 | ||
162 | 162 | ||
163 | -rm -f $NGX_AUTOTEST | 163 | -rm -rf $NGX_AUTOTEST* |
164 | + rm -f $NGX_AUTOTEST | 164 | - |
165 | + rm -rf $NGX_AUTOTEST* | ||
165 | +fi | 166 | +fi |
166 | 167 | ||
167 | |||
168 | case $ngx_size in | 168 | case $ngx_size in |
169 | 4) | ||
169 | diff -uraN nginx-1.0.11.orig/auto/unix nginx-1.0.11/auto/unix | 170 | diff -uraN nginx-1.0.11.orig/auto/unix nginx-1.0.11/auto/unix |
170 | --- nginx-1.0.11.orig/auto/unix 2011-12-14 07:34:16.000000000 -0600 | 171 | --- nginx-1.0.11.orig/auto/unix 2011-12-14 07:34:16.000000000 -0600 |
171 | +++ nginx-1.0.11/auto/unix 2011-12-27 13:56:42.327370060 -0600 | 172 | +++ nginx-1.0.11/auto/unix 2011-12-27 13:56:42.327370060 -0600 |
diff --git a/meta-webserver/recipes-httpd/nginx/nginx_1.4.4.bb b/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb index 27e4749d6..a251523bc 100644 --- a/meta-webserver/recipes-httpd/nginx/nginx_1.4.4.bb +++ b/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb | |||
@@ -6,7 +6,7 @@ concurrency, performance and low memory usage." | |||
6 | 6 | ||
7 | HOMEPAGE = "http://nginx.org/" | 7 | HOMEPAGE = "http://nginx.org/" |
8 | LICENSE = "BSD-2-Clause" | 8 | LICENSE = "BSD-2-Clause" |
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=917bfdf005ffb6fd025550414ff05a9f" | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3845852aedfa8d6d7765f55d06cc3ebd" |
10 | SECTION = "net" | 10 | SECTION = "net" |
11 | 11 | ||
12 | DEPENDS = "libpcre gzip openssl" | 12 | DEPENDS = "libpcre gzip openssl" |
@@ -19,8 +19,8 @@ SRC_URI = " \ | |||
19 | file://nginx-volatile.conf \ | 19 | file://nginx-volatile.conf \ |
20 | file://nginx.service \ | 20 | file://nginx.service \ |
21 | " | 21 | " |
22 | SRC_URI[md5sum] = "5dfaba1cbeae9087f3949860a02caa9f" | 22 | SRC_URI[md5sum] = "2562320f1535e3e31d165e337ae94f21" |
23 | SRC_URI[sha256sum] = "7c989a58e5408c9593da0bebcd0e4ffc3d892d1316ba5042ddb0be5b0b4102b9" | 23 | SRC_URI[sha256sum] = "48e2787a6b245277e37cb7c5a31b1549a0bbacf288aa4731baacf9eaacdb481b" |
24 | 24 | ||
25 | inherit update-rc.d useradd | 25 | inherit update-rc.d useradd |
26 | 26 | ||