diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2013-04-27 13:31:17 +0100 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2013-05-02 11:11:54 +0100 |
commit | a5f631eefdfaeca22d8d06b63d1e27fb934a8bc5 (patch) | |
tree | e9cf89e0ee7d26c76310f95a0503e9c3d18eaa28 /meta-webserver | |
parent | 0546dd4297abcf8f01b719a6dcb6c2c21214734e (diff) | |
download | meta-openembedded-a5f631eefdfaeca22d8d06b63d1e27fb934a8bc5.tar.gz |
sthttpd: add recipe
This is the "supported" fork of thttpd which has a rewritten build
system to avoid the need to patch it, as well as other minor
fixes. The recipe was based on the thttpd recipe in meta-arago-extras
(originally migrated from OE-Classic by
Franklin S. Cooper Jr <fcooper@ti.com>) with the following improvements:
* Set SUMMARY
* Remove PARALLEL_MAKE = "" (new build system should avoid previous issues)
* Use more accurate LICENSE
* Rearrange recipe to conform with current style
* Use += instead of _append for FILES definitions
* Add LSB headers to initscript
* Fix hardcoded ${sbindir} in initscript
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-httpd/sthttpd/sthttpd/init | 52 | ||||
-rw-r--r-- | meta-webserver/recipes-httpd/sthttpd/sthttpd_2.26.4.bb | 31 |
2 files changed, 83 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/sthttpd/sthttpd/init b/meta-webserver/recipes-httpd/sthttpd/sthttpd/init new file mode 100644 index 000000000..70f6797a7 --- /dev/null +++ b/meta-webserver/recipes-httpd/sthttpd/sthttpd/init | |||
@@ -0,0 +1,52 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | ### BEGIN INIT INFO | ||
4 | # Provides: thttpd | ||
5 | # Required-Start: $remote_fs $syslog | ||
6 | # Required-Stop: $remote_fs $syslog | ||
7 | # Default-Start: 2 3 4 5 | ||
8 | # Default-Stop: 0 1 6 | ||
9 | # Short-Description: Small http server | ||
10 | # Description: thttpd is a simple, small, portable, fast, and secure HTTP server. | ||
11 | ### END INIT INFO | ||
12 | |||
13 | |||
14 | thttpd=/usr/sbin/thttpd | ||
15 | test -x "$thttpd" || exit 0 | ||
16 | |||
17 | |||
18 | case "$1" in | ||
19 | start) | ||
20 | echo -n "Starting thttpd" | ||
21 | start-stop-daemon --start --quiet --exec $thttpd -- -d @@SRVDIR | ||
22 | echo "." | ||
23 | ;; | ||
24 | stop) | ||
25 | echo -n "Stopping thttpd" | ||
26 | start-stop-daemon --stop --quiet --exec $thttpd | ||
27 | echo "." | ||
28 | ;; | ||
29 | reload|force-reload) | ||
30 | start-stop-daemon --stop --quiet --signal 1 --exec $thttpd | ||
31 | ;; | ||
32 | restart) | ||
33 | echo -n "Stopping thttpd" | ||
34 | start-stop-daemon --stop --quiet --exec $thttpd -- -d @@SRVDIR | ||
35 | echo "." | ||
36 | echo -n "Waiting for thttpd to die off" | ||
37 | for i in 1 2 3 ; | ||
38 | do | ||
39 | sleep 1 | ||
40 | echo -n "." | ||
41 | done | ||
42 | echo "" | ||
43 | echo -n "Starting thttpd" | ||
44 | start-stop-daemon --start --quiet --exec $thttpd -- -d @@SRVDIR | ||
45 | echo "." | ||
46 | ;; | ||
47 | *) | ||
48 | echo "Usage: /etc/init.d/thttpd {start|stop|reload|restart|force-reload}" | ||
49 | exit 1 | ||
50 | esac | ||
51 | |||
52 | exit 0 | ||
diff --git a/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.26.4.bb b/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.26.4.bb new file mode 100644 index 000000000..ba2f047a9 --- /dev/null +++ b/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.26.4.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | SUMMARY = "A simple, small, portable, fast, and secure HTTP server" | ||
2 | DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server (supported fork of thttpd)." | ||
3 | HOMEPAGE = "http://opensource.dyc.edu/sthttpd" | ||
4 | LICENSE = "BSD-2-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://src/thttpd.c;beginline=1;endline=26;md5=0c5762c2c34dcbe9eb18815516502872" | ||
6 | |||
7 | SRC_URI = "http://opensource.dyc.edu/pub/sthttpd/sthttpd-${PV}.tar.gz \ | ||
8 | file://init" | ||
9 | |||
10 | SRC_URI[md5sum] = "e645a85a97d3cb883011a35bc2211815" | ||
11 | SRC_URI[sha256sum] = "78e87979140cbda123c81b4051552242dbbffb5dec1a17e5f95ec4826b1eaddb" | ||
12 | |||
13 | S = "${WORKDIR}/sthttpd-${PV}" | ||
14 | |||
15 | inherit autotools update-rc.d | ||
16 | |||
17 | EXTRA_OEMAKE += "'WEBDIR=${servicedir}/www'" | ||
18 | |||
19 | do_install_append () { | ||
20 | install -d ${D}${sysconfdir}/init.d | ||
21 | install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/thttpd | ||
22 | sed -i -e 's,@@SRVDIR,${servicedir}/www,g' ${D}${sysconfdir}/init.d/thttpd | ||
23 | sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/thttpd | ||
24 | } | ||
25 | |||
26 | INITSCRIPT_NAME = "thttpd" | ||
27 | INITSCRIPT_PARAMS = "defaults" | ||
28 | |||
29 | FILES_${PN} += "${servicedir}" | ||
30 | FILES_${PN}-dbg += "${servicedir}/www/cgi-bin/.debug" | ||
31 | |||