diff options
author | Kai Kang <kai.kang@windriver.com> | 2019-09-06 06:38:38 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-09-05 18:13:44 -0700 |
commit | 8d4d608b4e937bb3b8e3b260bd75338c3ff7e8fd (patch) | |
tree | 9d97846b0a640e29d3be73f990d9ee1acfdc2e5d /meta-webserver | |
parent | 99bb172561b72d11b6b0efc3bb5a9d915f9763f8 (diff) | |
download | meta-openembedded-8d4d608b4e937bb3b8e3b260bd75338c3ff7e8fd.tar.gz |
apache2: fix multilib file conflicts
There are errors of apache2 about files conflicts when multilib enabled:
| Error: Transaction check error:
| file /etc/apache2/extra/httpd-ssl.conf conflicts between attempted installs of lib32-apache2-2.4.41-r0.core2_32 and apache2-2.4.41-r0.core2_64
| file /etc/apache2/httpd.conf conflicts between attempted installs of lib32-apache2-2.4.41-r0.core2_32 and apache2-2.4.41-r0.core2_64
| file /usr/sbin/envvars conflicts between attempted installs of lib32-apache2-2.4.41-r0.core2_32 and apache2-2.4.41-r0.core2_64
| file /usr/sbin/envvars-std conflicts between attempted installs of lib32-apache2-2.4.41-r0.core2_32 and apache2-2.4.41-r0.core2_64
It makes libexecdir point to ${libdir}. Reset to ${libexecdir} which could
eliminate file conflicts of the conf files. And remove /usr/sbin/envvars and
/usr/sbin/envvars-std which only used by apachectl. They only add standard
library path ${libdir} to LD_LIBRARY_PATH, so remove them to avoid multilib
file conflicts.
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-httpd/apache2/apache2_2.4.41.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.41.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.41.bb index a8da7e227..a34734c20 100644 --- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.41.bb +++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.41.bb | |||
@@ -53,7 +53,7 @@ EXTRA_OECONF_class-target = "\ | |||
53 | --sysconfdir=${sysconfdir}/${BPN} \ | 53 | --sysconfdir=${sysconfdir}/${BPN} \ |
54 | --datadir=${datadir}/${BPN} \ | 54 | --datadir=${datadir}/${BPN} \ |
55 | --libdir=${libdir} \ | 55 | --libdir=${libdir} \ |
56 | --libexecdir=${libdir}/${BPN}/modules \ | 56 | --libexecdir=${libexecdir}/${BPN}/modules \ |
57 | --localstatedir=${localstatedir} \ | 57 | --localstatedir=${localstatedir} \ |
58 | --enable-ssl \ | 58 | --enable-ssl \ |
59 | --with-dbm=sdbm \ | 59 | --with-dbm=sdbm \ |
@@ -78,7 +78,7 @@ EXTRA_OECONF_class-native = "\ | |||
78 | " | 78 | " |
79 | 79 | ||
80 | do_configure_prepend() { | 80 | do_configure_prepend() { |
81 | sed -i -e 's:$''{prefix}/usr/lib/cgi-bin:$''{libdir}/cgi-bin:g' ${S}/config.layout | 81 | sed -i -e 's:$''{prefix}/usr/lib/cgi-bin:$''{libexecdir}/cgi-bin:g' ${S}/config.layout |
82 | } | 82 | } |
83 | 83 | ||
84 | do_install_append_class-target() { | 84 | do_install_append_class-target() { |
@@ -139,7 +139,7 @@ do_install_append_class-target() { | |||
139 | install -m 0644 ${WORKDIR}/volatiles.04_apache2 ${D}${sysconfdir}/default/volatiles/04_apache2 | 139 | install -m 0644 ${WORKDIR}/volatiles.04_apache2 ${D}${sysconfdir}/default/volatiles/04_apache2 |
140 | fi | 140 | fi |
141 | 141 | ||
142 | rm -rf ${D}${localstatedir} | 142 | rm -rf ${D}${localstatedir} ${D}${sbindir}/envvars* |
143 | chown -R root:root ${D} | 143 | chown -R root:root ${D} |
144 | } | 144 | } |
145 | 145 | ||