diff options
author | Koen Kooi <koen.kooi@linaro.org> | 2014-06-17 09:22:17 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-06-21 12:20:20 +0200 |
commit | 6730b008976dbf168ad2094811622dc08ce93999 (patch) | |
tree | d45b9664130c77be68469a6113bbbb78fa68d4d2 /meta-webserver | |
parent | 52b21a1951fc21ae1ae85440fcf6da04ad3258ea (diff) | |
download | meta-openembedded-6730b008976dbf168ad2094811622dc08ce93999.tar.gz |
apache2(-native): use pkg-config for pcre detection
Also fixup apache2-native recipe to use autotools and SEPB.
Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver')
3 files changed, 66 insertions, 10 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.9.bb b/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.9.bb index aaa7e607d..e50f2b818 100644 --- a/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.9.bb +++ b/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.9.bb | |||
@@ -6,9 +6,11 @@ DEPENDS = "expat-native pcre-native apr-native apr-util-native" | |||
6 | SECTION = "net" | 6 | SECTION = "net" |
7 | LICENSE = "Apache-2.0" | 7 | LICENSE = "Apache-2.0" |
8 | 8 | ||
9 | inherit native | 9 | inherit autotools native |
10 | 10 | ||
11 | SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2" | 11 | SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \ |
12 | file://0001-configure-use-pkg-config-for-PCRE-detection.patch \ | ||
13 | " | ||
12 | 14 | ||
13 | S = "${WORKDIR}/httpd-${PV}" | 15 | S = "${WORKDIR}/httpd-${PV}" |
14 | 16 | ||
@@ -16,11 +18,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=dbff5a2b542fa58854455bf1a0b94b83" | |||
16 | SRC_URI[md5sum] = "2ef4e65353497606b24fa9bb3e5a3c40" | 18 | SRC_URI[md5sum] = "2ef4e65353497606b24fa9bb3e5a3c40" |
17 | SRC_URI[sha256sum] = "f78cc90dfa47caf3d83ad18fd6b4e85f237777c1733fc9088594b70ce2847603" | 19 | SRC_URI[sha256sum] = "f78cc90dfa47caf3d83ad18fd6b4e85f237777c1733fc9088594b70ce2847603" |
18 | 20 | ||
19 | do_configure () { | 21 | EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ |
20 | ./configure --with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ | 22 | --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \ |
21 | --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \ | 23 | --prefix=${prefix} --datadir=${datadir}/apache2 \ |
22 | --prefix=${prefix} --datadir=${datadir}/apache2 | 24 | " |
23 | } | ||
24 | 25 | ||
25 | do_install () { | 26 | do_install () { |
26 | install -d ${D}${bindir} ${D}${libdir} | 27 | install -d ${D}${bindir} ${D}${libdir} |
@@ -28,13 +29,15 @@ do_install () { | |||
28 | install -m 755 support/apxs ${D}${bindir}/ | 29 | install -m 755 support/apxs ${D}${bindir}/ |
29 | install -m 755 httpd ${D}${bindir}/ | 30 | install -m 755 httpd ${D}${bindir}/ |
30 | install -d ${D}${datadir}/apache2/build | 31 | install -d ${D}${datadir}/apache2/build |
32 | cp ${S}/build/*.mk ${D}${datadir}/apache2/build | ||
31 | cp build/*.mk ${D}${datadir}/apache2/build | 33 | cp build/*.mk ${D}${datadir}/apache2/build |
32 | cp build/instdso.sh ${D}${datadir}/apache2/build | 34 | cp ${S}/build/instdso.sh ${D}${datadir}/apache2/build |
33 | 35 | ||
34 | install -d ${D}${includedir}/apache2 | 36 | install -d ${D}${includedir}/apache2 |
37 | cp ${S}/include/* ${D}${includedir}/apache2 | ||
35 | cp include/* ${D}${includedir}/apache2 | 38 | cp include/* ${D}${includedir}/apache2 |
36 | cp os/unix/os.h ${D}${includedir}/apache2 | 39 | cp ${S}/os/unix/os.h ${D}${includedir}/apache2 |
37 | cp os/unix/unixd.h ${D}${includedir}/apache2 | 40 | cp ${S}/os/unix/unixd.h ${D}${includedir}/apache2 |
38 | 41 | ||
39 | cp support/envvars-std ${D}${bindir}/envvars | 42 | cp support/envvars-std ${D}${bindir}/envvars |
40 | chmod 755 ${D}${bindir}/envvars | 43 | chmod 755 ${D}${bindir}/envvars |
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.9.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.9.bb index 33e197ab8..47881103c 100644 --- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.9.bb +++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.9.bb | |||
@@ -16,6 +16,7 @@ SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \ | |||
16 | file://apache-ssl-ltmain-rpath.patch \ | 16 | file://apache-ssl-ltmain-rpath.patch \ |
17 | file://httpd-2.4.3-fix-race-issue-of-dir-install.patch \ | 17 | file://httpd-2.4.3-fix-race-issue-of-dir-install.patch \ |
18 | file://npn-patch-2.4.7.patch \ | 18 | file://npn-patch-2.4.7.patch \ |
19 | file://0001-configure-use-pkg-config-for-PCRE-detection.patch \ | ||
19 | file://init \ | 20 | file://init \ |
20 | file://apache2-volatile.conf" | 21 | file://apache2-volatile.conf" |
21 | 22 | ||
diff --git a/meta-webserver/recipes-httpd/apache2/files/0001-configure-use-pkg-config-for-PCRE-detection.patch b/meta-webserver/recipes-httpd/apache2/files/0001-configure-use-pkg-config-for-PCRE-detection.patch new file mode 100644 index 000000000..63096db0a --- /dev/null +++ b/meta-webserver/recipes-httpd/apache2/files/0001-configure-use-pkg-config-for-PCRE-detection.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | From d8837756f2a48adcfe5d645c39cf163d96eac76c Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen.kooi@linaro.org> | ||
3 | Date: Tue, 17 Jun 2014 09:10:57 +0200 | ||
4 | Subject: [PATCH] configure: use pkg-config for PCRE detection | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen.kooi@linaro.org> | ||
7 | Upstream-Status: pending | ||
8 | --- | ||
9 | configure.in | 27 +++++---------------------- | ||
10 | 1 file changed, 5 insertions(+), 22 deletions(-) | ||
11 | |||
12 | diff --git a/configure.in b/configure.in | ||
13 | index 864d7c7..da4138e 100644 | ||
14 | --- a/configure.in | ||
15 | +++ b/configure.in | ||
16 | @@ -215,28 +215,11 @@ fi | ||
17 | AC_ARG_WITH(pcre, | ||
18 | APACHE_HELP_STRING(--with-pcre=PATH,Use external PCRE library)) | ||
19 | |||
20 | -AC_PATH_PROG(PCRE_CONFIG, pcre-config, false) | ||
21 | -if test -d "$with_pcre" && test -x "$with_pcre/bin/pcre-config"; then | ||
22 | - PCRE_CONFIG=$with_pcre/bin/pcre-config | ||
23 | -elif test -x "$with_pcre"; then | ||
24 | - PCRE_CONFIG=$with_pcre | ||
25 | -fi | ||
26 | - | ||
27 | -if test "$PCRE_CONFIG" != "false"; then | ||
28 | - if $PCRE_CONFIG --version >/dev/null 2>&1; then :; else | ||
29 | - AC_MSG_ERROR([Did not find pcre-config script at $PCRE_CONFIG]) | ||
30 | - fi | ||
31 | - case `$PCRE_CONFIG --version` in | ||
32 | - [[1-5].*]) | ||
33 | - AC_MSG_ERROR([Need at least pcre version 6.0]) | ||
34 | - ;; | ||
35 | - esac | ||
36 | - AC_MSG_NOTICE([Using external PCRE library from $PCRE_CONFIG]) | ||
37 | - APR_ADDTO(PCRE_INCLUDES, [`$PCRE_CONFIG --cflags`]) | ||
38 | - APR_ADDTO(PCRE_LIBS, [`$PCRE_CONFIG --libs`]) | ||
39 | -else | ||
40 | - AC_MSG_ERROR([pcre-config for libpcre not found. PCRE is required and available from http://pcre.org/]) | ||
41 | -fi | ||
42 | +PKG_CHECK_MODULES([PCRE], [libpcre], [ | ||
43 | + AC_DEFINE([HAVE_PCRE], [1], [Define if you have PCRE library]) | ||
44 | +], [ | ||
45 | + AC_MSG_ERROR([$PCRE_PKG_ERRORS]) | ||
46 | +]) | ||
47 | APACHE_SUBST(PCRE_LIBS) | ||
48 | |||
49 | AC_MSG_NOTICE([]) | ||
50 | -- | ||
51 | 1.9.3 | ||
52 | |||