diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-07-11 16:43:07 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-07-14 12:06:20 -0700 |
commit | 294c0251f83671151c46fe3538e9bad27c0278bd (patch) | |
tree | ee9cf31eebb19613fa9060c979f84be1b330762a /meta-webserver | |
parent | 85132c16210d1bdf83e8be5b3da4f430ce7b4b91 (diff) | |
download | meta-openembedded-294c0251f83671151c46fe3538e9bad27c0278bd.tar.gz |
webmin: Upgrade to 2.111 release
Drop remove-python2.3.patch since corresponding script is gone
License-Update: Formatting changes
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch | 76 | ||||
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/files/mount-excludefs.patch | 7 | ||||
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/files/mysql-config-fix.patch | 7 | ||||
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/files/net-generic.patch | 22 | ||||
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/files/net-lib.pl.patch | 12 | ||||
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/files/remove-python2.3.patch | 25 | ||||
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/webmin_2.111.bb (renamed from meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb) | 8 |
7 files changed, 51 insertions, 106 deletions
diff --git a/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch b/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch index 1ca26ca0d..46b1f7c7b 100644 --- a/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch +++ b/meta-webserver/recipes-webadmin/webmin/files/disable-version-check.patch | |||
@@ -7,58 +7,44 @@ Upstream-Status: Inappropriate | |||
7 | 7 | ||
8 | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> | 8 | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> |
9 | 9 | ||
10 | Index: webmin-1.850/webmin/webmin-lib.pl | 10 | --- a/webmin/webmin-lib.pl |
11 | =================================================================== | 11 | +++ b/webmin/webmin-lib.pl |
12 | --- webmin-1.850.orig/webmin/webmin-lib.pl | 12 | @@ -1170,38 +1170,6 @@ my %miniserv; |
13 | +++ webmin-1.850/webmin/webmin-lib.pl | 13 | &get_miniserv_config(\%miniserv); |
14 | @@ -1112,28 +1112,28 @@ my %miniserv; | ||
15 | &load_theme_library(); # So that UI functions work | 14 | &load_theme_library(); # So that UI functions work |
16 | 15 | ||
17 | # Need OS upgrade | 16 | -# Need OS upgrade, but only once per day or if the system was rebooted |
18 | -my %realos = &detect_operating_system(undef, 1); | 17 | -my $now = time(); |
19 | -if (($realos{'os_version'} ne $gconfig{'os_version'} || | 18 | -my $uptime = &get_system_uptime(); |
20 | - $realos{'os_type'} ne $gconfig{'os_type'}) && | 19 | -if (&foreign_available("webmin")) { |
21 | - $realos{'os_version'} && $realos{'os_type'} && | 20 | - my %realos; |
22 | - &foreign_available("webmin")) { | 21 | - my @st = stat($realos_cache_file); |
23 | - my ($realminor) = split(/\./, $realos{'os_version'}); | 22 | - if (!@st || $now - $st[9] > 24*60*60 || |
24 | - my ($minor) = split(/\./, $gconfig{'os_version'}); | 23 | - $uptime && $now - $st[9] > $uptime) { |
25 | - if ($realos{'os_type'} eq $gconfig{'os_type'} && | 24 | - %realos = &detect_operating_system(undef, 1); |
26 | - $realminor == $minor) { | 25 | - &write_file($realos_cache_file, \%realos); |
27 | - # Only the minor version number changed - no need to apply | ||
28 | - &apply_new_os_version(\%realos); | ||
29 | - } | 26 | - } |
30 | - else { | 27 | - else { |
31 | - # Large enough change to tell the user | 28 | - &read_file($realos_cache_file, \%realos); |
32 | - push(@notifs, | 29 | - } |
33 | - &ui_form_start("$gconfig{'webprefix'}/webmin/fix_os.cgi"). | 30 | - if (($realos{'os_version'} ne $gconfig{'os_version'} || |
34 | - &text('os_incorrect', $realos{'real_os_type'}, | 31 | - $realos{'real_os_version'} ne $gconfig{'real_os_version'} || |
35 | - $realos{'real_os_version'})."<p>\n". | 32 | - $realos{'os_type'} ne $gconfig{'os_type'}) && |
33 | - $realos{'os_version'} && $realos{'os_type'} && | ||
34 | - &foreign_available("webmin")) { | ||
35 | - # Tell the user that OS version was updated | ||
36 | - push(@notifs, | ||
37 | - &ui_form_start("@{[&get_webprefix()]}/webmin/fix_os.cgi"). | ||
38 | - &text('os_incorrect', | ||
39 | - $realos{'real_os_type'}, | ||
40 | - $realos{'real_os_version'}). | ||
41 | - &show_os_release_notes($realos{'real_os_version'}). | ||
42 | - "<p>\n". | ||
36 | - &ui_form_end([ [ undef, $text{'os_fix'} ] ]) | 43 | - &ui_form_end([ [ undef, $text{'os_fix'} ] ]) |
37 | - ); | 44 | - ); |
38 | - } | 45 | - } |
39 | - } | 46 | - } |
40 | +#my %realos = &detect_operating_system(undef, 1); | 47 | - |
41 | +#if (($realos{'os_version'} ne $gconfig{'os_version'} || | ||
42 | +# $realos{'os_type'} ne $gconfig{'os_type'}) && | ||
43 | +# $realos{'os_version'} && $realos{'os_type'} && | ||
44 | +# &foreign_available("webmin")) { | ||
45 | +# my ($realminor) = split(/\./, $realos{'os_version'}); | ||
46 | +# my ($minor) = split(/\./, $gconfig{'os_version'}); | ||
47 | +# if ($realos{'os_type'} eq $gconfig{'os_type'} && | ||
48 | +# $realminor == $minor) { | ||
49 | +# # Only the minor version number changed - no need to apply | ||
50 | +# &apply_new_os_version(\%realos); | ||
51 | +# } | ||
52 | +# else { | ||
53 | +# # Large enough change to tell the user | ||
54 | +# push(@notifs, | ||
55 | +# &ui_form_start("$gconfig{'webprefix'}/webmin/fix_os.cgi"). | ||
56 | +# &text('os_incorrect', $realos{'real_os_type'}, | ||
57 | +# $realos{'real_os_version'})."<p>\n". | ||
58 | +# &ui_form_end([ [ undef, $text{'os_fix'} ] ]) | ||
59 | +# ); | ||
60 | +# } | ||
61 | +# } | ||
62 | |||
63 | # Password close to expiry | 48 | # Password close to expiry |
64 | my $warn_days = $config{'warn_days'}; | 49 | my $warn_days = $config{'warn_days'}; |
50 | if (&foreign_check("acl")) { | ||
diff --git a/meta-webserver/recipes-webadmin/webmin/files/mount-excludefs.patch b/meta-webserver/recipes-webadmin/webmin/files/mount-excludefs.patch index 787bd8c69..7d6a2275f 100644 --- a/meta-webserver/recipes-webadmin/webmin/files/mount-excludefs.patch +++ b/meta-webserver/recipes-webadmin/webmin/files/mount-excludefs.patch | |||
@@ -8,9 +8,9 @@ Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> | |||
8 | 8 | ||
9 | Upstream-Status: Pending | 9 | Upstream-Status: Pending |
10 | 10 | ||
11 | --- webmin-1.570.orig/mount/index.cgi | 11 | --- a/mount/index.cgi |
12 | +++ webmin-1.570/mount/index.cgi | 12 | +++ b/mount/index.cgi |
13 | @@ -33,10 +33,12 @@ elsif ($config{'sort_mode'} == 1) { | 13 | @@ -34,9 +34,11 @@ elsif ($config{'sort_mode'} == 1) { |
14 | } | 14 | } |
15 | 15 | ||
16 | # Build visible filesystems list | 16 | # Build visible filesystems list |
@@ -18,7 +18,6 @@ Upstream-Status: Pending | |||
18 | foreach $m (@all) { | 18 | foreach $m (@all) { |
19 | @minfo = @$m; | 19 | @minfo = @$m; |
20 | $p = &simplify_mount_path($minfo[0], $minfo[2]); | 20 | $p = &simplify_mount_path($minfo[0], $minfo[2]); |
21 | next if ($ignore{$minfo[2]}); | ||
22 | + next if (grep {$_ eq $minfo[2]} @excludefs); | 21 | + next if (grep {$_ eq $minfo[2]} @excludefs); |
23 | @mmodes = &mount_modes($minfo[2], $minfo[0], $minfo[1]); | 22 | @mmodes = &mount_modes($minfo[2], $minfo[0], $minfo[1]); |
24 | $canedit = $can_edit{$minfo[2]} && !$mmodes[4] && | 23 | $canedit = $can_edit{$minfo[2]} && !$mmodes[4] && |
diff --git a/meta-webserver/recipes-webadmin/webmin/files/mysql-config-fix.patch b/meta-webserver/recipes-webadmin/webmin/files/mysql-config-fix.patch index c6c1f0df7..d62353592 100644 --- a/meta-webserver/recipes-webadmin/webmin/files/mysql-config-fix.patch +++ b/meta-webserver/recipes-webadmin/webmin/files/mysql-config-fix.patch | |||
@@ -10,8 +10,6 @@ Signed-off-by: Diego Rondini <diego.ml@zoho.com> | |||
10 | mysql/config | 18 +++++++++--------- | 10 | mysql/config | 18 +++++++++--------- |
11 | 1 file changed, 9 insertions(+), 9 deletions(-) | 11 | 1 file changed, 9 insertions(+), 9 deletions(-) |
12 | 12 | ||
13 | diff --git a/mysql/config b/mysql/config | ||
14 | index e5b6fb3..77bfe69 100644 | ||
15 | --- a/mysql/config | 13 | --- a/mysql/config |
16 | +++ b/mysql/config | 14 | +++ b/mysql/config |
17 | @@ -1,13 +1,13 @@ | 15 | @@ -1,13 +1,13 @@ |
@@ -33,7 +31,7 @@ index e5b6fb3..77bfe69 100644 | |||
33 | -mysqladmin=/usr/local/mysql/bin/mysqladmin | 31 | -mysqladmin=/usr/local/mysql/bin/mysqladmin |
34 | +mysql_libs=/usr/lib | 32 | +mysql_libs=/usr/lib |
35 | +mysqladmin=/usr/bin/mysqladmin | 33 | +mysqladmin=/usr/bin/mysqladmin |
36 | style=0 | 34 | style=1 |
37 | add_mode=1 | 35 | add_mode=1 |
38 | nodbi=0 | 36 | nodbi=0 |
39 | @@ -15,7 +15,7 @@ access=*: * | 37 | @@ -15,7 +15,7 @@ access=*: * |
@@ -45,6 +43,3 @@ index e5b6fb3..77bfe69 100644 | |||
45 | max_dbs=50 | 43 | max_dbs=50 |
46 | my_cnf=/etc/my.cnf | 44 | my_cnf=/etc/my.cnf |
47 | max_text=1000 | 45 | max_text=1000 |
48 | -- | ||
49 | 2.5.0 | ||
50 | |||
diff --git a/meta-webserver/recipes-webadmin/webmin/files/net-generic.patch b/meta-webserver/recipes-webadmin/webmin/files/net-generic.patch index 6ae3dced7..5fd83a429 100644 --- a/meta-webserver/recipes-webadmin/webmin/files/net-generic.patch +++ b/meta-webserver/recipes-webadmin/webmin/files/net-generic.patch | |||
@@ -3,23 +3,19 @@ Add support for configuring network interfaces on a generic linux system | |||
3 | Upstream-Status: Inappropriate [config] | 3 | Upstream-Status: Inappropriate [config] |
4 | 4 | ||
5 | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> | 5 | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> |
6 | Index: webmin-1.850/net/module.info | 6 | --- a/net/module.info |
7 | =================================================================== | 7 | +++ b/net/module.info |
8 | --- webmin-1.850.orig/net/module.info | 8 | @@ -1,7 +1,7 @@ |
9 | +++ webmin-1.850/net/module.info | 9 | version=2.111 |
10 | @@ -14,7 +14,7 @@ desc_ko_KR.UTF-8=네트워크 구성 | 10 | longdesc=Configure boot time and active interfaces, DNS, routing and /etc/hosts. |
11 | name=Networking | 11 | name=Networking |
12 | desc_tr=A Yaplandrmas | ||
13 | desc_de=Netzwerkkonfiguration | ||
14 | -os_support=solaris coherent-linux redhat-linux/5.0-* mandrake-linux united-linux suse-linux/6.0-* open-linux unixware turbo-linux/4.0 freebsd/3.2-* openbsd debian-linux/2.2-* cobalt-linux/2.2-* msc-linux gentoo-linux macos/1.5-* trustix-linux slackware-linux/8.0-* openmamba-linux cygwin windows pardus-linux | 12 | -os_support=solaris coherent-linux redhat-linux/5.0-* mandrake-linux united-linux suse-linux/6.0-* open-linux unixware turbo-linux/4.0 freebsd/3.2-* openbsd debian-linux/2.2-* cobalt-linux/2.2-* msc-linux gentoo-linux macos/1.5-* trustix-linux slackware-linux/8.0-* openmamba-linux cygwin windows pardus-linux |
15 | +os_support=generic-linux solaris coherent-linux redhat-linux/5.0-* mandrake-linux united-linux suse-linux/6.0-* open-linux unixware turbo-linux/4.0 freebsd/3.2-* openbsd debian-linux/2.2-* cobalt-linux/2.2-* msc-linux gentoo-linux macos/1.5-* trustix-linux slackware-linux/8.0-* openmamba-linux cygwin windows pardus-linux | 13 | +os_support=generic-linux solaris coherent-linux redhat-linux/5.0-* mandrake-linux united-linux suse-linux/6.0-* open-linux unixware turbo-linux/4.0 freebsd/3.2-* openbsd debian-linux/2.2-* cobalt-linux/2.2-* msc-linux gentoo-linux macos/1.5-* trustix-linux slackware-linux/8.0-* openmamba-linux cygwin windows pardus-linux |
16 | desc_sk=Konfigurcia siete | 14 | readonly=1 |
17 | desc_zh_CN= | 15 | desc=Network Configuration |
18 | risk=low medium high | 16 | category=net |
19 | Index: webmin-1.850/net/generic-linux-lib.pl | ||
20 | =================================================================== | ||
21 | --- /dev/null | 17 | --- /dev/null |
22 | +++ webmin-1.850/net/generic-linux-lib.pl | 18 | +++ b/net/generic-linux-lib.pl |
23 | @@ -0,0 +1,2 @@ | 19 | @@ -0,0 +1,2 @@ |
24 | +do 'linux-lib.pl'; | 20 | +do 'linux-lib.pl'; |
25 | + | 21 | + |
diff --git a/meta-webserver/recipes-webadmin/webmin/files/net-lib.pl.patch b/meta-webserver/recipes-webadmin/webmin/files/net-lib.pl.patch index bdba5e73f..949525dfd 100644 --- a/meta-webserver/recipes-webadmin/webmin/files/net-lib.pl.patch +++ b/meta-webserver/recipes-webadmin/webmin/files/net-lib.pl.patch | |||
@@ -4,16 +4,14 @@ XXX: need to work out a better fix. | |||
4 | 4 | ||
5 | Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> | 5 | Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> |
6 | 6 | ||
7 | diff -Nru webmin-1.570.orig//net/net-lib.pl webmin-1.570/net/net-lib.pl | 7 | --- a/net/net-lib.pl |
8 | --- webmin-1.570.orig//net/net-lib.pl 2011-10-03 09:01:48.000000000 +0800 | 8 | +++ b/net/net-lib.pl |
9 | +++ webmin-1.570/net/net-lib.pl 2011-10-28 13:52:56.138873664 +0800 | 9 | @@ -38,7 +38,7 @@ elsif ($gconfig{'os_type'} eq 'debian-li |
10 | @@ -21,7 +21,8 @@ | 10 | $net_mode = "netplan"; |
11 | do "$gconfig{'os_type'}-9.1-ALL-lib.pl"; | ||
12 | } | 11 | } |
13 | else { | 12 | else { |
14 | - do "$gconfig{'os_type'}-lib.pl"; | 13 | - do "$gconfig{'os_type'}-lib.pl"; |
15 | + #do "$gconfig{'os_type'}-lib.pl"; | ||
16 | + do "debian-linux-lib.pl"; | 14 | + do "debian-linux-lib.pl"; |
15 | $net_mode = $gconfig{'os_type'}; | ||
17 | } | 16 | } |
18 | 17 | ||
19 | # list_hosts() | ||
diff --git a/meta-webserver/recipes-webadmin/webmin/files/remove-python2.3.patch b/meta-webserver/recipes-webadmin/webmin/files/remove-python2.3.patch deleted file mode 100644 index 75e5bd1ea..000000000 --- a/meta-webserver/recipes-webadmin/webmin/files/remove-python2.3.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From 6f04699d5d417122b67e8118fd1955c769f17e76 Mon Sep 17 00:00:00 2001 | ||
2 | From: Robert Yang <liezhi.yang@windriver.com> | ||
3 | Date: Tue, 2 Sep 2014 00:11:05 -0700 | ||
4 | Subject: [PATCH] ajaxterm/ajaxterm/qweb.py: fix hardcode of python2.3 | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> | ||
9 | --- | ||
10 | ajaxterm/ajaxterm/qweb.py | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/ajaxterm/ajaxterm/qweb.py b/ajaxterm/ajaxterm/qweb.py | ||
14 | index 20c5092..c658a6b 100644 | ||
15 | --- a/ajaxterm/ajaxterm/qweb.py | ||
16 | +++ b/ajaxterm/ajaxterm/qweb.py | ||
17 | @@ -1,4 +1,4 @@ | ||
18 | -#!/usr/bin/python2.3 | ||
19 | +#!/usr/bin/env python | ||
20 | # | ||
21 | # vim:set et ts=4 fdc=0 fdn=2 fdl=0: | ||
22 | # | ||
23 | -- | ||
24 | 1.7.9.5 | ||
25 | |||
diff --git a/meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb b/meta-webserver/recipes-webadmin/webmin/webmin_2.111.bb index bbc59443c..6058afb8c 100644 --- a/meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb +++ b/meta-webserver/recipes-webadmin/webmin/webmin_2.111.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | SUMMARY = "Web-based administration interface" | 1 | SUMMARY = "Web-based administration interface" |
2 | HOMEPAGE = "http://www.webmin.com" | 2 | HOMEPAGE = "http://www.webmin.com" |
3 | LICENSE = "BSD-3-Clause" | 3 | LICENSE = "BSD-3-Clause" |
4 | LIC_FILES_CHKSUM = "file://LICENCE;md5=0373ac9f611e542ddebe1ec6394afc3c" | 4 | LIC_FILES_CHKSUM = "file://LICENCE;md5=0a6446108c96d0819d21e40b48109507" |
5 | 5 | ||
6 | SRC_URI = "${SOURCEFORGE_MIRROR}/webadmin/webmin-${PV}.tar.gz \ | 6 | SRC_URI = "${SOURCEFORGE_MIRROR}/webadmin/webmin-${PV}.tar.gz \ |
7 | file://setup.sh \ | 7 | file://setup.sh \ |
@@ -16,14 +16,10 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/webadmin/webmin-${PV}.tar.gz \ | |||
16 | file://proftpd-config-fix.patch \ | 16 | file://proftpd-config-fix.patch \ |
17 | file://net-lib.pl.patch \ | 17 | file://net-lib.pl.patch \ |
18 | file://media-tomb.patch \ | 18 | file://media-tomb.patch \ |
19 | file://remove-python2.3.patch \ | ||
20 | file://mysql-config-fix.patch \ | 19 | file://mysql-config-fix.patch \ |
21 | file://webmin.service \ | 20 | file://webmin.service \ |
22 | " | 21 | " |
23 | 22 | SRC_URI[sha256sum] = "9000ce55275494802ec433e2de634289989f5d99ea2970716d7d9c97e38f2f5e" | |
24 | SRC_URI[md5sum] = "cd6ee98f73f9418562197675b952d81b" | ||
25 | SRC_URI[sha256sum] = "c66caa9e4cb50d5447bc8aceb7989d2284dde060278f404b13e171c7ce1690e1" | ||
26 | |||
27 | UPSTREAM_CHECK_URI = "http://www.webmin.com/download.html" | 23 | UPSTREAM_CHECK_URI = "http://www.webmin.com/download.html" |
28 | UPSTREAM_CHECK_REGEX = "webmin-(?P<pver>\d+(\.\d+)+).tar.gz" | 24 | UPSTREAM_CHECK_REGEX = "webmin-(?P<pver>\d+(\.\d+)+).tar.gz" |
29 | 25 | ||