summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-03-10 16:12:13 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-21 16:42:22 +0100
commite9e68c43d890c7121130df3e388bf21200935381 (patch)
treec1b5a6e950ddbf05ba93379600f9809c036af2a6 /meta-webserver
parentca5d383441f2d2eceb608b864b28b26cb4f70f53 (diff)
downloadmeta-openembedded-e9e68c43d890c7121130df3e388bf21200935381.tar.gz
spawn-fcgi: add initial recipe
Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi-1.6.4/fix_configure_ipv6_test.patch35
-rw-r--r--meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi_1.6.4.bb16
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi-1.6.4/fix_configure_ipv6_test.patch b/meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi-1.6.4/fix_configure_ipv6_test.patch
new file mode 100644
index 000000000..9409dd2b1
--- /dev/null
+++ b/meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi-1.6.4/fix_configure_ipv6_test.patch
@@ -0,0 +1,35 @@
1Testing for IPv6 support got broken by configure.ac changes in 1.6.4
2As a temp workaround, revert back to the 1.6.3 version.
3
4Upstream-Status: Pending
5
6--- spawn-fcgi-1.6.4/configure.ac
7+++ spawn-fcgi-1.6.3/configure.ac
8@@ -66,8 +47,8 @@
9 # Check for IPv6 support
10
11 AC_ARG_ENABLE(ipv6,
12- AC_HELP_STRING([--disable-ipv6],[disable IPv6 support]),
13- [case "${enableval}" in
14+ AC_HELP_STRING([--disable-ipv6],[disable IPv6 support]),
15+ [case "${enableval}" in
16 yes) ipv6=true ;;
17 no) ipv6=false ;;
18 *) AC_MSG_ERROR(bad value ${enableval} for --enable-ipv6) ;;
19@@ -75,13 +56,10 @@
20
21 if test x$ipv6 = xtrue; then
22 AC_CACHE_CHECK([for IPv6 support], ac_cv_ipv6_support,
23- [AC_TRY_LINK([[
24-#include <sys/types.h>
25+ [AC_TRY_LINK([ #include <sys/types.h>
26 #include <sys/socket.h>
27-#include <netinet/in.h>
28- ]], [[
29-struct sockaddr_in6 s; struct in6_addr t=in6addr_any; int i=AF_INET6; s; t.s6_addr[0] = 0;
30- ]], [ac_cv_ipv6_support=yes], [ac_cv_ipv6_support=no])])
31+#include <netinet/in.h>], [struct sockaddr_in6 s; struct in6_addr t=in6addr_any; int i=AF_INET6; s; t.s6_addr[0] = 0; ],
32+ [ac_cv_ipv6_support=yes], [ac_cv_ipv6_support=no])])
33
34 if test "$ac_cv_ipv6_support" = yes; then
35 AC_DEFINE(HAVE_IPV6,1,[Whether to enable IPv6 support])
diff --git a/meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi_1.6.4.bb b/meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi_1.6.4.bb
new file mode 100644
index 000000000..99e58bd8b
--- /dev/null
+++ b/meta-webserver/recipes-support/spawn-fcgi/spawn-fcgi_1.6.4.bb
@@ -0,0 +1,16 @@
1SUMMARRY = "spawn-fcgi is used to spawn FastCGI applications"
2HOMEPAGE = "http://redmine.lighttpd.net/projects/spawn-fcgi"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
6
7SRC_URI = "http://download.lighttpd.net/spawn-fcgi/releases-1.6.x/spawn-fcgi-${PV}.tar.gz \
8 file://fix_configure_ipv6_test.patch"
9
10SRC_URI[md5sum] = "e970de4efe8045c01dd76280f39901aa"
11SRC_URI[sha256sum] = "ab327462cb99894a3699f874425a421d934f957cb24221f00bb888108d9dd09e"
12
13inherit autotools
14
15PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
16PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"