summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:51 +0100
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:03 -0700
commit9078b0df2026fcf9d2ed287cb713b76907ae7087 (patch)
treee603cfb97abea31fef07a5e03dafc109b2721521 /meta-webserver
parentcf1819332d48d3307aa2e80255834aa7911cd0dc (diff)
downloadmeta-openembedded-9078b0df2026fcf9d2ed287cb713b76907ae7087.tar.gz
meta-webserver: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb4
-rw-r--r--meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb4
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb2
-rw-r--r--meta-webserver/recipes-httpd/monkey/monkey_1.5.6.bb2
-rw-r--r--meta-webserver/recipes-httpd/nginx/nginx.inc2
-rw-r--r--meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb2
6 files changed, 8 insertions, 8 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
index df2503421..81151d1a4 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
@@ -57,7 +57,7 @@ EXTRA_OECONF = "--enable-ssl \
57 --enable-mpms-shared \ 57 --enable-mpms-shared \
58 ac_cv_have_threadsafe_pollset=no" 58 ac_cv_have_threadsafe_pollset=no"
59 59
60PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}" 60PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
61PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux" 61PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
62PACKAGECONFIG[openldap] = "--enable-ldap --enable-authnz-ldap,--disable-ldap --disable-authnz-ldap,openldap" 62PACKAGECONFIG[openldap] = "--enable-ldap --enable-authnz-ldap,--disable-ldap --disable-authnz-ldap,openldap"
63 63
@@ -86,7 +86,7 @@ do_install_append() {
86 # Set 'ServerName' to fix error messages when restart apache service 86 # Set 'ServerName' to fix error messages when restart apache service
87 sed -i 's/^#ServerName www.example.com/ServerName localhost/' ${D}/${sysconfdir}/${BPN}/httpd.conf 87 sed -i 's/^#ServerName www.example.com/ServerName localhost/' ${D}/${sysconfdir}/${BPN}/httpd.conf
88 88
89 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 89 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
90 install -d ${D}${sysconfdir}/tmpfiles.d/ 90 install -d ${D}${sysconfdir}/tmpfiles.d/
91 install -m 0644 ${WORKDIR}/apache2-volatile.conf ${D}${sysconfdir}/tmpfiles.d/ 91 install -m 0644 ${WORKDIR}/apache2-volatile.conf ${D}${sysconfdir}/tmpfiles.d/
92 fi 92 fi
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
index 451e97cb7..5287ea42c 100644
--- a/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
+++ b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7 7
8PR = "r9" 8PR = "r9"
9 9
10DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" 10DEPENDS = "libpcre openssl mysql5 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
11 11
12SRC_URI = "http://www.cherokee-project.de/mirrors/cherokee/1.2/${PV}/cherokee-${PV}.tar.gz \ 12SRC_URI = "http://www.cherokee-project.de/mirrors/cherokee/1.2/${PV}/cherokee-${PV}.tar.gz \
13 file://cherokee.init \ 13 file://cherokee.init \
@@ -26,7 +26,7 @@ PACKAGECONFIG[geoip] = "--with-geoip,--without-geoip,geoip"
26 26
27EXTRA_OECONF = "--disable-static \ 27EXTRA_OECONF = "--disable-static \
28 --disable-nls \ 28 --disable-nls \
29 ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \ 29 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
30 --with-wwwroot=${localstatedir}/www/cherokee \ 30 --with-wwwroot=${localstatedir}/www/cherokee \
31" 31"
32 32
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb
index 31293e48f..706217479 100644
--- a/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb
+++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb
@@ -48,7 +48,7 @@ do_install_append() {
48 # by default if php is installed 48 # by default if php is installed
49 echo "Server = ${bindir}/php-cgi ; 2 ; 127.0.0.1:2005 ; nobody:nobody ; ${sysconfdir}/php/hiawatha-php5/php.ini" >> ${D}${sysconfdir}/hiawatha/php-fcgi.conf 49 echo "Server = ${bindir}/php-cgi ; 2 ; 127.0.0.1:2005 ; nobody:nobody ; ${sysconfdir}/php/hiawatha-php5/php.ini" >> ${D}${sysconfdir}/hiawatha/php-fcgi.conf
50 50
51 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then 51 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
52 install -d ${D}/${systemd_unitdir}/system 52 install -d ${D}/${systemd_unitdir}/system
53 install -m 644 ${WORKDIR}/hiawatha.service ${D}/${systemd_unitdir}/system 53 install -m 644 ${WORKDIR}/hiawatha.service ${D}/${systemd_unitdir}/system
54 fi 54 fi
diff --git a/meta-webserver/recipes-httpd/monkey/monkey_1.5.6.bb b/meta-webserver/recipes-httpd/monkey/monkey_1.5.6.bb
index 22d88f8e9..be8ed37b9 100644
--- a/meta-webserver/recipes-httpd/monkey/monkey_1.5.6.bb
+++ b/meta-webserver/recipes-httpd/monkey/monkey_1.5.6.bb
@@ -58,7 +58,7 @@ do_install_append() {
58 mkdir -p ${D}${sysconfdir}/init.d 58 mkdir -p ${D}${sysconfdir}/init.d
59 install -m 0755 ${WORKDIR}/monkey.init ${D}${sysconfdir}/init.d/monkey 59 install -m 0755 ${WORKDIR}/monkey.init ${D}${sysconfdir}/init.d/monkey
60 60
61 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then 61 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
62 install -d ${D}${systemd_unitdir}/system 62 install -d ${D}${systemd_unitdir}/system
63 install -m 644 ${WORKDIR}/monkey.service ${D}/${systemd_unitdir}/system 63 install -m 644 ${WORKDIR}/monkey.service ${D}/${systemd_unitdir}/system
64 fi 64 fi
diff --git a/meta-webserver/recipes-httpd/nginx/nginx.inc b/meta-webserver/recipes-httpd/nginx/nginx.inc
index 2169b67c5..ebf926a20 100644
--- a/meta-webserver/recipes-httpd/nginx/nginx.inc
+++ b/meta-webserver/recipes-httpd/nginx/nginx.inc
@@ -66,7 +66,7 @@ do_configure () {
66do_install () { 66do_install () {
67 oe_runmake 'DESTDIR=${D}' install 67 oe_runmake 'DESTDIR=${D}' install
68 rm -fr ${D}${localstatedir}/run ${D}/run 68 rm -fr ${D}${localstatedir}/run ${D}/run
69 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 69 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
70 install -d ${D}${sysconfdir}/tmpfiles.d 70 install -d ${D}${sysconfdir}/tmpfiles.d
71 echo "d /run/${BPN} - - - -" \ 71 echo "d /run/${BPN} - - - -" \
72 > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf 72 > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
diff --git a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
index fe860ec9a..562ecd004 100644
--- a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
+++ b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
@@ -46,7 +46,7 @@ do_install() {
46 install -m 0644 ${WORKDIR}/nhttpd.conf ${D}${sysconfdir} 46 install -m 0644 ${WORKDIR}/nhttpd.conf ${D}${sysconfdir}
47 install -m 0755 ${WORKDIR}/nostromo ${D}${sysconfdir}/init.d 47 install -m 0755 ${WORKDIR}/nostromo ${D}${sysconfdir}/init.d
48 install -D -m 0644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/nostromo 48 install -D -m 0644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/nostromo
49 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 49 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
50 install -D -m 0644 ${WORKDIR}/tmpfiles.conf ${D}${sysconfdir}/tmpfiles.d/nostromo.conf 50 install -D -m 0644 ${WORKDIR}/tmpfiles.conf ${D}${sysconfdir}/tmpfiles.d/nostromo.conf
51 fi 51 fi
52 install -m 0644 htdocs/index.html ${D}${localstatedir}/nostromo/htdocs/index.html 52 install -m 0644 htdocs/index.html ${D}${localstatedir}/nostromo/htdocs/index.html