summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorEmmanuel Roullit <emmanuel.roullit@gmail.com>2020-05-04 20:35:33 +0200
committerKhem Raj <raj.khem@gmail.com>2020-05-04 14:03:55 -0700
commiteaf4a9d8a770cc0d1a19a5866a33ce25cba065ce (patch)
tree0be60bef485e990d0d0409d411b24ddf70370758 /meta-webserver
parent7d137c5b21913e7d86851124f8f259dff409f9ed (diff)
downloadmeta-openembedded-eaf4a9d8a770cc0d1a19a5866a33ce25cba065ce.tar.gz
cockpit: fix metainfo.xml file ownership
The 'tar -cf - | tar -xf' combo applies an invalid ownership. This is corrected by patching the install target to use the --no-same-owner tar parameter. Signed-off-by: Emmanuel Roullit <emmanuel.roullit@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/cockpit_218.bb4
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/files/0003-install-fix-metainfo.xml-ownership-on-install.patch30
2 files changed, 31 insertions, 3 deletions
diff --git a/meta-webserver/recipes-webadmin/cockpit/cockpit_218.bb b/meta-webserver/recipes-webadmin/cockpit/cockpit_218.bb
index 863793a21..4ddffb4bd 100644
--- a/meta-webserver/recipes-webadmin/cockpit/cockpit_218.bb
+++ b/meta-webserver/recipes-webadmin/cockpit/cockpit_218.bb
@@ -8,6 +8,7 @@ SRC_URI += " \
8 https://github.com/cockpit-project/cockpit/releases/download/${PV}/cockpit-${PV}.tar.xz \ 8 https://github.com/cockpit-project/cockpit/releases/download/${PV}/cockpit-${PV}.tar.xz \
9 file://0001-remove-tests-dep-on-gobject-intro.patch \ 9 file://0001-remove-tests-dep-on-gobject-intro.patch \
10 file://0002-fix-makefile-use-copy-rule-for-unmodified-files.patch \ 10 file://0002-fix-makefile-use-copy-rule-for-unmodified-files.patch \
11 file://0003-install-fix-metainfo.xml-ownership-on-install.patch \
11 file://cockpit.pam \ 12 file://cockpit.pam \
12 " 13 "
13SRC_URI[md5sum] = "e69b0b8a75a5d55ddfd9817d857c71af" 14SRC_URI[md5sum] = "e69b0b8a75a5d55ddfd9817d857c71af"
@@ -165,9 +166,6 @@ RDEPENDS_${PN} += "${PN}-bridge"
165do_install_append() { 166do_install_append() {
166 pkgdatadir=${datadir}/cockpit 167 pkgdatadir=${datadir}/cockpit
167 168
168 # avoid host contamination
169 find ${D}${datadir}/cockpit -name manifest.json -exec chown root:root {} \;
170
171 chmod 4750 ${D}${libexecdir}/cockpit-session 169 chmod 4750 ${D}${libexecdir}/cockpit-session
172 170
173 install -d "${D}${sysconfdir}/pam.d" 171 install -d "${D}${sysconfdir}/pam.d"
diff --git a/meta-webserver/recipes-webadmin/cockpit/files/0003-install-fix-metainfo.xml-ownership-on-install.patch b/meta-webserver/recipes-webadmin/cockpit/files/0003-install-fix-metainfo.xml-ownership-on-install.patch
new file mode 100644
index 000000000..b967b1c0a
--- /dev/null
+++ b/meta-webserver/recipes-webadmin/cockpit/files/0003-install-fix-metainfo.xml-ownership-on-install.patch
@@ -0,0 +1,30 @@
1From e56f2b294ca8c805bfd3d715d523bef188c54cb1 Mon Sep 17 00:00:00 2001
2From: Emmanuel Roullit <emmanuel.roullit@gmail.com>
3Date: Sat, 2 May 2020 14:05:35 +0200
4Subject: [PATCH] install: fix metainfo.xml ownership on install
5
6Signed-off-by: Emmanuel Roullit <emmanuel.roullit@gmail.com>
7---
8 Makefile.am | 4 ++--
9 1 file changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/Makefile.am b/Makefile.am
12index d9f918e99..9a23e0a7b 100644
13--- a/Makefile.am
14+++ b/Makefile.am
15@@ -226,10 +226,10 @@ maintainer-clean-local::
16
17 install-data-local:: $(WEBPACK_INSTALL)
18 $(MKDIR_P) $(DESTDIR)$(pkgdatadir)
19- tar -cf - $^ | tar -C $(DESTDIR)$(pkgdatadir) --strip-components=1 -xvf -
20+ tar -cf - $^ | tar --no-same-owner -C $(DESTDIR)$(pkgdatadir) --strip-components=1 -xvf -
21 install-data-local:: $(WEBPACK_DEBUG)
22 $(MKDIR_P) $(DESTDIR)$(debugdir)$(pkgdatadir)
23- tar -cf - $^ | tar -C $(DESTDIR)$(debugdir)$(pkgdatadir) --strip-components=1 -xvf -
24+ tar -cf - $^ | tar --no-same-owner -C $(DESTDIR)$(debugdir)$(pkgdatadir) --strip-components=1 -xvf -
25 uninstall-local::
26 find $(DESTDIR)$(pkgdatadir) -ignore_readdir_race -type f -exec rm -f {} \;
27 find $(DESTDIR)$(pkgdatadir) -ignore_readdir_race -type d -empty -delete
28--
292.17.1
30