summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2020-05-14 16:03:56 +0800
committerKhem Raj <raj.khem@gmail.com>2020-05-14 10:43:48 -0700
commite789c3837ca8d65abb4bac29dc2e5c595c8ce05b (patch)
tree7ef30015c8db90b1d1a2303781abf1f1201c28e2 /meta-webserver
parent337094167094536a40d94d3ee74e6355d8fbf2dd (diff)
downloadmeta-openembedded-e789c3837ca8d65abb4bac29dc2e5c595c8ce05b.tar.gz
apache2: fix service start fail
reproduce steps: 1. boot up target 2. scp apache2-2.4.41-r0.1.aarch64.rpm on target 3. rpm -i apache2-2.4.41-r0.1.aarch64.rpm 4. systemctl status apache2 Error: httpd[7767]: (2)No such file or directory: AH02291: Cannot access directory '/var/log/apache2/' for main error log with the old way, /var/log/apache2/ is created by service systemd-tmpfiles-setup during boot, so only works when apache2 already installed before boot, in above scenario, /var/log/apache2/ will not created. fix by creating it in the service file. similar fix for sysV system Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.43.bb8
-rw-r--r--meta-webserver/recipes-httpd/apache2/files/apache2-volatile.conf2
-rw-r--r--meta-webserver/recipes-httpd/apache2/files/apache2.service4
-rw-r--r--meta-webserver/recipes-httpd/apache2/files/init5
-rw-r--r--meta-webserver/recipes-httpd/apache2/files/volatiles.04_apache23
5 files changed, 9 insertions, 13 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.43.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.43.bb
index 520011152..9b80bbff6 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.43.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.43.bb
@@ -20,9 +20,7 @@ SRC_URI = "${APACHE_MIRROR}/httpd/httpd-${PV}.tar.bz2 \
20SRC_URI_append_class-target = " \ 20SRC_URI_append_class-target = " \
21 file://0008-apache2-do-not-use-relative-path-for-gen_test_char.patch \ 21 file://0008-apache2-do-not-use-relative-path-for-gen_test_char.patch \
22 file://init \ 22 file://init \
23 file://apache2-volatile.conf \
24 file://apache2.service \ 23 file://apache2.service \
25 file://volatiles.04_apache2 \
26 " 24 "
27 25
28LIC_FILES_CHKSUM = "file://LICENSE;md5=bddeddfac80b2c9a882241d008bb41c3" 26LIC_FILES_CHKSUM = "file://LICENSE;md5=bddeddfac80b2c9a882241d008bb41c3"
@@ -128,16 +126,10 @@ do_install_append_class-target() {
128 -e 's,".*/configure","configure",g' ${D}${datadir}/apache2/build/config.nice 126 -e 's,".*/configure","configure",g' ${D}${datadir}/apache2/build/config.nice
129 127
130 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 128 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
131 install -d ${D}${sysconfdir}/tmpfiles.d/
132 install -m 0644 ${WORKDIR}/apache2-volatile.conf ${D}${sysconfdir}/tmpfiles.d/
133
134 install -d ${D}${systemd_unitdir}/system 129 install -d ${D}${systemd_unitdir}/system
135 install -m 0644 ${WORKDIR}/apache2.service ${D}${systemd_unitdir}/system 130 install -m 0644 ${WORKDIR}/apache2.service ${D}${systemd_unitdir}/system
136 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/apache2.service 131 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/apache2.service
137 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' ${D}${systemd_unitdir}/system/apache2.service 132 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' ${D}${systemd_unitdir}/system/apache2.service
138 elif ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
139 install -d ${D}${sysconfdir}/default/volatiles
140 install -m 0644 ${WORKDIR}/volatiles.04_apache2 ${D}${sysconfdir}/default/volatiles/04_apache2
141 fi 133 fi
142 134
143 rm -rf ${D}${localstatedir} ${D}${sbindir}/envvars* 135 rm -rf ${D}${localstatedir} ${D}${sbindir}/envvars*
diff --git a/meta-webserver/recipes-httpd/apache2/files/apache2-volatile.conf b/meta-webserver/recipes-httpd/apache2/files/apache2-volatile.conf
deleted file mode 100644
index ff2c58704..000000000
--- a/meta-webserver/recipes-httpd/apache2/files/apache2-volatile.conf
+++ /dev/null
@@ -1,2 +0,0 @@
1d /var/run/apache2 0755 root root -
2d /var/log/apache2 0755 root root -
diff --git a/meta-webserver/recipes-httpd/apache2/files/apache2.service b/meta-webserver/recipes-httpd/apache2/files/apache2.service
index 9b5548c76..25d43acf8 100644
--- a/meta-webserver/recipes-httpd/apache2/files/apache2.service
+++ b/meta-webserver/recipes-httpd/apache2/files/apache2.service
@@ -5,6 +5,10 @@ After=network.target remote-fs.target nss-lookup.target
5[Service] 5[Service]
6Type=simple 6Type=simple
7Environment=LANG=C 7Environment=LANG=C
8ExecStartPre=mkdir -p /var/log/apache2
9ExecStartPre=mkdir -p /var/run/apache2
10ExecStartPre=chmod -R 0755 /var/log/apache2
11ExecStartPre=chmod -R 0755 /var/run/apache2
8ExecStart=@SBINDIR@/httpd -DFOREGROUND -D SSL -D PHP5 -k start 12ExecStart=@SBINDIR@/httpd -DFOREGROUND -D SSL -D PHP5 -k start
9ExecStop=@BASE_BINDIR@/kill -WINCH ${MAINPID} 13ExecStop=@BASE_BINDIR@/kill -WINCH ${MAINPID}
10KillSignal=SIGCONT 14KillSignal=SIGCONT
diff --git a/meta-webserver/recipes-httpd/apache2/files/init b/meta-webserver/recipes-httpd/apache2/files/init
index 758d133b9..80a7ebfcb 100644
--- a/meta-webserver/recipes-httpd/apache2/files/init
+++ b/meta-webserver/recipes-httpd/apache2/files/init
@@ -97,6 +97,11 @@ do_start()
97 return 1 97 return 1
98 fi 98 fi
99 99
100 mkdir -p /var/log/apache2
101 chmod -R 0755 /var/log/apache2
102 mkdir -p /var/run/apache2
103 chmod -R 0755 /var/run/apache2
104
100 if apache_conftest ; then 105 if apache_conftest ; then
101 $APACHECTL start 106 $APACHECTL start
102 apache_wait_start $? 107 apache_wait_start $?
diff --git a/meta-webserver/recipes-httpd/apache2/files/volatiles.04_apache2 b/meta-webserver/recipes-httpd/apache2/files/volatiles.04_apache2
deleted file mode 100644
index 922075b1b..000000000
--- a/meta-webserver/recipes-httpd/apache2/files/volatiles.04_apache2
+++ /dev/null
@@ -1,3 +0,0 @@
1# <type> <owner> <group> <mode> <path> <linksource>
2d root root 0755 /var/run/apache2 none
3d root root 0755 /var/log/apache2 none