diff options
author | Eric Bénard <eric@eukrea.com> | 2012-11-25 18:25:10 +0100 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-11-27 10:48:24 +0000 |
commit | e4236266b7ac6103e4b9400eb51b5cb0037f3ba9 (patch) | |
tree | d5d22219c82d93b9d7312c8b774ae396b95d7196 /meta-webserver | |
parent | 9439d8132a0f936dfb7cefb73fa0a1c582826e4b (diff) | |
download | meta-openembedded-e4236266b7ac6103e4b9400eb51b5cb0037f3ba9.tar.gz |
hiawatha: add CONFFILES and a php example
- add CONFFILES so that configuration files don't get overwritten
during upgrade
- add an example on how to launch php-cgi using php-fcgi
Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb | 14 |
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb index 2e6955e99..7dcbe9ed9 100644 --- a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb +++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb | |||
@@ -4,6 +4,8 @@ LICENSE = "GPLv2" | |||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" |
5 | DEPENDS = "libxml2 libxslt" | 5 | DEPENDS = "libxml2 libxslt" |
6 | 6 | ||
7 | PR = "r1" | ||
8 | |||
7 | SECTION = "net" | 9 | SECTION = "net" |
8 | 10 | ||
9 | SRC_URI = "http://hiawatha-webserver.org/files/${PN}-${PV}.tar.gz \ | 11 | SRC_URI = "http://hiawatha-webserver.org/files/${PN}-${PV}.tar.gz \ |
@@ -36,10 +38,20 @@ EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \ | |||
36 | -DWORK_DIR=/var/lib/hiawatha " | 38 | -DWORK_DIR=/var/lib/hiawatha " |
37 | 39 | ||
38 | do_install_append() { | 40 | do_install_append() { |
39 | |||
40 | # Copy over init script and sed in the correct sbin path | 41 | # Copy over init script and sed in the correct sbin path |
41 | sed -i 's,sed_sbin_path,${sbindir},' ${WORKDIR}/hiawatha-init | 42 | sed -i 's,sed_sbin_path,${sbindir},' ${WORKDIR}/hiawatha-init |
42 | mkdir -p ${D}${sysconfdir}/init.d | 43 | mkdir -p ${D}${sysconfdir}/init.d |
43 | install -m 0755 ${WORKDIR}/hiawatha-init ${D}${sysconfdir}/init.d/hiawatha | 44 | install -m 0755 ${WORKDIR}/hiawatha-init ${D}${sysconfdir}/init.d/hiawatha |
44 | 45 | ||
46 | # configure php-fcgi to have a working configuration | ||
47 | # by default if php is installed | ||
48 | echo "Server = ${bindir}/php-cgi ; 2 ; 127.0.0.1:2005 ; nobody:nobody ; ${sysconfdir}/php/hiawatha-php5/php.ini" >> ${D}${sysconfdir}/hiawatha/php-fcgi.conf | ||
45 | } | 49 | } |
50 | |||
51 | CONFFILES_${PN} = " \ | ||
52 | ${sysconfdir}/hiawatha/cgi-wrapper.conf \ | ||
53 | ${sysconfdir}/hiawatha/hiawatha.conf \ | ||
54 | ${sysconfdir}/hiawatha/index.xslt \ | ||
55 | ${sysconfdir}/hiawatha/mimetype.conf \ | ||
56 | ${sysconfdir}/hiawatha/php-fcgi.conf \ | ||
57 | " | ||