summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2013-01-25 18:10:50 +0800
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-01-25 18:20:24 +0000
commitd4051ea47c3842f7acb1ba1d8eb688d275ace11f (patch)
tree716ebced4dc56f5d592bc8f558bb9ad5fd6150a0 /meta-webserver
parente2012416a6588215ad07ce5575dbd15f149bf20c (diff)
downloadmeta-openembedded-d4051ea47c3842f7acb1ba1d8eb688d275ace11f.tar.gz
apache2: fix the race issue of parallel installation
fix following race issue when do parallel install | mkdir: cannot create directory `/home/mypc/workspace/poky/build_p4080ds_release/tmp/work/ppce500mc-fsl_networking-linux/apache2/2.4.3-r1/image/usr/share/apache2': File exists ... | mkdir: cannot create directory `/home/mypc/workspace/poky/build_p4080ds_release/tmp/work/ppce500mc-fsl_networking-linux/apache2/2.4.3-r1/image/usr/share/apache2': File exists | make[1]: *** [install-man] Error 1 | make[1]: *** Waiting for unfinished jobs.... Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb3
-rw-r--r--meta-webserver/recipes-httpd/apache2/files/httpd-2.4.3-fix-race-issue-of-dir-install.patch21
2 files changed, 23 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
index 9179bcacb..a221e1da7 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://httpd.apache.org/"
5DEPENDS = "libtool-native apache2-native openssl expat pcre apr apr-util" 5DEPENDS = "libtool-native apache2-native openssl expat pcre apr apr-util"
6SECTION = "net" 6SECTION = "net"
7LICENSE = "Apache-2.0" 7LICENSE = "Apache-2.0"
8PR = "r0" 8PR = "r1"
9 9
10SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \ 10SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \
11 file://server-makefile.patch \ 11 file://server-makefile.patch \
@@ -16,6 +16,7 @@ SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \
16 file://apache-configure_perlbin.patch \ 16 file://apache-configure_perlbin.patch \
17 file://replace-lynx-to-curl-in-apachectl-script.patch \ 17 file://replace-lynx-to-curl-in-apachectl-script.patch \
18 file://apache-ssl-ltmain-rpath.patch \ 18 file://apache-ssl-ltmain-rpath.patch \
19 file://httpd-2.4.3-fix-race-issue-of-dir-install.patch \
19 file://init" 20 file://init"
20 21
21LIC_FILES_CHKSUM = "file://LICENSE;md5=eff226ae95d0516d6210ed77dfdf2dcc" 22LIC_FILES_CHKSUM = "file://LICENSE;md5=eff226ae95d0516d6210ed77dfdf2dcc"
diff --git a/meta-webserver/recipes-httpd/apache2/files/httpd-2.4.3-fix-race-issue-of-dir-install.patch b/meta-webserver/recipes-httpd/apache2/files/httpd-2.4.3-fix-race-issue-of-dir-install.patch
new file mode 100644
index 000000000..b948753b4
--- /dev/null
+++ b/meta-webserver/recipes-httpd/apache2/files/httpd-2.4.3-fix-race-issue-of-dir-install.patch
@@ -0,0 +1,21 @@
1Upstream-Status: Pending
2
3fix following race issue when do parallel install
4| mkdir: cannot create directory `/home/mypc/workspace/poky/build_p4080ds_release/tmp/work/ppce500mc-fsl_networking-linux/apache2/2.4.3-r1/image/usr/share/apache2': File exists
5...
6| mkdir: cannot create directory `/home/mypc/workspace/poky/build_p4080ds_release/tmp/work/ppce500mc-fsl_networking-linux/apache2/2.4.3-r1/image/usr/share/apache2': File exists
7| make[1]: *** [install-man] Error 1
8| make[1]: *** Waiting for unfinished jobs....
9
10-Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
11--- httpd-2.4.3/build/mkdir.sh.orig 2013-01-25 03:47:21.565255420 -0600
12+++ httpd-2.4.3/build/mkdir.sh 2013-01-25 03:46:17.833051230 -0600
13@@ -39,7 +39,7 @@
14 esac
15 if test ! -d "$pathcomp"; then
16 echo "mkdir $pathcomp" 1>&2
17- mkdir "$pathcomp" || errstatus=$?
18+ mkdir -p "$pathcomp" || errstatus=$?
19 fi
20 pathcomp="$pathcomp/"
21 done