summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-04-22 09:35:40 +0100
committerEric BĂ©nard <eric@eukrea.com>2013-04-30 21:25:09 +0200
commitcca735e1eba4e32f9a74eec953a7308f9cad9b5a (patch)
tree71547934d896370c420ed2b0ef89606d2e8feffb /meta-webserver
parent6cbeee15372c911b54df13973417eab54234bbb4 (diff)
downloadmeta-openembedded-cca735e1eba4e32f9a74eec953a7308f9cad9b5a.tar.gz
apache2: fix multilib builds
Change PN -> BPN in a number of places so that files are stored in the correct location and packaged correctly. Based on a patch by Song.Li <Song.Li@windriver.com> with additional PN -> BPN replacements. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb67
1 files changed, 33 insertions, 34 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
index a7f358666..5589f1f2e 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
@@ -38,13 +38,13 @@ EXTRA_OECONF = "--enable-ssl \
38 --enable-rewrite \ 38 --enable-rewrite \
39 --with-dbm=sdbm \ 39 --with-dbm=sdbm \
40 --with-berkeley-db=no \ 40 --with-berkeley-db=no \
41 --localstatedir=/var/${PN} \ 41 --localstatedir=/var/${BPN} \
42 --with-gdbm=no \ 42 --with-gdbm=no \
43 --with-ndbm=no \ 43 --with-ndbm=no \
44 --includedir=${includedir}/${PN} \ 44 --includedir=${includedir}/${BPN} \
45 --datadir=${datadir}/${PN} \ 45 --datadir=${datadir}/${BPN} \
46 --sysconfdir=${sysconfdir}/${PN} \ 46 --sysconfdir=${sysconfdir}/${BPN} \
47 --libexecdir=${libdir}/${PN}/modules \ 47 --libexecdir=${libdir}/${BPN}/modules \
48 ap_cv_void_ptr_lt_long=no \ 48 ap_cv_void_ptr_lt_long=no \
49 --enable-mpms-shared \ 49 --enable-mpms-shared \
50 ac_cv_have_threadsafe_pollset=no" 50 ac_cv_have_threadsafe_pollset=no"
@@ -65,19 +65,19 @@ do_install_append() {
65 -e 's,/usr/bin/,${bindir}/,g' \ 65 -e 's,/usr/bin/,${bindir}/,g' \
66 -e 's,/usr/lib,${libdir}/,g' \ 66 -e 's,/usr/lib,${libdir}/,g' \
67 -e 's,/etc/,${sysconfdir}/,g' \ 67 -e 's,/etc/,${sysconfdir}/,g' \
68 -e 's,/usr/,${prefix}/,g' > ${D}/${sysconfdir}/init.d/${PN} 68 -e 's,/usr/,${prefix}/,g' > ${D}/${sysconfdir}/init.d/${BPN}
69 chmod 755 ${D}/${sysconfdir}/init.d/${PN} 69 chmod 755 ${D}/${sysconfdir}/init.d/${BPN}
70 # remove the goofy original files... 70 # remove the goofy original files...
71 rm -rf ${D}/${sysconfdir}/${PN}/original 71 rm -rf ${D}/${sysconfdir}/${BPN}/original
72 # Expat should be found in the staging area via DEPENDS... 72 # Expat should be found in the staging area via DEPENDS...
73 rm -f ${D}/${libdir}/libexpat.* 73 rm -f ${D}/${libdir}/libexpat.*
74 74
75 install -d ${D}${sysconfdir}/${PN}/conf.d 75 install -d ${D}${sysconfdir}/${BPN}/conf.d
76 install -d ${D}${sysconfdir}/${PN}/modules.d 76 install -d ${D}${sysconfdir}/${BPN}/modules.d
77 77
78 # Ensure configuration file pulls in conf.d and modules.d 78 # Ensure configuration file pulls in conf.d and modules.d
79 printf "\nIncludeOptional ${sysconfdir}/${PN}/conf.d/*.conf" >> ${D}/${sysconfdir}/${PN}/httpd.conf 79 printf "\nIncludeOptional ${sysconfdir}/${BPN}/conf.d/*.conf" >> ${D}/${sysconfdir}/${BPN}/httpd.conf
80 printf "\nIncludeOptional ${sysconfdir}/${PN}/modules.d/*.conf\n\n" >> ${D}/${sysconfdir}/${PN}/httpd.conf 80 printf "\nIncludeOptional ${sysconfdir}/${BPN}/modules.d/*.conf\n\n" >> ${D}/${sysconfdir}/${BPN}/httpd.conf
81} 81}
82 82
83SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess" 83SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess"
@@ -85,12 +85,12 @@ SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess"
85apache_sysroot_preprocess () { 85apache_sysroot_preprocess () {
86 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 86 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
87 install -m 755 ${D}${bindir}/apxs ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 87 install -m 755 ${D}${bindir}/apxs ${SYSROOT_DESTDIR}${bindir_crossscripts}/
88 sed -i 's!my $installbuilddir = .*!my $installbuilddir = "${STAGING_DIR_HOST}/${datadir}/${PN}/build";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs 88 sed -i 's!my $installbuilddir = .*!my $installbuilddir = "${STAGING_DIR_HOST}/${datadir}/${BPN}/build";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs
89 sed -i 's!my $libtool = .*!my $libtool = "${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs 89 sed -i 's!my $libtool = .*!my $libtool = "${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs
90 90
91 sed -i 's!^APR_CONFIG = .*!APR_CONFIG = ${STAGING_BINDIR_CROSS}/apr-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk 91 sed -i 's!^APR_CONFIG = .*!APR_CONFIG = ${STAGING_BINDIR_CROSS}/apr-1-config!' ${SYSROOT_DESTDIR}${datadir}/${BPN}/build/config_vars.mk
92 sed -i 's!^APU_CONFIG = .*!APU_CONFIG = ${STAGING_BINDIR_CROSS}/apu-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk 92 sed -i 's!^APU_CONFIG = .*!APU_CONFIG = ${STAGING_BINDIR_CROSS}/apu-1-config!' ${SYSROOT_DESTDIR}${datadir}/${BPN}/build/config_vars.mk
93 sed -i 's!^includedir = .*!includedir = ${STAGING_INCDIR}/apache2!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk 93 sed -i 's!^includedir = .*!includedir = ${STAGING_INCDIR}/apache2!' ${SYSROOT_DESTDIR}${datadir}/${BPN}/build/config_vars.mk
94} 94}
95 95
96# 96#
@@ -102,40 +102,39 @@ LEAD_SONAME = "libapr-1.so.0"
102 102
103PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}" 103PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
104 104
105CONFFILES_${PN} = "${sysconfdir}/${PN}/httpd.conf \ 105CONFFILES_${PN} = "${sysconfdir}/${BPN}/httpd.conf \
106 ${sysconfdir}/${PN}/magic \ 106 ${sysconfdir}/${BPN}/magic \
107 ${sysconfdir}/${PN}/mime.types \ 107 ${sysconfdir}/${BPN}/mime.types \
108 ${sysconfdir}/init.d/${PN} " 108 ${sysconfdir}/init.d/${BPN} "
109 109
110# we override here rather than append so that .so links are 110# we override here rather than append so that .so links are
111# included in the runtime package rather than here (-dev) 111# included in the runtime package rather than here (-dev)
112# and to get build, icons, error into the -dev package 112# and to get build, icons, error into the -dev package
113FILES_${PN}-dev = "${datadir}/${PN}/build \ 113FILES_${PN}-dev = "${datadir}/${BPN}/build \
114 ${datadir}/${PN}/icons \ 114 ${datadir}/${BPN}/icons \
115 ${datadir}/${PN}/error \ 115 ${datadir}/${BPN}/error \
116 ${bindir}/apr-config ${bindir}/apu-config \ 116 ${bindir}/apr-config ${bindir}/apu-config \
117 ${libdir}/apr*.exp \ 117 ${libdir}/apr*.exp \
118 ${includedir}/${PN} \ 118 ${includedir}/${BPN} \
119 ${libdir}/*.la \ 119 ${libdir}/*.la \
120 ${libdir}/*.a" 120 ${libdir}/*.a"
121 121
122# manual to manual 122# manual to manual
123FILES_${PN}-doc += " ${datadir}/${PN}/manual" 123FILES_${PN}-doc += " ${datadir}/${BPN}/manual"
124 124
125# 125#
126# override this too - here is the default, less datadir 126# override this too - here is the default, less datadir
127# 127#
128FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* ${sysconfdir} \ 128FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* ${sysconfdir} \
129 ${sharedstatedir} ${localstatedir} /bin /sbin /lib/*.so* \ 129 ${sharedstatedir} ${localstatedir} /bin /sbin /lib/*.so* \
130 ${libdir}/${PN}" 130 ${libdir}/${BPN}"
131 131
132# we want htdocs and cgi-bin to go with the binary 132# we want htdocs and cgi-bin to go with the binary
133FILES_${PN} += "${datadir}/${PN}/htdocs ${datadir}/${PN}/cgi-bin" 133FILES_${PN} += "${datadir}/${BPN}/htdocs ${datadir}/${BPN}/cgi-bin"
134 134
135#make sure the lone .so links also get wrapped in the base package 135#make sure the lone .so links also get wrapped in the base package
136FILES_${PN} += "${libdir}/lib*.so ${libdir}/pkgconfig/*" 136FILES_${PN} += "${libdir}/lib*.so ${libdir}/pkgconfig/*"
137 137
138FILES_${PN}-dbg += "${libdir}/${PN}/modules/.debug" 138FILES_${PN}-dbg += "${libdir}/${BPN}/modules/.debug"
139 139
140RDEPENDS_${PN} += "openssl libgcc" 140RDEPENDS_${PN} += "openssl libgcc"
141