summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-10 11:04:20 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-11 09:28:09 +0100
commita6614039ee04605d4b5efe6b2c2942dc9d0aac4d (patch)
treef0a65a3b78081c4c4b4c847960bc6a3000bff09c /meta-webserver
parentdff2c1bd5291e95b35a102c1b5fdbe78aa627c41 (diff)
downloadmeta-openembedded-a6614039ee04605d4b5efe6b2c2942dc9d0aac4d.tar.gz
apache2: reorganise packaging definitions
Move RDEPENDS to the end and PACKAGES before other packaging definitions. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
index 2c0fa6b92..5857be7de 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
@@ -3,7 +3,6 @@ extensible web server."
3SUMMARY = "Apache HTTP Server" 3SUMMARY = "Apache HTTP Server"
4HOMEPAGE = "http://httpd.apache.org/" 4HOMEPAGE = "http://httpd.apache.org/"
5DEPENDS = "libtool-native apache2-native openssl expat pcre apr apr-util" 5DEPENDS = "libtool-native apache2-native openssl expat pcre apr apr-util"
6RDEPENDS_${PN} += "openssl libgcc"
7SECTION = "net" 6SECTION = "net"
8LICENSE = "Apache-2.0" 7LICENSE = "Apache-2.0"
9PR = "r2" 8PR = "r2"
@@ -103,13 +102,13 @@ INITSCRIPT_NAME = "apache2"
103INITSCRIPT_PARAMS = "defaults 91 20" 102INITSCRIPT_PARAMS = "defaults 91 20"
104LEAD_SONAME = "libapr-1.so.0" 103LEAD_SONAME = "libapr-1.so.0"
105 104
105PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
106
106CONFFILES_${PN} = "${sysconfdir}/${PN}/httpd.conf \ 107CONFFILES_${PN} = "${sysconfdir}/${PN}/httpd.conf \
107 ${sysconfdir}/${PN}/magic \ 108 ${sysconfdir}/${PN}/magic \
108 ${sysconfdir}/${PN}/mime.types \ 109 ${sysconfdir}/${PN}/mime.types \
109 ${sysconfdir}/init.d/${PN} " 110 ${sysconfdir}/init.d/${PN} "
110 111
111PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
112
113# we override here rather than append so that .so links are 112# we override here rather than append so that .so links are
114# included in the runtime package rather than here (-dev) 113# included in the runtime package rather than here (-dev)
115# and to get build, icons, error into the -dev package 114# and to get build, icons, error into the -dev package
@@ -140,3 +139,5 @@ FILES_${PN} += "${libdir}/lib*.so ${libdir}/pkgconfig/*"
140 139
141FILES_${PN}-dbg += "${libdir}/${PN}/modules/.debug" 140FILES_${PN}-dbg += "${libdir}/${PN}/modules/.debug"
142 141
142RDEPENDS_${PN} += "openssl libgcc"
143