summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-07 11:51:22 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-09 11:09:23 +0200
commit6d182b316f366e3491ee50ccd021eb7a79189136 (patch)
tree3c159cb0ac7b4d3dab2cc9c06b361d7239dd6c25 /meta-webserver
parentcbac8756e815c3f141cebf6d2e6875400980a4f9 (diff)
downloadmeta-openembedded-6d182b316f366e3491ee50ccd021eb7a79189136.tar.gz
apache2: fix configuration
* Include conf files in /etc/apache2/modules.d and conf.d * Add -D PHP5 to options so that PHP is enabled if installed * Fix "reload" action in initscript Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb10
-rwxr-xr-xmeta-webserver/recipes-httpd/apache2/files/init6
2 files changed, 10 insertions, 6 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
index 15c4d024f..0eb53275c 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
@@ -6,7 +6,7 @@ DEPENDS = "libtool-native apache2-native openssl expat pcre apr apr-util"
6RDEPENDS_${PN} += "openssl libgcc" 6RDEPENDS_${PN} += "openssl libgcc"
7SECTION = "net" 7SECTION = "net"
8LICENSE = "Apache-2.0" 8LICENSE = "Apache-2.0"
9PR = "r0" 9PR = "r1"
10 10
11SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \ 11SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \
12 file://server-makefile.patch \ 12 file://server-makefile.patch \
@@ -68,8 +68,12 @@ do_install_append() {
68 # Expat should be found in the staging area via DEPENDS... 68 # Expat should be found in the staging area via DEPENDS...
69 rm -f ${D}/${libdir}/libexpat.* 69 rm -f ${D}/${libdir}/libexpat.*
70 70
71 # Ensure configuration file pulls in modules.d 71 install -d ${D}${sysconfdir}/${PN}/conf.d
72 printf "\nInclude ${sysconfdir}/${PN}/modules.d/*\n\n" >> ${D}/${sysconfdir}/${PN}/httpd.conf 72 install -d ${D}${sysconfdir}/${PN}/modules.d
73
74 # Ensure configuration file pulls in conf.d and modules.d
75 printf "\nIncludeOptional ${sysconfdir}/${PN}/conf.d/*.conf" >> ${D}/${sysconfdir}/${PN}/httpd.conf
76 printf "\nIncludeOptional ${sysconfdir}/${PN}/modules.d/*.conf\n\n" >> ${D}/${sysconfdir}/${PN}/httpd.conf
73} 77}
74 78
75SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess" 79SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess"
diff --git a/meta-webserver/recipes-httpd/apache2/files/init b/meta-webserver/recipes-httpd/apache2/files/init
index 85af74283..346dc0d52 100755
--- a/meta-webserver/recipes-httpd/apache2/files/init
+++ b/meta-webserver/recipes-httpd/apache2/files/init
@@ -9,12 +9,12 @@
9# implementing the current HTTP standards. 9# implementing the current HTTP standards.
10### END INIT INFO 10### END INIT INFO
11 11
12ARGS="-D SSL -k start" 12ARGS="-D SSL -D PHP5 -k start"
13NAME=apache2 13NAME=apache2
14PATH=/bin:/usr/bin:/sbin:/usr/sbin 14PATH=/bin:/usr/bin:/sbin:/usr/sbin
15DAEMON=/usr/sbin/httpd 15DAEMON=/usr/sbin/httpd
16SUEXEC=/usr/lib/apache/suexec 16SUEXEC=/usr/lib/apache/suexec
17PIDFILE=/var/run/$NAME.pid 17PIDFILE=/var/apache2/logs/httpd.pid
18CONF=/etc/apache2/httpd.conf 18CONF=/etc/apache2/httpd.conf
19APACHECTL=/usr/sbin/apachectl 19APACHECTL=/usr/sbin/apachectl
20 20
@@ -40,7 +40,7 @@ case "$1" in
40 40
41 reload) 41 reload)
42 echo -n "Reloading $NAME configuration" 42 echo -n "Reloading $NAME configuration"
43 $APACHECTL reload 43 kill -HUP `cat $PIDFILE`
44 ;; 44 ;;
45 45
46 reload-modules) 46 reload-modules)