summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorJack Mitchell <jack.mitchell@dbbroadcast.co.uk>2012-10-18 14:08:16 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-18 15:12:31 +0100
commit4cd60deb11a8a6f9134d7f6ec39255a35d921426 (patch)
treefecc86531d10ee6a776eb33d30f2a6fe1ad5bc9b /meta-webserver
parent6fe4073a2618c1c962972dc83523b72fc1d66e31 (diff)
downloadmeta-openembedded-4cd60deb11a8a6f9134d7f6ec39255a35d921426.tar.gz
hiawatha: add initial 8.5 recipe and associated files
Signed-off-by: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/files/hiawatha-init44
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/hiawatha_8.5.bb45
2 files changed, 89 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/hiawatha/files/hiawatha-init b/meta-webserver/recipes-httpd/hiawatha/files/hiawatha-init
new file mode 100644
index 000000000..47fc0877a
--- /dev/null
+++ b/meta-webserver/recipes-httpd/hiawatha/files/hiawatha-init
@@ -0,0 +1,44 @@
1#!/bin/sh
2
3### BEGIN INIT INFO
4# Provides: hiawatha httpd httpd-cgi
5# Required-Start: $syslog $network $remote_fs
6# Required-Stop: $syslog $network $remote_fs
7# Default-Start: 2 3 4 5
8# Default-Stop: 0 1 6
9# Short-Description: Hiawatha webserver
10# Description: Hiawatha, a secure and advanced webserver.
11### END INIT INFO
12
13PATH=/sbin:/bin:/usr/sbin:/usr/bin
14DAEMON=sed_sbin_path/hiawatha
15NAME=hiawatha
16DESC="Hiawatha Web Server"
17OPTS=""
18
19case "$1" in
20 start)
21 echo -n "Starting $DESC: "
22 start-stop-daemon --start -x "$DAEMON" -- $OPTS
23 echo "$NAME."
24 ;;
25 stop)
26 echo -n "Stopping $DESC: "
27 start-stop-daemon --stop -x "$DAEMON"
28 echo "$NAME."
29 ;;
30 restart|force-reload)
31 echo -n "Restarting $DESC: "
32 start-stop-daemon --stop -x "$DAEMON"
33 sleep 1
34 start-stop-daemon --start -x "$DAEMON" -- $OPTS
35 echo "$NAME."
36 ;;
37 *)
38 N=/etc/init.d/$NAME
39 echo "Usage: $N {start|stop|restart|force-reload}" >&2
40 exit 1
41 ;;
42esac
43
44exit 0
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.5.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.5.bb
new file mode 100644
index 000000000..71cc88561
--- /dev/null
+++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.5.bb
@@ -0,0 +1,45 @@
1DESCRIPTION = "Lightweight secure web server"
2HOMEPAGE = "http://www.hiawatha-webserver.org"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
5DEPENDS = "libxml2 libxslt"
6
7SECTION = "net"
8
9SRC_URI = "http://hiawatha-webserver.org/files/${PN}-${PV}.tar.gz \
10 file://hiawatha-init"
11
12SRC_URI[md5sum] = "71d3903657953c93fc930758d158097d"
13SRC_URI[sha256sum] = "2567e6b4b4c6666388087b586238e6e91a4afd80e10a879920020a097fcdc946"
14
15inherit cmake update-rc.d
16
17INITSCRIPT_NAME = "hiawatha"
18INITSCRIPT_PARAMS = "defaults 70"
19
20EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \
21 -DENABLE_CACHE=ON \
22 -DENABLE_DEBUG=OFF \
23 -DENABLE_SSL=OFF \
24 -DENABLE_TOOLKIT=OFF \
25 -DENABLE_CHROOT=OFF \
26 -DENABLE_XSLT=ON \
27 -DENABLE_TOMAHAWK=OFF \
28 -DCMAKE_INSTALL_MANDIR=${mandir} \
29 -DCMAKE_INSTALL_BINDIR=${bindir} \
30 -DCMAKE_INSTALL_SBINDIR=${sbindir} \
31 -DCMAKE_INSTALL_SYSCONFDIR=${sysconfdir} \
32 -DCMAKE_INSTALL_LIBDIR=${libdir} \
33 -DLOG_DIR=/var/log/hiawatha \
34 -DPID_DIR=/var/run \
35 -DWEBROOT_DIR=/var/www/hiawatha \
36 -DWORK_DIR=/var/lib/hiawatha "
37
38do_install_append() {
39
40 # Copy over init script and sed in the correct sbin path
41 sed -i 's,sed_sbin_path,${sbindir},' ${WORKDIR}/hiawatha-init
42 mkdir -p ${D}${sysconfdir}/init.d
43 install -m 0755 ${WORKDIR}/hiawatha-init ${D}${sysconfdir}/init.d/hiawatha
44
45}