summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorJack Mitchell <jack.mitchell@dbbroadcast.co.uk>2013-01-15 10:00:46 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-01-16 09:42:12 +0000
commit1e1afc219b92fab6ef86b8ff9c003020982ce8df (patch)
tree2672f89dd23e67800c6cddea3de2709a003441fe /meta-webserver
parenta69aa98293bba340ce9161b4e890e085d982c778 (diff)
downloadmeta-openembedded-1e1afc219b92fab6ef86b8ff9c003020982ce8df.tar.gz
hiawatha: update to 8.7
Signed-off-by: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/files/xslt-fix.patch71
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/hiawatha_8.7.bb (renamed from meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb)9
2 files changed, 3 insertions, 77 deletions
diff --git a/meta-webserver/recipes-httpd/hiawatha/files/xslt-fix.patch b/meta-webserver/recipes-httpd/hiawatha/files/xslt-fix.patch
deleted file mode 100644
index 81c5d1b24..000000000
--- a/meta-webserver/recipes-httpd/hiawatha/files/xslt-fix.patch
+++ /dev/null
@@ -1,71 +0,0 @@
1Upstream-Status: Backport
2Signed-off-by: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk>
3---
4 src/xslt.c | 19 +++++++------------
5 1 file changed, 7 insertions(+), 12 deletions(-)
6
7diff --git a/src/xslt.c b/src/xslt.c
8index 9d8d31a..58ca52d 100644
9--- a/src/xslt.c
10+++ b/src/xslt.c
11@@ -23,6 +23,7 @@
12 #include <libxslt/transform.h>
13 #include <libxslt/xsltutils.h>
14 #include "libstr.h"
15+#include "liblist.h"
16 #include "send.h"
17 #include "log.h"
18 #ifdef ENABLE_TOMAHAWK
19@@ -343,10 +344,10 @@ bool can_transform_with_xslt(t_session *session) {
20 static int apply_xslt_sheet(t_session *session, xmlDocPtr data_xml) {
21 xmlDocPtr style_xml, result_xml;
22 xsltStylesheetPtr xslt;
23- xmlOutputBufferPtr output;
24+ xmlChar *raw_xml;
25 char value[VALUE_SIZE + 1];
26 const char **params;
27- int result = 200;
28+ int result = 200, raw_size;
29
30 /* Read XML data
31 */
32@@ -396,14 +397,8 @@ static int apply_xslt_sheet(t_session *session, xmlDocPtr data_xml) {
33 xsltFreeStylesheet(xslt);
34 return 500;
35 }
36- if ((output = xmlAllocOutputBuffer(NULL)) == NULL) {
37- xmlFreeDoc(result_xml);
38- xsltFreeStylesheet(xslt);
39- return 500;
40- }
41- if (xsltSaveResultTo(output, result_xml, xslt) == -1) {
42+ if (xsltSaveResultToString(&raw_xml, &raw_size, result_xml, xslt) == -1) {
43 log_file_error(session, session->file_on_disk, "transformation error");
44- xmlOutputBufferClose(output);
45 xmlFreeDoc(result_xml);
46 xsltFreeStylesheet(xslt);
47 return 500;
48@@ -414,17 +409,17 @@ static int apply_xslt_sheet(t_session *session, xmlDocPtr data_xml) {
49 value[VALUE_SIZE] = '\0';
50 if (send_buffer(session, hs_conlen, 16) == -1) {
51 result = -1;
52- } else if (snprintf(value, VALUE_SIZE, "%d\r\n\r\n", output->buffer->use) == -1) {
53+ } else if (snprintf(value, VALUE_SIZE, "%d\r\n\r\n", raw_size) == -1) {
54 result = -1;
55 } else if (send_buffer(session, value, strlen(value)) == -1) {
56 result = -1;
57- } else if (send_buffer(session, (char*)output->buffer->content, output->buffer->use) == -1) {
58+ } else if (send_buffer(session, (char*)raw_xml, raw_size) == -1) {
59 result = -1;
60 }
61
62 /* Free buffers
63 */
64- xmlOutputBufferClose(output);
65+ xmlFree(raw_xml);
66 xmlFreeDoc(result_xml);
67 xsltFreeStylesheet(xslt);
68
69--
701.8.0.1
71
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.7.bb
index d49bcabda..d8a0583fa 100644
--- a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.6.bb
+++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.7.bb
@@ -4,16 +4,13 @@ LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
5DEPENDS = "libxml2 libxslt" 5DEPENDS = "libxml2 libxslt"
6 6
7PR = "r2"
8
9SECTION = "net" 7SECTION = "net"
10 8
11SRC_URI = "http://hiawatha-webserver.org/files/${PN}-${PV}.tar.gz \ 9SRC_URI = "http://hiawatha-webserver.org/files/${PN}-${PV}.tar.gz \
12 file://hiawatha-init \ 10 file://hiawatha-init "
13 file://xslt-fix.patch "
14 11
15SRC_URI[md5sum] = "372ea9e8329ed36e4fb781fdc1a6734c" 12SRC_URI[md5sum] = "712b1822ef525153dc4347417252768d"
16SRC_URI[sha256sum] = "1a7fa98ce66beb54fc8490cc787461d719a98cb0e4a81caedfa18ac8b5ba3b3b" 13SRC_URI[sha256sum] = "c35e1e975962e1105d7914f74901e304ba90681985c94236c113eaca502b5e34"
17 14
18inherit cmake update-rc.d 15inherit cmake update-rc.d
19 16