summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorNick Glynn <n.s.glynn@gmail.com>2013-10-14 15:10:54 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-10-28 16:31:38 +0000
commit603c635feb211e7c092a39e73784303859bfdd47 (patch)
treec10f2178af865a85deb94af14dd8fcc794cc9b21 /meta-webserver
parentbeee26305246a75b3e0c75828ba6c660abee6392 (diff)
downloadmeta-openembedded-603c635feb211e7c092a39e73784303859bfdd47.tar.gz
sthttpd: add systemd service
Signed-off-by: Nick Glynn <n.s.glynn@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/sthttpd/sthttpd/thttpd.service10
-rw-r--r--meta-webserver/recipes-httpd/sthttpd/sthttpd_2.26.4.bb11
2 files changed, 20 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/sthttpd/sthttpd/thttpd.service b/meta-webserver/recipes-httpd/sthttpd/sthttpd/thttpd.service
new file mode 100644
index 000000000..e2dae61fd
--- /dev/null
+++ b/meta-webserver/recipes-httpd/sthttpd/sthttpd/thttpd.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=Tiny/Turbo/Throttling Web Server
3
4[Service]
5Type=forking
6ExecStart=/usr/sbin/thttpd -d @@SRVDIR -c cgi-bin/* -i /var/run/thttpd.pid
7PIDFile=/var/run/thttpd.pid
8
9[Install]
10WantedBy=multi-user.target
diff --git a/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.26.4.bb b/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.26.4.bb
index ba2f047a9..0abd13169 100644
--- a/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.26.4.bb
+++ b/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.26.4.bb
@@ -5,6 +5,7 @@ LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://src/thttpd.c;beginline=1;endline=26;md5=0c5762c2c34dcbe9eb18815516502872" 5LIC_FILES_CHKSUM = "file://src/thttpd.c;beginline=1;endline=26;md5=0c5762c2c34dcbe9eb18815516502872"
6 6
7SRC_URI = "http://opensource.dyc.edu/pub/sthttpd/sthttpd-${PV}.tar.gz \ 7SRC_URI = "http://opensource.dyc.edu/pub/sthttpd/sthttpd-${PV}.tar.gz \
8 file://thttpd.service \
8 file://init" 9 file://init"
9 10
10SRC_URI[md5sum] = "e645a85a97d3cb883011a35bc2211815" 11SRC_URI[md5sum] = "e645a85a97d3cb883011a35bc2211815"
@@ -12,7 +13,7 @@ SRC_URI[sha256sum] = "78e87979140cbda123c81b4051552242dbbffb5dec1a17e5f95ec4826b
12 13
13S = "${WORKDIR}/sthttpd-${PV}" 14S = "${WORKDIR}/sthttpd-${PV}"
14 15
15inherit autotools update-rc.d 16inherit autotools update-rc.d systemd
16 17
17EXTRA_OEMAKE += "'WEBDIR=${servicedir}/www'" 18EXTRA_OEMAKE += "'WEBDIR=${servicedir}/www'"
18 19
@@ -21,11 +22,19 @@ do_install_append () {
21 install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/thttpd 22 install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/thttpd
22 sed -i -e 's,@@SRVDIR,${servicedir}/www,g' ${D}${sysconfdir}/init.d/thttpd 23 sed -i -e 's,@@SRVDIR,${servicedir}/www,g' ${D}${sysconfdir}/init.d/thttpd
23 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/thttpd 24 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/thttpd
25
26 install -d ${D}${systemd_unitdir}/system
27 install -m 0644 ${WORKDIR}/thttpd.service ${D}${systemd_unitdir}/system
28 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${systemd_unitdir}/system/thttpd.service
29 sed -i 's!/var/!${localstatedir}/!g' ${D}${systemd_unitdir}/system/thttpd.service
30 sed -i -e 's,@@SRVDIR,${servicedir}/www,g' ${D}${systemd_unitdir}/system/thttpd.service
24} 31}
25 32
26INITSCRIPT_NAME = "thttpd" 33INITSCRIPT_NAME = "thttpd"
27INITSCRIPT_PARAMS = "defaults" 34INITSCRIPT_PARAMS = "defaults"
28 35
36SYSTEMD_SERVICE_${PN} = "thttpd.service"
37
29FILES_${PN} += "${servicedir}" 38FILES_${PN} += "${servicedir}"
30FILES_${PN}-dbg += "${servicedir}/www/cgi-bin/.debug" 39FILES_${PN}-dbg += "${servicedir}/www/cgi-bin/.debug"
31 40