diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2014-08-20 02:24:18 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-23 13:18:06 +0200 |
commit | bb4fedff5f6f74165c52f3c978ed98c7f3f5539e (patch) | |
tree | db6b0623a0e862b4b4b21668d4313c35c54afc6c /meta-webserver/recipes-webadmin | |
parent | 2d6b021fcea16948dc84bb4da82a9a27b681d7a9 (diff) | |
download | meta-openembedded-bb4fedff5f6f74165c52f3c978ed98c7f3f5539e.tar.gz |
webmin: uprev from 1.620 to 1.700
Changed:
- Adjust or remake the following patches based on 1.700:
init-exclude.patch
exports-lib.pl.patch
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-webadmin')
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/files/exports-lib.pl.patch | 2 | ||||
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/files/init-exclude.patch | 35 | ||||
-rw-r--r-- | meta-webserver/recipes-webadmin/webmin/webmin_1.700.bb (renamed from meta-webserver/recipes-webadmin/webmin/webmin_1.620.bb) | 4 |
3 files changed, 26 insertions, 15 deletions
diff --git a/meta-webserver/recipes-webadmin/webmin/files/exports-lib.pl.patch b/meta-webserver/recipes-webadmin/webmin/files/exports-lib.pl.patch index 140ae7e45..177d8a372 100644 --- a/meta-webserver/recipes-webadmin/webmin/files/exports-lib.pl.patch +++ b/meta-webserver/recipes-webadmin/webmin/files/exports-lib.pl.patch | |||
@@ -24,7 +24,7 @@ index 22891c0..1c67494 100755 | |||
24 | # Try exportfs -r first | 24 | # Try exportfs -r first |
25 | -if ($config{'apply_cmd'} && &find_byname("nfsd") && &find_byname("mountd")) { | 25 | -if ($config{'apply_cmd'} && &find_byname("nfsd") && &find_byname("mountd")) { |
26 | +if ($config{'apply_cmd'} && &find_byname("mountd")) { | 26 | +if ($config{'apply_cmd'} && &find_byname("mountd")) { |
27 | local $out = &backquote_logged("$config{'apply_cmd'} 2>&1 </dev/null"); | 27 | my $out = &backquote_logged("$config{'apply_cmd'} 2>&1 </dev/null"); |
28 | if (!$? && $out !~ /invalid|error|failed/i) { | 28 | if (!$? && $out !~ /invalid|error|failed/i) { |
29 | # Looks like it worked! | 29 | # Looks like it worked! |
30 | -- | 30 | -- |
diff --git a/meta-webserver/recipes-webadmin/webmin/files/init-exclude.patch b/meta-webserver/recipes-webadmin/webmin/files/init-exclude.patch index 135492d71..5563227d5 100644 --- a/meta-webserver/recipes-webadmin/webmin/files/init-exclude.patch +++ b/meta-webserver/recipes-webadmin/webmin/files/init-exclude.patch | |||
@@ -5,9 +5,17 @@ | |||
5 | # Upstream-status: Pending | 5 | # Upstream-status: Pending |
6 | # | 6 | # |
7 | # Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> | 7 | # Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> |
8 | --- webmin-1.570.orig/init/index.cgi | 8 | # Signed-off-by: Jackie Huang <jackie.huang@windriver.com> |
9 | +++ webmin-1.570/init/index.cgi | 9 | --- |
10 | @@ -48,19 +48,20 @@ elsif ($init_mode eq "init" && $access{' | 10 | init/index.cgi | 27 ++++++++++++++------------- |
11 | init/init-lib.pl | 5 +++-- | ||
12 | 2 files changed, 17 insertions(+), 15 deletions(-) | ||
13 | |||
14 | diff --git a/init/index.cgi b/init/index.cgi | ||
15 | index d48b793..30dafd4 100755 | ||
16 | --- a/init/index.cgi | ||
17 | +++ b/init/index.cgi | ||
18 | @@ -45,19 +45,20 @@ elsif ($init_mode eq "init" && $access{'bootup'}) { | ||
11 | : "$config{'init_dir'}/$ac[0]"); | 19 | : "$config{'init_dir'}/$ac[0]"); |
12 | } | 20 | } |
13 | @runlevels = &list_runlevels(); | 21 | @runlevels = &list_runlevels(); |
@@ -41,11 +49,11 @@ | |||
41 | 49 | ||
42 | # For each action, look at /etc/rc*.d/* files to see if it is | 50 | # For each action, look at /etc/rc*.d/* files to see if it is |
43 | # started at boot | 51 | # started at boot |
44 | Index: webmin-1.570/init/init-lib.pl | 52 | diff --git a/init/init-lib.pl b/init/init-lib.pl |
45 | =================================================================== | 53 | index ead21ed..b41794b 100755 |
46 | --- webmin-1.570.orig/init/init-lib.pl | 54 | --- a/init/init-lib.pl |
47 | +++ webmin-1.570/init/init-lib.pl | 55 | +++ b/init/init-lib.pl |
48 | @@ -108,15 +108,17 @@ List boot time action names from init.d, | 56 | @@ -119,8 +119,9 @@ List boot time action names from init.d, such as httpd and cron. |
49 | =cut | 57 | =cut |
50 | sub list_actions | 58 | sub list_actions |
51 | { | 59 | { |
@@ -56,12 +64,15 @@ Index: webmin-1.570/init/init-lib.pl | |||
56 | opendir(DIR, $dir); | 64 | opendir(DIR, $dir); |
57 | foreach $f (sort { lc($a) cmp lc($b) } readdir(DIR)) { | 65 | foreach $f (sort { lc($a) cmp lc($b) } readdir(DIR)) { |
58 | if ($f eq "." || $f eq ".." || $f =~ /\.bak$/ || $f eq "functions" || | 66 | if ($f eq "." || $f eq ".." || $f =~ /\.bak$/ || $f eq "functions" || |
59 | $f eq "core" || $f eq "README" || $f eq "rc" || $f eq "rcS" || | 67 | @@ -128,7 +129,7 @@ foreach $f (sort { lc($a) cmp lc($b) } readdir(DIR)) { |
60 | -d "$dir/$f" || $f =~ /\.swp$/ || $f eq "skeleton" || | 68 | -d "$dir/$f" || $f =~ /\.swp$/ || $f eq "skeleton" || |
61 | $f =~ /\.lock$/ || $f =~ /\.dpkg-(old|dist)$/ || | 69 | $f =~ /\.lock$/ || $f =~ /\.dpkg-(old|dist)$/ || |
62 | - $f =~ /^\.depend\./ || $f eq '.legacy-bootordering') { next; } | 70 | $f =~ /^\.depend\./ || $f eq '.legacy-bootordering' || |
63 | + $f =~ /^\.depend\./ || $f eq '.legacy-bootordering' || | 71 | - $f =~ /^mandrake/) { next; } |
64 | + grep {$_ eq $f} @exclude ) { next; } | 72 | + $f =~ /^mandrake/ || grep {$_ eq $f} @exclude ) { next; } |
65 | if (@stbuf = stat("$dir/$f")) { | 73 | if (@stbuf = stat("$dir/$f")) { |
66 | push(@rv, "$f $stbuf[1]"); | 74 | push(@rv, "$f $stbuf[1]"); |
67 | } | 75 | } |
76 | -- | ||
77 | 2.0.0 | ||
78 | |||
diff --git a/meta-webserver/recipes-webadmin/webmin/webmin_1.620.bb b/meta-webserver/recipes-webadmin/webmin/webmin_1.700.bb index 95540ccb7..45d635e09 100644 --- a/meta-webserver/recipes-webadmin/webmin/webmin_1.620.bb +++ b/meta-webserver/recipes-webadmin/webmin/webmin_1.700.bb | |||
@@ -17,8 +17,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/webadmin/webmin-${PV}.tar.gz \ | |||
17 | file://net-lib.pl.patch \ | 17 | file://net-lib.pl.patch \ |
18 | file://media-tomb.patch" | 18 | file://media-tomb.patch" |
19 | 19 | ||
20 | SRC_URI[md5sum] = "e93bc5057a5b7d7e31ecb2bb228d7044" | 20 | SRC_URI[md5sum] = "e5261114a6a6ed10caf570d3239ed5b7" |
21 | SRC_URI[sha256sum] = "3d36153406d8e5d3dcaeadba34dfb5cdbc4060b75c38339174ac97b2277f284b" | 21 | SRC_URI[sha256sum] = "1a6a8aa62c32c04932b902d17fc1864ee8f3fba03012bd25f709aa65e7e9b0f2" |
22 | 22 | ||
23 | inherit perlnative update-rc.d | 23 | inherit perlnative update-rc.d |
24 | 24 | ||