summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-webadmin
diff options
context:
space:
mode:
authorJan Vermaete <jan.vermaete@gmail.com>2022-02-16 21:36:02 +0100
committerKhem Raj <raj.khem@gmail.com>2022-02-17 11:12:44 -0800
commit5c379cf62588c4e2365570010bcb115d5360e930 (patch)
tree1c214ee89e2a34bc0223ac3bd9272dfde0953779 /meta-webserver/recipes-webadmin
parentf967602a43cede3e78cba4d2197035b2d72bc50b (diff)
downloadmeta-openembedded-5c379cf62588c4e2365570010bcb115d5360e930.tar.gz
netdata: version bump 1.33.0 -> 1.33.1
https can now be enabled (default) or disabled. The lz4 patch is now in this release. Package size increase of 2% Tested on RaspberryPi4-64 Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-webadmin')
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch26
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata_1.33.1.bb (renamed from meta-webserver/recipes-webadmin/netdata/netdata_1.33.0.bb)12
2 files changed, 5 insertions, 33 deletions
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch b/meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch
deleted file mode 100644
index c699f956d..000000000
--- a/meta-webserver/recipes-webadmin/netdata/netdata/0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 85e59be1c656b946a1fcd19404cb0df6095e7dfb Mon Sep 17 00:00:00 2001
2From: odynik <odynik.ee@gmail.com>
3Date: Fri, 28 Jan 2022 12:15:41 +0200
4Subject: [PATCH 1/4] [Stream Compression] - Bug fix #12043 - lz4.h compilation
5 error - compile from source (#12049)
6
7---
8 streaming/compression.c | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/streaming/compression.c b/streaming/compression.c
12index 917f05bd6..93810aaed 100644
13--- a/streaming/compression.c
14+++ b/streaming/compression.c
15@@ -1,7 +1,7 @@
16 #include "rrdpush.h"
17-#include "lz4.h"
18
19 #ifdef ENABLE_COMPRESSION
20+#include "lz4.h"
21
22 #define LZ4_MAX_MSG_SIZE 0x4000
23 #define LZ4_STREAM_BUFFER_SIZE (0x10000 + LZ4_MAX_MSG_SIZE)
24--
252.25.1
26
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_1.33.0.bb b/meta-webserver/recipes-webadmin/netdata/netdata_1.33.1.bb
index 8b6432cec..2004670f6 100644
--- a/meta-webserver/recipes-webadmin/netdata/netdata_1.33.0.bb
+++ b/meta-webserver/recipes-webadmin/netdata/netdata_1.33.1.bb
@@ -5,13 +5,10 @@ DESCRIPTION = "Netdata is high-fidelity infrastructure monitoring and troublesho
5LICENSE = "GPLv3" 5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24"
7 7
8DEPENDS += "libuv openssl util-linux zlib" 8DEPENDS += "libuv util-linux zlib"
9 9
10SRC_URI = "\ 10SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BPN}-v${PV}.tar.gz"
11 https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BPN}-v${PV}.tar.gz \ 11SRC_URI[sha256sum] = "20ba8695d87187787b27128ac3aab9b09aa29ca6b508c48542e0f7d50ec9322b"
12 file://0001-Stream-Compression-Bug-fix-12043-lz4.h-compilation-e.patch \
13"
14SRC_URI[sha256sum] = "d167d4b2d8529119fa4047ae40d22833dac9d360a6ed07c314ba313807c027eb"
15 12
16# default netdata.conf for netdata configuration 13# default netdata.conf for netdata configuration
17SRC_URI += "file://netdata.conf" 14SRC_URI += "file://netdata.conf"
@@ -43,8 +40,9 @@ SYSTEMD_AUTO_ENABLE:${PN} = "enable"
43USERADD_PACKAGES = "${PN}" 40USERADD_PACKAGES = "${PN}"
44USERADD_PARAM:${PN} = "--system --no-create-home --home-dir ${localstatedir}/run/netdata --user-group netdata" 41USERADD_PARAM:${PN} = "--system --no-create-home --home-dir ${localstatedir}/run/netdata --user-group netdata"
45 42
46PACKAGECONFIG ??= "" 43PACKAGECONFIG ??= "https"
47PACKAGECONFIG[compression] = "--enable-compression, --disable-compression, lz4" 44PACKAGECONFIG[compression] = "--enable-compression, --disable-compression, lz4"
45PACKAGECONFIG[https] = "--enable-https, --disable-https, openssl"
48 46
49# ebpf doesn't compile (or detect) the cross compilation well 47# ebpf doesn't compile (or detect) the cross compilation well
50EXTRA_OECONF += "--disable-ebpf" 48EXTRA_OECONF += "--disable-ebpf"