diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-07-18 11:05:47 +0100 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-03 14:36:56 +0100 |
commit | 6190260bea64aa19834ce468a67d5251ded08259 (patch) | |
tree | 48d6094e1a7688a5dfea7fb1a7207b02ee49ad07 /meta-webserver/recipes-php | |
parent | 418650c55d05724af398dc5fe1185b47bf788135 (diff) | |
download | meta-openembedded-6190260bea64aa19834ce468a67d5251ded08259.tar.gz |
xdebug: add new recipe
Add new recipe for the Xdebug PHP debugger/profiler.
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver/recipes-php')
-rw-r--r-- | meta-webserver/recipes-php/xdebug/xdebug_2.2.1.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/xdebug/xdebug_2.2.1.bb b/meta-webserver/recipes-php/xdebug/xdebug_2.2.1.bb new file mode 100644 index 000000000..48e1f8e58 --- /dev/null +++ b/meta-webserver/recipes-php/xdebug/xdebug_2.2.1.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "Debugging and profiling extension for PHP" | ||
2 | LICENSE = "Xdebug" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=34df3a274aa12b795417c65634c07f16" | ||
4 | |||
5 | DEPENDS = "modphp" | ||
6 | |||
7 | PR = "r0" | ||
8 | |||
9 | SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz" | ||
10 | |||
11 | SRC_URI[md5sum] = "5e5c467e920240c20f165687d7ac3709" | ||
12 | SRC_URI[sha256sum] = "11d340eb7f87909a596bac054cc927df757dc2fc7c90b50a832c30e9bf84c9ad" | ||
13 | |||
14 | inherit autotools | ||
15 | |||
16 | EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config" | ||
17 | |||
18 | do_configure() { | ||
19 | ${STAGING_BINDIR_CROSS}/phpize | ||
20 | |||
21 | # Running autoreconf as autotools_do_configure would do here | ||
22 | # breaks the libtool configuration resulting in a failure later | ||
23 | # in do_compile. It's possible this may be fixable, however the | ||
24 | # easiest course of action for the moment is to avoid doing that. | ||
25 | oe_runconf | ||
26 | } | ||
27 | |||
28 | do_install() { | ||
29 | oe_runmake install INSTALL_ROOT=${D} | ||
30 | } | ||
31 | |||
32 | FILES_${PN} += "${libdir}/php5/extensions/*/*.so" | ||
33 | FILES_${PN}-dbg += "${libdir}/php5/extensions/*/.debug" | ||
34 | |||