diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2012-10-07 11:55:20 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-10-09 11:09:23 +0200 |
commit | 0cd6b15d729c7f4b17ac02180e7c5462b91ed9e4 (patch) | |
tree | abd3c30fe4a23fb9abc1ac6d6708d6135869acbe /meta-webserver/recipes-php/modphp | |
parent | 6d182b316f366e3491ee50ccd021eb7a79189136 (diff) | |
download | meta-openembedded-0cd6b15d729c7f4b17ac02180e7c5462b91ed9e4.tar.gz |
modphp: fix default php.ini & add PACKAGECONFIG
* Add "mysql" PACKAGECONFIG option
* Add "pgsql" PACKAGECONFIG option (untested)
* Use the correct template php.ini filename so that we actually get
some content in the default file
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver/recipes-php/modphp')
-rw-r--r-- | meta-webserver/recipes-php/modphp/modphp5.inc | 34 | ||||
-rw-r--r-- | meta-webserver/recipes-php/modphp/modphp_5.3.14.bb | 2 |
2 files changed, 18 insertions, 18 deletions
diff --git a/meta-webserver/recipes-php/modphp/modphp5.inc b/meta-webserver/recipes-php/modphp/modphp5.inc index 82b5ce1a6..344eb31d9 100644 --- a/meta-webserver/recipes-php/modphp/modphp5.inc +++ b/meta-webserver/recipes-php/modphp/modphp5.inc | |||
@@ -20,27 +20,27 @@ CFLAGS += " -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -I${STAGING_INCDIR}/apache2" | |||
20 | EXTRA_OECONF = "--with-apxs2=${STAGING_BINDIR_CROSS}/apxs \ | 20 | EXTRA_OECONF = "--with-apxs2=${STAGING_BINDIR_CROSS}/apxs \ |
21 | --enable-maintainer-zts \ | 21 | --enable-maintainer-zts \ |
22 | --without-mysql \ | 22 | --without-mysql \ |
23 | --enable-force-cgi-redirect \ | 23 | --enable-force-cgi-redirect \ |
24 | --disable-cgi \ | 24 | --disable-cgi \ |
25 | --disable-cli \ | 25 | --disable-cli \ |
26 | --disable-pdo \ | 26 | --disable-pdo \ |
27 | --without-pear \ | 27 | --without-pear \ |
28 | --without-iconv \ | 28 | --without-iconv \ |
29 | --disable-ipv6 \ | 29 | --disable-ipv6 \ |
30 | --disable-xml \ | 30 | --disable-xml \ |
31 | --disable-xmlreader \ | 31 | --disable-xmlreader \ |
32 | --disable-xmlwriter \ | 32 | --disable-xmlwriter \ |
33 | --disable-simplexml \ | 33 | --disable-simplexml \ |
34 | --disable-libxml \ | 34 | --disable-libxml \ |
35 | --disable-dom \ | 35 | --disable-dom \ |
36 | --disable-rpath \ | 36 | --disable-rpath \ |
37 | --libdir=${libdir}/php5 \ | 37 | --libdir=${libdir}/php5 \ |
38 | --with-zlib --with-zlib-dir=${STAGING_DIR_TARGET}${exec_prefix} \ | 38 | --with-zlib --with-zlib-dir=${STAGING_DIR_TARGET}${exec_prefix} \ |
39 | --with-config-file-path=${sysconfdir}/php/apache2-php5" | 39 | --with-config-file-path=${sysconfdir}/php/apache2-php5" |
40 | 40 | ||
41 | # to get postgres support, add it to the DEPENDS above | 41 | PACKAGECONFIG ??= "" |
42 | # and uncomment this line. similar for mysql | 42 | PACKAGECONFIG[mysql] = "--with-mysqli=${STAGING_BINDIR_CROSS}/mysql_config,--without-mysqli,mysql5" |
43 | #EXTRA_OECONF += " --with-pgsql=${STAGING_DIR_HOST}${layout_exec_prefix}" | 43 | PACKAGECONFIG[pgsql] = "--with-pgsql=${STAGING_DIR_TARGET}${exec_prefix},--without-pgsql,mysql5" |
44 | 44 | ||
45 | acpaths = "" | 45 | acpaths = "" |
46 | 46 | ||
@@ -60,7 +60,7 @@ do_install () { | |||
60 | install -d ${D}${sysconfdir}/php/apache2-php5 | 60 | install -d ${D}${sysconfdir}/php/apache2-php5 |
61 | install -m 755 libs/libphp5.so ${D}${libdir}/apache2/modules | 61 | install -m 755 libs/libphp5.so ${D}${libdir}/apache2/modules |
62 | install -m 644 ${WORKDIR}/70_mod_php5.conf ${D}${sysconfdir}/apache2/modules.d | 62 | install -m 644 ${WORKDIR}/70_mod_php5.conf ${D}${sysconfdir}/apache2/modules.d |
63 | cat ${S}/php.ini-dist | \ | 63 | cat ${S}/php.ini-production | \ |
64 | sed -e 's,extension_dir = \"\./\",extension_dir = \"/usr/lib/extensions\",' \ | 64 | sed -e 's,extension_dir = \"\./\",extension_dir = \"/usr/lib/extensions\",' \ |
65 | > ${D}${sysconfdir}/php/apache2-php5/php.ini | 65 | > ${D}${sysconfdir}/php/apache2-php5/php.ini |
66 | 66 | ||
diff --git a/meta-webserver/recipes-php/modphp/modphp_5.3.14.bb b/meta-webserver/recipes-php/modphp/modphp_5.3.14.bb index b6a51267b..707f5f90b 100644 --- a/meta-webserver/recipes-php/modphp/modphp_5.3.14.bb +++ b/meta-webserver/recipes-php/modphp/modphp_5.3.14.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | include modphp5.inc | 1 | include modphp5.inc |
2 | PR = "r0" | 2 | PR = "r1" |
3 | 3 | ||
4 | SRC_URI[md5sum] = "7caac4f71e2f21426c11ac153e538392" | 4 | SRC_URI[md5sum] = "7caac4f71e2f21426c11ac153e538392" |
5 | SRC_URI[sha256sum] = "c8075b6e83c5db0d26cc8426a7456856421089a76c963813b1fcac3ced041cb3" | 5 | SRC_URI[sha256sum] = "c8075b6e83c5db0d26cc8426a7456856421089a76c963813b1fcac3ced041cb3" |