summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/modphp/modphp5.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-webserver/recipes-php/modphp/modphp5.inc
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-webserver/recipes-php/modphp/modphp5.inc')
-rw-r--r--meta-webserver/recipes-php/modphp/modphp5.inc56
1 files changed, 28 insertions, 28 deletions
diff --git a/meta-webserver/recipes-php/modphp/modphp5.inc b/meta-webserver/recipes-php/modphp/modphp5.inc
index fdf7b1857..a49dc7523 100644
--- a/meta-webserver/recipes-php/modphp/modphp5.inc
+++ b/meta-webserver/recipes-php/modphp/modphp5.inc
@@ -9,7 +9,7 @@ SRC_URI = "http://www.php.net/distributions/php-${PV}.tar.bz2 \
9 file://pthread-check-threads-m4.patch \ 9 file://pthread-check-threads-m4.patch \
10 file://70_mod_php5.conf \ 10 file://70_mod_php5.conf \
11 file://php-5.3.14-aconf259.patch \ 11 file://php-5.3.14-aconf259.patch \
12 " 12"
13 13
14S = "${WORKDIR}/php-${PV}" 14S = "${WORKDIR}/php-${PV}"
15 15
@@ -50,45 +50,45 @@ PACKAGECONFIG[pgsql] = "--with-pgsql=${STAGING_DIR_TARGET}${exec_prefix},--witho
50acpaths = "" 50acpaths = ""
51 51
52do_configure_prepend () { 52do_configure_prepend () {
53 rm -f build/libtool.m4 ltmain.sh aclocal.m4 53 rm -f build/libtool.m4 ltmain.sh aclocal.m4
54 find . -name config.m4 | xargs -n1 sed -i 's!APXS_HTTPD=.*!APXS_HTTPD=${STAGING_BINDIR_NATIVE}/httpd!' 54 find . -name config.m4 | xargs -n1 sed -i 's!APXS_HTTPD=.*!APXS_HTTPD=${STAGING_BINDIR_NATIVE}/httpd!'
55} 55}
56 56
57do_configure_append() { 57do_configure_append() {
58 # No libtool, we really don't want rpath set... 58 # No libtool, we really don't want rpath set...
59 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${HOST_SYS}-libtool 59 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${HOST_SYS}-libtool
60 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${HOST_SYS}-libtool 60 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${HOST_SYS}-libtool
61} 61}
62 62
63do_install () { 63do_install () {
64 install -d ${D}${libdir}/apache2/modules 64 install -d ${D}${libdir}/apache2/modules
65 install -d ${D}${sysconfdir}/apache2/modules.d 65 install -d ${D}${sysconfdir}/apache2/modules.d
66 install -d ${D}${sysconfdir}/php/apache2-php5 66 install -d ${D}${sysconfdir}/php/apache2-php5
67 install -m 755 libs/libphp5.so ${D}${libdir}/apache2/modules 67 install -m 755 libs/libphp5.so ${D}${libdir}/apache2/modules
68 sed -i s,lib/,${libdir}/, ${WORKDIR}/70_mod_php5.conf 68 sed -i s,lib/,${libdir}/, ${WORKDIR}/70_mod_php5.conf
69 install -m 644 ${WORKDIR}/70_mod_php5.conf ${D}${sysconfdir}/apache2/modules.d 69 install -m 644 ${WORKDIR}/70_mod_php5.conf ${D}${sysconfdir}/apache2/modules.d
70 cat ${S}/php.ini-production | \ 70 cat ${S}/php.ini-production | \
71 sed -e 's,extension_dir = \"\./\",extension_dir = \"/usr/lib/extensions\",' \ 71 sed -e 's,extension_dir = \"\./\",extension_dir = \"/usr/lib/extensions\",' \
72 > ${D}${sysconfdir}/php/apache2-php5/php.ini 72 > ${D}${sysconfdir}/php/apache2-php5/php.ini
73 73
74 install -d ${D}${bindir} 74 install -d ${D}${bindir}
75 install -m 755 scripts/phpize ${D}${bindir} 75 install -m 755 scripts/phpize ${D}${bindir}
76 install -m 755 scripts/php-config ${D}${bindir} 76 install -m 755 scripts/php-config ${D}${bindir}
77 cat aclocal-copy/libtool.m4 aclocal-copy/lt~obsolete.m4 aclocal-copy/ltoptions.m4 \ 77 cat aclocal-copy/libtool.m4 aclocal-copy/lt~obsolete.m4 aclocal-copy/ltoptions.m4 \
78 aclocal-copy/ltsugar.m4 aclocal-copy/ltversion.m4 > build/libtool.m4 78 aclocal-copy/ltsugar.m4 aclocal-copy/ltversion.m4 > build/libtool.m4
79 79
80 oe_runmake install-build install-headers INSTALL_ROOT=${D} 80 oe_runmake install-build install-headers INSTALL_ROOT=${D}
81} 81}
82 82
83SYSROOT_PREPROCESS_FUNCS += "php_sysroot_preprocess" 83SYSROOT_PREPROCESS_FUNCS += "php_sysroot_preprocess"
84 84
85php_sysroot_preprocess () { 85php_sysroot_preprocess () {
86 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 86 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
87 install -m 755 ${D}${bindir}/phpize ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 87 install -m 755 ${D}${bindir}/phpize ${SYSROOT_DESTDIR}${bindir_crossscripts}/
88 install -m 755 ${D}${bindir}/php-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 88 install -m 755 ${D}${bindir}/php-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
89 89
90 sed -i 's!eval echo /!eval echo ${STAGING_DIR_HOST}/!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/phpize 90 sed -i 's!eval echo /!eval echo ${STAGING_DIR_HOST}/!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/phpize
91 sed -i 's!^include_dir=.*!include_dir=${STAGING_INCDIR}/php!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/php-config 91 sed -i 's!^include_dir=.*!include_dir=${STAGING_INCDIR}/php!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/php-config
92} 92}
93 93
94RDEPENDS_${PN} = "apache2" 94RDEPENDS_${PN} = "apache2"