diff options
author | Eduardo Silva <eduardo@monkey.io> | 2014-08-07 09:07:41 -0600 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-10 16:07:19 +0200 |
commit | 8af4e17c7020b4b5cf133da09ac849542f6c5787 (patch) | |
tree | df8ce0edef4f812038791f2642f1b8f5840920e3 /meta-webserver/recipes-httpd | |
parent | 7815a6d97ec81487ebcd18e39558241959c9a96b (diff) | |
download | meta-openembedded-8af4e17c7020b4b5cf133da09ac849542f6c5787.tar.gz |
monkey: new v1.5.2 release.
This patch add the new Monkey HTTP Server v1.5.2. The new Bitbake file
contains the modifications suggested over the patch set for v1.5.1. It
specify each configuration file for CONFFILES_${PN}.
For more details about software changes please visit:
http://monkey-project.com/Announcements/v1.5.2
=== Build Tests ==
This version and new Bitbake file have been tested on Yocto/Daisy being
packaged and deployed on images based on rpm and ipk successfully.
monkey-yocto/70d57bfd19c01ec055db57e35385ffc4185ae186
Signed-off-by: Eduardo Silva <eduardo@monkey.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd')
-rw-r--r-- | meta-webserver/recipes-httpd/monkey/monkey_1.5.1.bb | 50 | ||||
-rw-r--r-- | meta-webserver/recipes-httpd/monkey/monkey_1.5.2.bb | 64 |
2 files changed, 64 insertions, 50 deletions
diff --git a/meta-webserver/recipes-httpd/monkey/monkey_1.5.1.bb b/meta-webserver/recipes-httpd/monkey/monkey_1.5.1.bb deleted file mode 100644 index 2de98f453..000000000 --- a/meta-webserver/recipes-httpd/monkey/monkey_1.5.1.bb +++ /dev/null | |||
@@ -1,50 +0,0 @@ | |||
1 | SUMMARY = "Fast and Lightweight HTTP Server for Linux" | ||
2 | HOMEPAGE = "http://monkey-project.com" | ||
3 | BUGTRACKER = "https://github.com/monkey/monkey/issues" | ||
4 | |||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" | ||
7 | |||
8 | SECTION = "net" | ||
9 | |||
10 | SRC_URI = "http://monkey-project.com/releases/1.5/monkey-${PV}.tar.gz \ | ||
11 | file://monkey.service \ | ||
12 | file://monkey.init" | ||
13 | |||
14 | SRC_URI[md5sum] = "2fe04135728f5c3a86c3a412059e0da3" | ||
15 | SRC_URI[sha256sum] = "28dfc5e57bbcd305727e7af6a1a0587868db1c1286498757bfeb72edddf457e7" | ||
16 | |||
17 | EXTRA_OECONF = " \ | ||
18 | --plugdir=${libdir}/monkey/ \ | ||
19 | --logdir=${localstatedir}/log/monkey/ \ | ||
20 | --pidfile=${localstatedir}/run/monkey.pid \ | ||
21 | --default-user=www-data \ | ||
22 | --datadir=${localstatedir}/www/monkey/ \ | ||
23 | --sysconfdir=${sysconfdir}/monkey/ \ | ||
24 | --enable-plugins=* \ | ||
25 | --disable-plugins=polarssl \ | ||
26 | --debug \ | ||
27 | --malloc-libc" | ||
28 | |||
29 | inherit autotools-brokensep pkgconfig update-rc.d systemd | ||
30 | |||
31 | INITSCRIPT_NAME = "monkey" | ||
32 | INITSCRIPT_PARAMS = "defaults 70" | ||
33 | |||
34 | SYSTEMD_SERVICE_${PN} = "monkey.service" | ||
35 | |||
36 | FILES_${PN} += "${localstatedir}/www/monkey/" | ||
37 | |||
38 | # temporarily remove, because ipk doesn't allow directories in CONFFILES | ||
39 | # CONFFILES_${PN} = "${sysconfdir}/monkey/" | ||
40 | |||
41 | do_install_append() { | ||
42 | |||
43 | mkdir -p ${D}${sysconfdir}/init.d | ||
44 | install -m 0755 ${WORKDIR}/monkey.init ${D}${sysconfdir}/init.d/monkey | ||
45 | |||
46 | if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
47 | install -d ${D}${systemd_unitdir}/system | ||
48 | install -m 644 ${WORKDIR}/monkey.service ${D}/${systemd_unitdir}/system | ||
49 | fi | ||
50 | } | ||
diff --git a/meta-webserver/recipes-httpd/monkey/monkey_1.5.2.bb b/meta-webserver/recipes-httpd/monkey/monkey_1.5.2.bb new file mode 100644 index 000000000..fcd40e08c --- /dev/null +++ b/meta-webserver/recipes-httpd/monkey/monkey_1.5.2.bb | |||
@@ -0,0 +1,64 @@ | |||
1 | SUMMARY = "Fast and Lightweight HTTP Server for Linux" | ||
2 | HOMEPAGE = "http://monkey-project.com" | ||
3 | BUGTRACKER = "https://github.com/monkey/monkey/issues" | ||
4 | |||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" | ||
7 | |||
8 | SECTION = "net" | ||
9 | |||
10 | SRC_URI = "http://monkey-project.com/releases/1.5/monkey-${PV}.tar.gz \ | ||
11 | file://monkey.service \ | ||
12 | file://monkey.init" | ||
13 | |||
14 | SRC_URI[md5sum] = "c90ccba23a814265c7e0fd3a75f883fd" | ||
15 | SRC_URI[sha256sum] = "2048d49662895f83df475e22d87c45ea8022c0b1565bba222bda2192fd02c349" | ||
16 | |||
17 | EXTRA_OECONF = "--plugdir=${libdir}/monkey/ \ | ||
18 | --logdir=${localstatedir}/log/monkey/ \ | ||
19 | --pidfile=${localstatedir}/run/monkey.pid \ | ||
20 | --default-user=www-data \ | ||
21 | --datadir=${localstatedir}/www/monkey/ \ | ||
22 | --sysconfdir=${sysconfdir}/monkey/ \ | ||
23 | --enable-plugins=* \ | ||
24 | --disable-plugins=polarssl \ | ||
25 | --debug \ | ||
26 | --malloc-libc" | ||
27 | |||
28 | inherit autotools-brokensep pkgconfig update-rc.d systemd | ||
29 | |||
30 | INITSCRIPT_NAME = "monkey" | ||
31 | INITSCRIPT_PARAMS = "defaults 70" | ||
32 | |||
33 | SYSTEMD_SERVICE_${PN} = "monkey.service" | ||
34 | |||
35 | FILES_${PN} += "${localstatedir}/www/monkey/" | ||
36 | |||
37 | CONFFILES_${PN} = "${sysconfdir}/monkey/monkey.conf \ | ||
38 | ${sysconfdir}/monkey/sites/default \ | ||
39 | ${sysconfdir}/monkey/monkey.mime \ | ||
40 | ${sysconfdir}/monkey/plugins.load \ | ||
41 | ${sysconfdir}/monkey/plugins/proxy_reverse/proxy_reverse.conf \ | ||
42 | ${sysconfdir}/monkey/plugins/mandril/mandril.conf \ | ||
43 | ${sysconfdir}/monkey/plugins/fastcgi/fastcgi.conf \ | ||
44 | ${sysconfdir}/monkey/plugins/logger/logger.conf \ | ||
45 | ${sysconfdir}/monkey/plugins/cgi/cgi.conf \ | ||
46 | ${sysconfdir}/monkey/plugins/cheetah/cheetah.conf \ | ||
47 | ${sysconfdir}/monkey/plugins/dirlisting/dirhtml.conf \ | ||
48 | ${sysconfdir}/monkey/plugins/dirlisting/themes/guineo/header.theme \ | ||
49 | ${sysconfdir}/monkey/plugins/dirlisting/themes/guineo/footer.theme \ | ||
50 | ${sysconfdir}/monkey/plugins/dirlisting/themes/guineo/entry.theme \ | ||
51 | ${sysconfdir}/monkey/plugins/auth/README \ | ||
52 | ${sysconfdir}/monkey/plugins/auth/monkey.users \ | ||
53 | " | ||
54 | |||
55 | do_install_append() { | ||
56 | |||
57 | mkdir -p ${D}${sysconfdir}/init.d | ||
58 | install -m 0755 ${WORKDIR}/monkey.init ${D}${sysconfdir}/init.d/monkey | ||
59 | |||
60 | if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
61 | install -d ${D}${systemd_unitdir}/system | ||
62 | install -m 644 ${WORKDIR}/monkey.service ${D}/${systemd_unitdir}/system | ||
63 | fi | ||
64 | } | ||