diff options
author | Amarnath Valluri <amarnath.valluri@intel.com> | 2015-11-06 15:27:38 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-11-11 10:46:54 +0100 |
commit | fc5b483f76571528462806fe030052a8319f8fe6 (patch) | |
tree | 205a53e75577310df424ecf45e3cb0ff581dc803 /meta-webserver/recipes-httpd | |
parent | 9f3a2e92d385b2f0b0d8a40c2a6f1e5fb735a3e4 (diff) | |
download | meta-openembedded-fc5b483f76571528462806fe030052a8319f8fe6.tar.gz |
nginx: Fix systemd service file
systemd service file expects full path of the executatbles.
Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd')
-rw-r--r-- | meta-webserver/recipes-httpd/nginx/files/nginx.service | 2 | ||||
-rw-r--r-- | meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb | 1 |
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/nginx/files/nginx.service b/meta-webserver/recipes-httpd/nginx/files/nginx.service index 705450e47..9926a4b9d 100644 --- a/meta-webserver/recipes-httpd/nginx/files/nginx.service +++ b/meta-webserver/recipes-httpd/nginx/files/nginx.service | |||
@@ -4,7 +4,7 @@ After=network.target | |||
4 | [Service] | 4 | [Service] |
5 | Type=forking | 5 | Type=forking |
6 | PIDFile=@SYSCONFDIR@/nginx/run/nginx.pid | 6 | PIDFile=@SYSCONFDIR@/nginx/run/nginx.pid |
7 | ExecStartPre=mkdir -p @LOCALSTATEDIR@/log/nginx | 7 | ExecStartPre=@BASEBINDIR@/mkdir -p @LOCALSTATEDIR@/log/nginx |
8 | ExecStart=@SYSCONFDIR@/init.d/nginx start | 8 | ExecStart=@SYSCONFDIR@/init.d/nginx start |
9 | ExecStop=@SYSCONFDIR@/init.d/nginx stop | 9 | ExecStop=@SYSCONFDIR@/init.d/nginx stop |
10 | [Install] | 10 | [Install] |
diff --git a/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb b/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb index 1c9bff7fb..87c953b56 100644 --- a/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb +++ b/meta-webserver/recipes-httpd/nginx/nginx_1.9.5.bb | |||
@@ -94,6 +94,7 @@ do_install () { | |||
94 | install -m 0644 ${WORKDIR}/nginx.service ${D}${systemd_unitdir}/system/ | 94 | install -m 0644 ${WORKDIR}/nginx.service ${D}${systemd_unitdir}/system/ |
95 | sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \ | 95 | sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
96 | -e 's,@LOCALSTATEDIR@,${localstatedir},g' \ | 96 | -e 's,@LOCALSTATEDIR@,${localstatedir},g' \ |
97 | -e 's,@BASEBINDIR@,${base_bindir},g' \ | ||
97 | ${D}${systemd_unitdir}/system/nginx.service | 98 | ${D}${systemd_unitdir}/system/nginx.service |
98 | fi | 99 | fi |
99 | } | 100 | } |