summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-04-18 06:39:38 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-19 02:45:28 +0200
commitf593c454bc60d1837bf1f1c97521850efb438f68 (patch)
treec5aeb13dc844fd6b967767212b750a7dfe7f167a /meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
parent9955ac116e1f57de4c1fb01a0fa47e9591db1d4a (diff)
downloadmeta-openembedded-f593c454bc60d1837bf1f1c97521850efb438f68.tar.gz
nostromo: move to meta-webserver and tweak
* Add SUMMARY * Move SRC_URI checksums next to SRC_URI Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb')
-rw-r--r--meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
new file mode 100644
index 000000000..e66676e96
--- /dev/null
+++ b/meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb
@@ -0,0 +1,52 @@
1SUMMARY = "A simple, fast and secure HTTP server"
2HOMEPAGE = "http://www.nazgul.ch/dev_nostromo.html"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://src/nhttpd/main.c;beginline=2;endline=14;md5=e5ec3fa723b29b7d59d205afd8d36938"
5
6SRC_URI = "http://www.nazgul.ch/dev/${PN}-${PV}.tar.gz \
7 file://0001-GNUmakefile-add-possibility-to-override-variables.patch \
8 file://nhttpd.conf \
9 file://volatiles \
10 file://nostromo \
11"
12
13SRC_URI[md5sum] = "dc6cfd6b5aae04c370c7f818fa7bde55"
14SRC_URI[sha256sum] = "5f62578285e02449406b46cf06a7888fe3dc4a90bedf58cc18523bad62f6b914"
15
16TARGET_CC_ARCH += "${LDFLAGS}"
17
18DEPENDS = "openssl"
19
20inherit update-rc.d
21
22INITSCRIPT_NAME = "nostromo"
23INITSCRIPT_PARAMS = "defaults 70"
24
25do_compile() {
26 oe_runmake
27}
28
29do_install() {
30 install -d ${D}/${sbindir}
31 install -m 0755 src/nhttpd/nhttpd ${D}/${sbindir}/nhttpd
32 install -m 0755 src/tools/crypt ${D}/${sbindir}/crypt
33 install -d ${D}/${mandir}/man8
34 install -m 0444 src/nhttpd/nhttpd.8 ${D}/${mandir}/man8/nhttpd.8
35 install -d ${D}${localstatedir}/nostromo/conf
36 install -d ${D}${localstatedir}/nostromo/htdocs/cgi-bin
37 install -d ${D}${localstatedir}/nostromo/icons
38 install -d ${D}${localstatedir}/log/nostromo
39 install -d ${D}${localstatedir}/run/nostromo
40 install -d ${D}${sysconfdir}/init.d
41 install -m 0644 conf/mimes ${D}${localstatedir}/nostromo/conf/mimes
42 install -m 0644 ${WORKDIR}/nhttpd.conf ${D}${sysconfdir}
43 install -m 0755 ${WORKDIR}/nostromo ${D}${sysconfdir}/init.d
44 install -c -D -m 644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/nostromo
45 install -m 0644 htdocs/index.html ${D}${localstatedir}/nostromo/htdocs/index.html
46 install -m 0644 htdocs/nostromo.gif ${D}${localstatedir}/nostromo/htdocs/nostromo.gif
47 install -m 0644 icons/dir.gif ${D}${localstatedir}/nostromo/icons/dir.gif
48 install -m 0644 icons/file.gif ${D}${localstatedir}/nostromo/icons/file.gif
49 chown -R www-data:www-data ${D}/${localstatedir}/nostromo ${D}/${localstatedir}/log/nostromo ${D}/${localstatedir}/run/nostromo
50}
51
52CONFFILES_${PN} += "/var/nostromo/conf/mimes ${sysconfdir}/nhttpd.conf"