diff options
author | Jack Mitchell <jack.mitchell@dbbroadcast.co.uk> | 2013-04-18 11:20:20 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-22 09:51:47 +0200 |
commit | e1a4953e29ae1d605365b895d430ad622c605059 (patch) | |
tree | 4392bd79699d4ae387cddfd77e6679ccf062c8ae /meta-webserver/recipes-httpd/hiawatha | |
parent | 6b0aa8daf1bce02c9e40ae28d569132e0cac77fa (diff) | |
download | meta-openembedded-e1a4953e29ae1d605365b895d430ad622c605059.tar.gz |
Hiawatha: update to 9.0, add systemd support
Signed-off-by: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/hiawatha')
-rw-r--r-- | meta-webserver/recipes-httpd/hiawatha/files/hiawatha.service | 16 | ||||
-rw-r--r-- | meta-webserver/recipes-httpd/hiawatha/hiawatha_9.0.bb (renamed from meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb) | 19 |
2 files changed, 30 insertions, 5 deletions
diff --git a/meta-webserver/recipes-httpd/hiawatha/files/hiawatha.service b/meta-webserver/recipes-httpd/hiawatha/files/hiawatha.service new file mode 100644 index 000000000..26cb8d03d --- /dev/null +++ b/meta-webserver/recipes-httpd/hiawatha/files/hiawatha.service | |||
@@ -0,0 +1,16 @@ | |||
1 | [Unit] | ||
2 | Description=Hiawatha Web Server | ||
3 | After=network.target remote-fs.target nss-lookup.target | ||
4 | |||
5 | [Service] | ||
6 | Type=simple | ||
7 | SyslogIdentifier=hiawatha | ||
8 | ExecStartPre=/usr/sbin/hiawatha -k ; /usr/sbin/wigwam | ||
9 | ExecStart= /usr/sbin/hiawatha -d | ||
10 | TimeoutSec=10 | ||
11 | #(doesn't like this setting. Can't find files) PrivateTmp=true | ||
12 | LimitNOFILE=infinity | ||
13 | CapabilityBoundingSet=CAP_NET_BIND_SERVICE CAP_CHOWN CAP_DAC_OVERRIDE CAP_FOWNER CAP_FSETID CAP_SETGID CAP_SETUID | ||
14 | |||
15 | [Install] | ||
16 | WantedBy=multi-user.target | ||
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.0.bb index a7299708d..ac2155813 100644 --- a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb +++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.0.bb | |||
@@ -7,16 +7,19 @@ DEPENDS = "libxml2 libxslt" | |||
7 | SECTION = "net" | 7 | SECTION = "net" |
8 | 8 | ||
9 | SRC_URI = "http://hiawatha-webserver.org/files/${PN}-${PV}.tar.gz \ | 9 | SRC_URI = "http://hiawatha-webserver.org/files/${PN}-${PV}.tar.gz \ |
10 | file://hiawatha-init " | 10 | file://hiawatha-init \ |
11 | file://hiawatha.service " | ||
11 | 12 | ||
12 | SRC_URI[md5sum] = "5def93779bbc10a021796abd3609caf7" | 13 | SRC_URI[md5sum] = "8abc4f85dbb9a76ed66e7f35de520064" |
13 | SRC_URI[sha256sum] = "2583d8e7f48ddc6cdedc27bb51d3e130679fc2f4411622bae9ddce3ef965d063" | 14 | SRC_URI[sha256sum] = "5e40119afb050b11737250c08d89ac7ba7472645738a48c06aa79979a19729fc" |
14 | |||
15 | inherit cmake update-rc.d | ||
16 | 15 | ||
17 | INITSCRIPT_NAME = "hiawatha" | 16 | INITSCRIPT_NAME = "hiawatha" |
18 | INITSCRIPT_PARAMS = "defaults 70" | 17 | INITSCRIPT_PARAMS = "defaults 70" |
19 | 18 | ||
19 | SYSTEMD_SERVICE_${PN} = "hiawatha.service" | ||
20 | |||
21 | inherit cmake update-rc.d systemd | ||
22 | |||
20 | EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \ | 23 | EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \ |
21 | -DENABLE_CACHE=OFF \ | 24 | -DENABLE_CACHE=OFF \ |
22 | -DENABLE_DEBUG=OFF \ | 25 | -DENABLE_DEBUG=OFF \ |
@@ -44,6 +47,12 @@ do_install_append() { | |||
44 | # configure php-fcgi to have a working configuration | 47 | # configure php-fcgi to have a working configuration |
45 | # by default if php is installed | 48 | # by default if php is installed |
46 | echo "Server = ${bindir}/php-cgi ; 2 ; 127.0.0.1:2005 ; nobody:nobody ; ${sysconfdir}/php/hiawatha-php5/php.ini" >> ${D}${sysconfdir}/hiawatha/php-fcgi.conf | 49 | echo "Server = ${bindir}/php-cgi ; 2 ; 127.0.0.1:2005 ; nobody:nobody ; ${sysconfdir}/php/hiawatha-php5/php.ini" >> ${D}${sysconfdir}/hiawatha/php-fcgi.conf |
50 | |||
51 | if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
52 | install -d ${D}/${systemd_unitdir}/system | ||
53 | install -m 644 ${WORKDIR}/hiawatha.service ${D}/${systemd_unitdir}/system | ||
54 | fi | ||
55 | |||
47 | } | 56 | } |
48 | 57 | ||
49 | CONFFILES_${PN} = " \ | 58 | CONFFILES_${PN} = " \ |