summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/cherokee
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-21 22:31:24 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:35 -0800
commit7df11a27a03f8752e3dade2adeb88d21b4b79da5 (patch)
treefbc24c9af79dae70f220d4c7e577b409ef0ad058 /meta-webserver/recipes-httpd/cherokee
parent0a4faceed66002ca04413f69f6b422197981cedf (diff)
downloadmeta-openembedded-7df11a27a03f8752e3dade2adeb88d21b4b79da5.tar.gz
cherokee: Only build with meta-py2 is in layermix
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/cherokee')
-rw-r--r--meta-webserver/recipes-httpd/cherokee/cherokee_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb b/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb
index d16e04e6b..81805891a 100644
--- a/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb
+++ b/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb
@@ -20,7 +20,7 @@ SRC_URI = "git://github.com/cherokee/webserver \
20 20
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
23inherit autotools-brokensep pkgconfig binconfig update-rc.d systemd python3native 23inherit autotools-brokensep pkgconfig binconfig update-rc.d systemd pythonnative
24 24
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" 25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
26PACKAGECONFIG[ffmpeg] = "--with-ffmpeg,--without-ffmpeg,libav" 26PACKAGECONFIG[ffmpeg] = "--with-ffmpeg,--without-ffmpeg,libav"
@@ -70,3 +70,8 @@ RPROVIDES_${PN} += "${PN}-systemd"
70RREPLACES_${PN} += "${PN}-systemd" 70RREPLACES_${PN} += "${PN}-systemd"
71RCONFLICTS_${PN} += "${PN}-systemd" 71RCONFLICTS_${PN} += "${PN}-systemd"
72SYSTEMD_SERVICE_${PN} = "cherokee.service" 72SYSTEMD_SERVICE_${PN} = "cherokee.service"
73
74python() {
75 if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
76 raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
77}