summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-09-01 02:25:50 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:41:51 +0200
commitdf56eb34857748f6400ac04279194212356a94cb (patch)
treeece5c870916a0e43d57e775e8d44517c3a0d8843 /meta-webserver/recipes-httpd/apache2
parent054cef3654905b5d6e287117332c446ecedffb6d (diff)
downloadmeta-openembedded-df56eb34857748f6400ac04279194212356a94cb.tar.gz
apache2: split apache2-scripts subpkg
Split apache2-scripts subpkg to put the perl script dbmmanage, so that apache2 doesn't have to RDEPEND on perl. Add another perl script apxs to apache2-dev pkg as Olof Johansson suggested. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb
index 035602934..573cd6fb0 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb
@@ -112,7 +112,7 @@ INITSCRIPT_NAME = "apache2"
112INITSCRIPT_PARAMS = "defaults 91 20" 112INITSCRIPT_PARAMS = "defaults 91 20"
113LEAD_SONAME = "libapr-1.so.0" 113LEAD_SONAME = "libapr-1.so.0"
114 114
115PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}" 115PACKAGES = "${PN}-scripts ${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
116 116
117CONFFILES_${PN} = "${sysconfdir}/${BPN}/httpd.conf \ 117CONFFILES_${PN} = "${sysconfdir}/${BPN}/httpd.conf \
118 ${sysconfdir}/${BPN}/magic \ 118 ${sysconfdir}/${BPN}/magic \
@@ -129,11 +129,16 @@ FILES_${PN}-dev = "${datadir}/${BPN}/build \
129 ${libdir}/apr*.exp \ 129 ${libdir}/apr*.exp \
130 ${includedir}/${BPN} \ 130 ${includedir}/${BPN} \
131 ${libdir}/*.la \ 131 ${libdir}/*.la \
132 ${libdir}/*.a" 132 ${libdir}/*.a \
133 ${bindir}/apxs \
134 "
135
133 136
134# manual to manual 137# manual to manual
135FILES_${PN}-doc += " ${datadir}/${BPN}/manual" 138FILES_${PN}-doc += " ${datadir}/${BPN}/manual"
136 139
140FILES_${PN}-scripts += "${bindir}/dbmmanage"
141
137# 142#
138# override this too - here is the default, less datadir 143# override this too - here is the default, less datadir
139# 144#
@@ -150,3 +155,4 @@ FILES_${PN} += "${libdir}/lib*.so ${libdir}/pkgconfig/*"
150FILES_${PN}-dbg += "${libdir}/${BPN}/modules/.debug" 155FILES_${PN}-dbg += "${libdir}/${BPN}/modules/.debug"
151 156
152RDEPENDS_${PN} += "openssl libgcc" 157RDEPENDS_${PN} += "openssl libgcc"
158RDEPENDS_${PN}-scripts += "perl ${PN}"