summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:51 +0100
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:03 -0700
commit9078b0df2026fcf9d2ed287cb713b76907ae7087 (patch)
treee603cfb97abea31fef07a5e03dafc109b2721521 /meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
parentcf1819332d48d3307aa2e80255834aa7911cd0dc (diff)
downloadmeta-openembedded-9078b0df2026fcf9d2ed287cb713b76907ae7087.tar.gz
meta-webserver: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
index df2503421..81151d1a4 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
@@ -57,7 +57,7 @@ EXTRA_OECONF = "--enable-ssl \
57 --enable-mpms-shared \ 57 --enable-mpms-shared \
58 ac_cv_have_threadsafe_pollset=no" 58 ac_cv_have_threadsafe_pollset=no"
59 59
60PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}" 60PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
61PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux" 61PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
62PACKAGECONFIG[openldap] = "--enable-ldap --enable-authnz-ldap,--disable-ldap --disable-authnz-ldap,openldap" 62PACKAGECONFIG[openldap] = "--enable-ldap --enable-authnz-ldap,--disable-ldap --disable-authnz-ldap,openldap"
63 63
@@ -86,7 +86,7 @@ do_install_append() {
86 # Set 'ServerName' to fix error messages when restart apache service 86 # Set 'ServerName' to fix error messages when restart apache service
87 sed -i 's/^#ServerName www.example.com/ServerName localhost/' ${D}/${sysconfdir}/${BPN}/httpd.conf 87 sed -i 's/^#ServerName www.example.com/ServerName localhost/' ${D}/${sysconfdir}/${BPN}/httpd.conf
88 88
89 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 89 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
90 install -d ${D}${sysconfdir}/tmpfiles.d/ 90 install -d ${D}${sysconfdir}/tmpfiles.d/
91 install -m 0644 ${WORKDIR}/apache2-volatile.conf ${D}${sysconfdir}/tmpfiles.d/ 91 install -m 0644 ${WORKDIR}/apache2-volatile.conf ${D}${sysconfdir}/tmpfiles.d/
92 fi 92 fi