diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2014-09-17 15:24:10 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-09-26 05:41:52 +0200 |
commit | 1956582b91afda4612f0e4c84ab59826a3e1a2c1 (patch) | |
tree | ed48919841d6ebfcd5688f3372b02936325a4a4e /meta-systemd | |
parent | 2b47bf3d60e92acca5cd012545c0ea5ffb7615c3 (diff) | |
download | meta-openembedded-1956582b91afda4612f0e4c84ab59826a3e1a2c1.tar.gz |
dhcp: remove parts now merged into OE-Core recipe
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-systemd')
3 files changed, 3 insertions, 36 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcpd.service b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcpd.service deleted file mode 100644 index 70beee92e6..0000000000 --- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcpd.service +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Dynamic Host Configuration Protocol (DHCP) | ||
3 | After=syslog.target network.target | ||
4 | |||
5 | [Service] | ||
6 | Type=forking | ||
7 | PIDFile=/var/run/dhcpd.pid | ||
8 | EnvironmentFile=-/etc/default/dhcp-server | ||
9 | ExecStart=/usr/sbin/dhcpd -cf /etc/dhcp/dhcpd.conf -q $INTERFACES | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcrelay.service b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcrelay.service deleted file mode 100644 index f68f468eef..0000000000 --- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcrelay.service +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=DHCP Relay Agent Daemon | ||
3 | After=syslog.target network.target | ||
4 | |||
5 | [Service] | ||
6 | EnvironmentFile=/etc/default/dhcp-relay | ||
7 | ExecStart=/usr/sbin/dhcrelay -d $DHCRELAYARGS | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend index 1dd6d58eb6..6c0fd02641 100644 --- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend +++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend | |||
@@ -1,16 +1,10 @@ | |||
1 | # look for files in the layer first | 1 | # look for files in the layer first |
2 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 2 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
3 | 3 | ||
4 | inherit systemd | 4 | SYSTEMD_PACKAGES += "dhcp-client" |
5 | |||
6 | SYSTEMD_PACKAGES = "dhcp-server dhcp-relay dhcp-client" | ||
7 | SYSTEMD_SERVICE_dhcp-server = "dhcpd.service" | ||
8 | SYSTEMD_SERVICE_dhcp-relay = "dhcrelay.service" | ||
9 | SYSTEMD_SERVICE_dhcp-client = "dhclient.service" | 5 | SYSTEMD_SERVICE_dhcp-client = "dhclient.service" |
10 | SYSTEMD_AUTO_ENABLE_dhcp-client = "disable" | 6 | SYSTEMD_AUTO_ENABLE_dhcp-client = "disable" |
11 | 7 | ||
12 | FILES_dhcp-server += "${systemd_unitdir}/system/dhcpd.service" | ||
13 | FILES_dhcp-relay += "${systemd_unitdir}/system/dhrelay.service" | ||
14 | FILES_dhcp-client += "${systemd_unitdir}/system/dhclient.service" | 8 | FILES_dhcp-client += "${systemd_unitdir}/system/dhclient.service" |
15 | RPROVIDES_dhcp-server += "dhcp-server-systemd" | 9 | RPROVIDES_dhcp-server += "dhcp-server-systemd" |
16 | RREPLACES_dhcp-server += "dhcp-server-systemd" | 10 | RREPLACES_dhcp-server += "dhcp-server-systemd" |
@@ -22,14 +16,9 @@ RPROVIDES_dhcp-client += "dhcp-client-systemd" | |||
22 | RREPLACES_dhcp-client += "dhcp-client-systemd" | 16 | RREPLACES_dhcp-client += "dhcp-client-systemd" |
23 | RCONFLICTS_dhcp-client += "dhcp-client-systemd" | 17 | RCONFLICTS_dhcp-client += "dhcp-client-systemd" |
24 | 18 | ||
25 | SRC_URI += "file://dhcpd.service \ | 19 | SRC_URI += "file://dhclient.service" |
26 | file://dhclient.service \ | 20 | |
27 | file://dhcrelay.service \ | ||
28 | " | ||
29 | do_install_append() { | 21 | do_install_append() { |
30 | install -d ${D}${systemd_unitdir}/system | ||
31 | install -m 0644 ${WORKDIR}/dhcpd.service ${D}${systemd_unitdir}/system | ||
32 | install -m 0644 ${WORKDIR}/dhclient.service ${D}${systemd_unitdir}/system | 22 | install -m 0644 ${WORKDIR}/dhclient.service ${D}${systemd_unitdir}/system |
33 | install -m 0644 ${WORKDIR}/dhcrelay.service ${D}${systemd_unitdir}/system | ||
34 | } | 23 | } |
35 | 24 | ||