summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-07-17 09:29:38 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-19 11:07:12 +0200
commit36b68478742d60b3f8f49a3f443a28cb6de53158 (patch)
treea86edd9c43f673089fde157ec850a8acbea7fc49 /meta-systemd
parentdf741a297e1190d2dc23a133bc4a0a41118019c6 (diff)
downloadmeta-openembedded-36b68478742d60b3f8f49a3f443a28cb6de53158.tar.gz
systemd: update to 186+git
This is a combined udev+systemd recipe: it will build both udev and systemd in one go, but keep the old (sub)package layout: udev udev-utils udev-systemd systemd systemd-vconsole-setup systemd-analyze systemd-initramfs And all libraries are seperated out: libgudev-1.0-0 libsystemd-daemon0 libsystemd-id128-0 libsystemd-journal0 libsystemd-login0 libudev1 The SRCREV is 94 patches ahead of the v186 tag to drag in compile fixes for 'old' gcc versions like 4.5.x. Runtime tested with build from scratch and opkg upgrade with angstrom Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/gtk-doc.make230
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/modprobe.rules17
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/touchscreen.rules18
-rw-r--r--meta-systemd/recipes-core/systemd/systemd_git.bb93
4 files changed, 344 insertions, 14 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd/gtk-doc.make b/meta-systemd/recipes-core/systemd/systemd/gtk-doc.make
new file mode 100644
index 000000000..57fab9868
--- /dev/null
+++ b/meta-systemd/recipes-core/systemd/systemd/gtk-doc.make
@@ -0,0 +1,230 @@
1# -*- mode: makefile -*-
2
3####################################
4# Everything below here is generic #
5####################################
6
7if GTK_DOC_USE_LIBTOOL
8GTKDOC_CC = $(LIBTOOL) --tag=CC --mode=compile $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
9GTKDOC_LD = $(LIBTOOL) --tag=CC --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
10GTKDOC_RUN = $(LIBTOOL) --mode=execute
11else
12GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
13GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
14GTKDOC_RUN =
15endif
16
17# We set GPATH here; this gives us semantics for GNU make
18# which are more like other make's VPATH, when it comes to
19# whether a source that is a target of one rule is then
20# searched for in VPATH/GPATH.
21#
22GPATH = $(srcdir)
23
24TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
25
26EXTRA_DIST = \
27 $(content_files) \
28 $(HTML_IMAGES) \
29 $(DOC_MAIN_SGML_FILE) \
30 $(DOC_MODULE)-sections.txt \
31 $(DOC_MODULE)-overrides.txt
32
33DOC_STAMPS=scan-build.stamp tmpl-build.stamp sgml-build.stamp html-build.stamp \
34 pdf-build.stamp \
35 $(srcdir)/tmpl.stamp $(srcdir)/sgml.stamp $(srcdir)/html.stamp \
36 $(srcdir)/pdf.stamp
37
38SCANOBJ_FILES = \
39 $(DOC_MODULE).args \
40 $(DOC_MODULE).hierarchy \
41 $(DOC_MODULE).interfaces \
42 $(DOC_MODULE).prerequisites \
43 $(DOC_MODULE).signals
44
45REPORT_FILES = \
46 $(DOC_MODULE)-undocumented.txt \
47 $(DOC_MODULE)-undeclared.txt \
48 $(DOC_MODULE)-unused.txt
49
50CLEANFILES = $(SCANOBJ_FILES) $(REPORT_FILES) $(DOC_STAMPS)
51
52if ENABLE_GTK_DOC
53if GTK_DOC_BUILD_HTML
54HTML_BUILD_STAMP=html-build.stamp
55else
56HTML_BUILD_STAMP=
57endif
58if GTK_DOC_BUILD_PDF
59PDF_BUILD_STAMP=pdf-build.stamp
60else
61PDF_BUILD_STAMP=
62endif
63
64all-local: $(HTML_BUILD_STAMP) $(PDF_BUILD_STAMP)
65else
66all-local:
67endif
68
69docs: $(HTML_BUILD_STAMP) $(PDF_BUILD_STAMP)
70
71$(REPORT_FILES): sgml-build.stamp
72
73#### scan ####
74
75scan-build.stamp: $(HFILE_GLOB) $(CFILE_GLOB)
76 @echo 'gtk-doc: Scanning header files'
77 @-chmod -R u+w $(srcdir)
78 @_source_dir='' ; for i in $(DOC_SOURCE_DIR) ; do \
79 _source_dir="$${_source_dir} --source-dir=$$i" ; \
80 done ; \
81 cd $(srcdir) && \
82 gtkdoc-scan --module=$(DOC_MODULE) --ignore-headers="$(IGNORE_HFILES)" $${_source_dir} $(SCAN_OPTIONS) $(EXTRA_HFILES)
83 @if grep -l '^..*$$' $(srcdir)/$(DOC_MODULE).types > /dev/null 2>&1 ; then \
84 CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" RUN="$(GTKDOC_RUN)" CFLAGS="$(GTKDOC_CFLAGS) $(CFLAGS)" LDFLAGS="$(GTKDOC_LIBS) $(LDFLAGS)" gtkdoc-scangobj $(SCANGOBJ_OPTIONS) --module=$(DOC_MODULE) --output-dir=$(srcdir) ; \
85 else \
86 cd $(srcdir) ; \
87 for i in $(SCANOBJ_FILES) ; do \
88 test -f $$i || touch $$i ; \
89 done \
90 fi
91 @touch scan-build.stamp
92
93$(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt: scan-build.stamp
94 @true
95
96#### templates ####
97
98tmpl-build.stamp: $(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt
99 @echo 'gtk-doc: Rebuilding template files'
100 @-chmod -R u+w $(srcdir)
101 @cd $(srcdir) && gtkdoc-mktmpl --module=$(DOC_MODULE) $(MKTMPL_OPTIONS)
102 @touch tmpl-build.stamp
103
104tmpl.stamp: tmpl-build.stamp
105 @true
106
107$(srcdir)/tmpl/*.sgml:
108 @true
109
110#### xml ####
111
112sgml-build.stamp: tmpl.stamp $(DOC_MODULE)-sections.txt $(srcdir)/tmpl/*.sgml $(expand_content_files)
113 @echo 'gtk-doc: Building XML'
114 @-chmod -R u+w $(srcdir)
115 @_source_dir='' ; for i in $(DOC_SOURCE_DIR) ; do \
116 _source_dir="$${_source_dir} --source-dir=$$i" ; \
117 done ; \
118 cd $(srcdir) && \
119 gtkdoc-mkdb --module=$(DOC_MODULE) --output-format=xml --expand-content-files="$(expand_content_files)" --main-sgml-file=$(DOC_MAIN_SGML_FILE) $${_source_dir} $(MKDB_OPTIONS)
120 @touch sgml-build.stamp
121
122sgml.stamp: sgml-build.stamp
123 @true
124
125#### html ####
126
127html-build.stamp: sgml.stamp $(DOC_MAIN_SGML_FILE) $(content_files)
128 @echo 'gtk-doc: Building HTML'
129 @-chmod -R u+w $(srcdir)
130 @rm -rf $(srcdir)/html
131 @mkdir $(srcdir)/html
132 @mkhtml_options=""; \
133 gtkdoc-mkhtml 2>&1 --help | grep >/dev/null "\-\-path"; \
134 if test "$(?)" = "0"; then \
135 mkhtml_options=--path="$(srcdir)"; \
136 fi; \
137 cd $(srcdir)/html && gtkdoc-mkhtml $$mkhtml_options $(MKHTML_OPTIONS) $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
138 @test "x$(HTML_IMAGES)" = "x" || ( cd $(srcdir) && cp $(HTML_IMAGES) html )
139 @echo 'gtk-doc: Fixing cross-references'
140 @cd $(srcdir) && gtkdoc-fixxref --module=$(DOC_MODULE) --module-dir=html --html-dir=$(HTML_DIR) $(FIXXREF_OPTIONS)
141 @touch html-build.stamp
142
143#### pdf ####
144
145pdf-build.stamp: sgml.stamp $(DOC_MAIN_SGML_FILE) $(content_files)
146 @echo 'gtk-doc: Building PDF'
147 @-chmod -R u+w $(srcdir)
148 @rm -rf $(srcdir)/$(DOC_MODULE).pdf
149 @mkpdf_imgdirs=""; \
150 if test "x$(HTML_IMAGES)" != "x"; then \
151 for img in $(HTML_IMAGES); do \
152 part=`dirname $$img`; \
153 echo $$mkpdf_imgdirs | grep >/dev/null "\-\-imgdir=$$part "; \
154 if test $$? != 0; then \
155 mkpdf_imgdirs="$$mkpdf_imgdirs --imgdir=$$part"; \
156 fi; \
157 done; \
158 fi; \
159 cd $(srcdir) && gtkdoc-mkpdf --path="$(abs_srcdir)" $$mkpdf_imgdirs $(DOC_MODULE) $(DOC_MAIN_SGML_FILE) $(MKPDF_OPTIONS)
160 @touch pdf-build.stamp
161
162##############
163
164clean-local:
165 rm -f *~ *.bak
166 rm -rf .libs
167
168distclean-local:
169 cd $(srcdir) && \
170 rm -rf xml $(REPORT_FILES) $(DOC_MODULE).pdf \
171 $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
172
173maintainer-clean-local: clean
174 cd $(srcdir) && rm -rf xml html
175
176install-data-local:
177 @installfiles=`echo $(srcdir)/html/*`; \
178 if test "$$installfiles" = '$(srcdir)/html/*'; \
179 then echo '-- Nothing to install' ; \
180 else \
181 if test -n "$(DOC_MODULE_VERSION)"; then \
182 installdir="$(DESTDIR)$(TARGET_DIR)-$(DOC_MODULE_VERSION)"; \
183 else \
184 installdir="$(DESTDIR)$(TARGET_DIR)"; \
185 fi; \
186 $(mkinstalldirs) $${installdir} ; \
187 for i in $$installfiles; do \
188 echo '-- Installing '$$i ; \
189 $(INSTALL_DATA) $$i $${installdir}; \
190 done; \
191 if test -n "$(DOC_MODULE_VERSION)"; then \
192 mv -f $${installdir}/$(DOC_MODULE).devhelp2 \
193 $${installdir}/$(DOC_MODULE)-$(DOC_MODULE_VERSION).devhelp2; \
194 mv -f $${installdir}/$(DOC_MODULE).devhelp \
195 $${installdir}/$(DOC_MODULE)-$(DOC_MODULE_VERSION).devhelp; \
196 fi; \
197 $(GTKDOC_REBASE) --relative --dest-dir=$(DESTDIR) --html-dir=$${installdir}; \
198 fi
199
200uninstall-local:
201 @if test -n "$(DOC_MODULE_VERSION)"; then \
202 installdir="$(DESTDIR)$(TARGET_DIR)-$(DOC_MODULE_VERSION)"; \
203 else \
204 installdir="$(DESTDIR)$(TARGET_DIR)"; \
205 fi; \
206 rm -rf $${installdir}
207
208#
209# Require gtk-doc when making dist
210#
211if ENABLE_GTK_DOC
212dist-check-gtkdoc:
213else
214dist-check-gtkdoc:
215 @echo "*** gtk-doc must be installed and enabled in order to make dist"
216 @false
217endif
218
219dist-hook: dist-check-gtkdoc dist-hook-local
220 mkdir $(distdir)/tmpl
221 mkdir $(distdir)/html
222 -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
223 cp $(srcdir)/html/* $(distdir)/html
224 -cp $(srcdir)/$(DOC_MODULE).pdf $(distdir)/
225 -cp $(srcdir)/$(DOC_MODULE).types $(distdir)/
226 -cp $(srcdir)/$(DOC_MODULE)-sections.txt $(distdir)/
227 cd $(distdir) && rm -f $(DISTCLEANFILES)
228 $(GTKDOC_REBASE) --online --relative --html-dir=$(distdir)/html
229
230.PHONY : dist-hook-local docs
diff --git a/meta-systemd/recipes-core/systemd/systemd/modprobe.rules b/meta-systemd/recipes-core/systemd/systemd/modprobe.rules
new file mode 100644
index 000000000..d4a096b82
--- /dev/null
+++ b/meta-systemd/recipes-core/systemd/systemd/modprobe.rules
@@ -0,0 +1,17 @@
1# There are a number of modifiers that are allowed to be used in some
2# of the different fields. They provide the following subsitutions:
3#
4# %n the "kernel number" of the device.
5# For example, 'sda3' has a "kernel number" of '3'
6# %e the smallest number for that name which does not matches an existing node
7# %k the kernel name for the device
8# %M the kernel major number for the device
9# %m the kernel minor number for the device
10# %b the bus id for the device
11# %c the string returned by the PROGRAM
12# %s{filename} the content of a sysfs attribute
13# %% the '%' char itself
14#
15
16# Try and modprobe for drivers for new hardware
17ACTION=="add", DEVPATH=="/devices/*", ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
diff --git a/meta-systemd/recipes-core/systemd/systemd/touchscreen.rules b/meta-systemd/recipes-core/systemd/systemd/touchscreen.rules
new file mode 100644
index 000000000..d83fd1673
--- /dev/null
+++ b/meta-systemd/recipes-core/systemd/systemd/touchscreen.rules
@@ -0,0 +1,18 @@
1# There are a number of modifiers that are allowed to be used in some
2# of the different fields. They provide the following subsitutions:
3#
4# %n the "kernel number" of the device.
5# For example, 'sda3' has a "kernel number" of '3'
6# %e the smallest number for that name which does not matches an existing node
7# %k the kernel name for the device
8# %M the kernel major number for the device
9# %m the kernel minor number for the device
10# %b the bus id for the device
11# %c the string returned by the PROGRAM
12# %s{filename} the content of a sysfs attribute
13# %% the '%' char itself
14#
15
16# Create a symlink to any touchscreen input device
17SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
18SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="ads7846", SYMLINK+="input/touchscreen0"
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb
index f4ca72a12..8af1aa571 100644
--- a/meta-systemd/recipes-core/systemd/systemd_git.bb
+++ b/meta-systemd/recipes-core/systemd/systemd_git.bb
@@ -1,9 +1,14 @@
1DESCRIPTION = "Systemd a init replacement" 1DESCRIPTION = "Systemd a init replacement"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd" 2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
5 3
6DEPENDS = "xz kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline udev dbus libcap libcgroup tcp-wrappers" 4LICENSE = "GPLv2 & LGPLv2.1 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe \
6 file://LICENSE.LGPL2.1;md5=fb919cc88dbe06ec0b0bd50e001ccf1f \
7 file://LICENSE.MIT;md5=544799d0b492f119fa04641d1b8868ed"
8
9PROVIDES = "udev"
10
11DEPENDS = "xz kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline dbus libcap libcgroup tcp-wrappers"
7DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" 12DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
8 13
9SERIAL_CONSOLE ?= "115200 /dev/ttyS0" 14SERIAL_CONSOLE ?= "115200 /dev/ttyS0"
@@ -14,20 +19,17 @@ inherit gitpkgv
14PKGV = "v${GITPKGVTAG}" 19PKGV = "v${GITPKGVTAG}"
15 20
16PV = "git" 21PV = "git"
17PR = "r27" 22PR = "r0"
18 23
19inherit useradd pkgconfig autotools vala perlnative 24inherit useradd pkgconfig autotools vala perlnative
20 25
21SRCREV = "3eff4208ffecedd778fec260f0d4b18e94dab443" 26SRCREV = "cd96b3b86abb4a88cac2722bdfb6e5d4413f6831"
22 27
23SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \ 28SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
24 ${UCLIBCPATCHES} \ 29 file://gtk-doc.make \
30 file://touchscreen.rules \
31 file://modprobe.rules \
25 " 32 "
26UCLIBCPATCHES = ""
27UCLIBCPATCHES_libc-uclibc = "file://paper-over-mkostemp.patch \
28 file://format-replace-m-uclibc.patch \
29 "
30
31LDFLAGS_libc-uclibc_append = " -lrt" 33LDFLAGS_libc-uclibc_append = " -lrt"
32 34
33S = "${WORKDIR}/git" 35S = "${WORKDIR}/git"
@@ -39,17 +41,27 @@ SYSTEMDDISTRO_angstrom = "angstrom"
39EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \ 41EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
40 --with-rootprefix=${base_prefix} \ 42 --with-rootprefix=${base_prefix} \
41 --with-rootlibdir=${base_libdir} \ 43 --with-rootlibdir=${base_libdir} \
44 --sbindir=${base_sbindir} \
45 --libexecdir=${base_libdir} \
42 ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \ 46 ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
43 --disable-gtk \
44 --enable-xz \ 47 --enable-xz \
45 --disable-manpages \ 48 --disable-manpages \
46 --disable-coredump \ 49 --disable-coredump \
50 --disable-introspection \
51 --with-pci-ids-path=/usr/share/misc \
52 ac_cv_file__usr_share_pci_ids=no \
53 ac_cv_file__usr_share_hwdata_pci_ids=no \
54 ac_cv_file__usr_share_misc_pci_ids=yes \
55 --disable-gtk-doc-html \
56 --disable-tcpwrap \
47 " 57 "
48 58
49# There's no docbook-xsl-native, so for the xsltproc check to false 59# There's no docbook-xsl-native, so for the xsltproc check to false
50do_configure_prepend() { 60do_configure_prepend() {
51 sed -i /xsltproc/d configure.ac 61 sed -i /xsltproc/d configure.ac
52 62
63 cp ${WORKDIR}/gtk-doc.make ${S}/docs/
64
53 # we only have /home/root, not /root 65 # we only have /home/root, not /root
54 sed -i -e 's:=/root:=/home/root:g' units/*.service* 66 sed -i -e 's:=/root:=/home/root:g' units/*.service*
55} 67}
@@ -68,6 +80,8 @@ do_install() {
68 # create machine-id 80 # create machine-id
69 # 20:12 < mezcalero> koen: you have three options: a) run systemd-machine-id-setup at install time, b) have / read-only and an empty file there (for stateless) and c) boot with / writable 81 # 20:12 < mezcalero> koen: you have three options: a) run systemd-machine-id-setup at install time, b) have / read-only and an empty file there (for stateless) and c) boot with / writable
70 touch ${D}${sysconfdir}/machine-id 82 touch ${D}${sysconfdir}/machine-id
83
84 install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
71} 85}
72 86
73python populate_packages_prepend (){ 87python populate_packages_prepend (){
@@ -100,10 +114,18 @@ FILES_${PN} = " ${base_bindir}/* \
100 ${datadir}/dbus-1/system-services \ 114 ${datadir}/dbus-1/system-services \
101 ${datadir}/polkit-1 \ 115 ${datadir}/polkit-1 \
102 ${datadir}/${PN} \ 116 ${datadir}/${PN} \
103 ${sysconfdir} \ 117 ${sysconfdir}/bash_completion.d/ \
118 ${sysconfdir}/binfmt.d/ \
119 ${sysconfdir}/dbus-1/ \
120 ${sysconfdir}/machine-id \
121 ${sysconfdir}/modules-load.d/ \
122 ${sysconfdir}/sysctl.d/ \
123 ${sysconfdir}/systemd/ \
124 ${sysconfdir}/tmpfiles.d/ \
125 ${sysconfdir}/xdg/ \
104 ${systemd_unitdir}/* \ 126 ${systemd_unitdir}/* \
105 ${systemd_unitdir}/system/* \ 127 ${systemd_unitdir}/system/* \
106 ${base_libdir}/udev/rules.d \ 128 ${base_libdir}/udev/rules.d/99-systemd.rules \
107 ${base_libdir}/security/*.so \ 129 ${base_libdir}/security/*.so \
108 /cgroup \ 130 /cgroup \
109 ${bindir}/systemd* \ 131 ${bindir}/systemd* \
@@ -114,6 +136,10 @@ FILES_${PN} = " ${base_bindir}/* \
114 ${libdir}/sysctl.d \ 136 ${libdir}/sysctl.d \
115 ${localstatedir} \ 137 ${localstatedir} \
116 ${libexecdir} \ 138 ${libexecdir} \
139 ${base_libdir}/udev/rules.d/70-uaccess.rules \
140 ${base_libdir}/udev/rules.d/71-seat.rules \
141 ${base_libdir}/udev/rules.d/73-seat-late.rules \
142 ${base_libdir}/udev/rules.d/99-systemd.rules \
117 " 143 "
118 144
119FILES_${PN}-dbg += "${systemd_unitdir}/.debug ${systemd_unitdir}/*/.debug ${base_libdir}/security/.debug/" 145FILES_${PN}-dbg += "${systemd_unitdir}/.debug ${systemd_unitdir}/*/.debug ${base_libdir}/security/.debug/"
@@ -136,6 +162,45 @@ RRECOMMENDS_${PN} += "systemd-serialgetty \
136 kernel-module-autofs4 kernel-module-unix kernel-module-ipv6 \ 162 kernel-module-autofs4 kernel-module-unix kernel-module-ipv6 \
137" 163"
138 164
165PACKAGES =+ "udev-dbg udev udev-consolekit udev-utils udev-systemd"
166
167FILES_udev-dbg += "${base_libdir}/udev/.debug"
168
169RDEPENDS_udev += "udev-utils"
170RPROVIDES_udev = "hotplug"
171
172FILES_udev += "${base_libdir}/udev/udevd \
173 ${base_libdir}/systemd/systemd-udevd \
174 ${base_libdir}/udev/accelerometer \
175 ${base_libdir}/udev/ata_id \
176 ${base_libdir}/udev/cdrom_id \
177 ${base_libdir}/udev/collect \
178 ${base_libdir}/udev/findkeyboards \
179 ${base_libdir}/udev/keyboard-force-release.sh \
180 ${base_libdir}/udev/keymap \
181 ${base_libdir}/udev/mtd_probe \
182 ${base_libdir}/udev/scsi_id \
183 ${base_libdir}/udev/v4l_id \
184 ${base_libdir}/udev/keymaps \
185 ${base_libdir}/udev/rules.d/4*.rules \
186 ${base_libdir}/udev/rules.d/5*.rules \
187 ${base_libdir}/udev/rules.d/6*.rules \
188 ${base_libdir}/udev/rules.d/70-power-switch.rules \
189 ${base_libdir}/udev/rules.d/75*.rules \
190 ${base_libdir}/udev/rules.d/78*.rules \
191 ${base_libdir}/udev/rules.d/8*.rules \
192 ${base_libdir}/udev/rules.d/95*.rules \
193 ${sysconfdir}/udev \
194 "
195
196FILES_udev-consolekit += "${libdir}/ConsoleKit"
197RDEPENDS_udev-consolekit += "${@base_contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d)}"
198
199FILES_udev-utils = "${bindir}/udevadm"
200
201FILES_udev-systemd = "${base_libdir}/systemd/system/*udev* ${base_libdir}/systemd/system/*.wants/*udev*"
202RDEPENDS_udev-systemd = "udev"
203
139# TODO: 204# TODO:
140# u-a for runlevel and telinit 205# u-a for runlevel and telinit
141 206