diff options
author | Sander van Grieken <sander@outrightsolutions.nl> | 2012-09-07 11:01:17 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-09-10 10:56:49 +0200 |
commit | 733280b4286264f478f5df68cbb99492509c8961 (patch) | |
tree | ed71a2d26e6d65ac8048bac4bdf3fbf10a91be43 /meta-systemd | |
parent | a5c8e3172008fcff788de63160f994ee7ab91151 (diff) | |
download | meta-openembedded-733280b4286264f478f5df68cbb99492509c8961.tar.gz |
dnsmasq: add systemd service scripts for dnsmasq
Signed-off-by: Sander van Grieken <sander@outrightsolutions.nl>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
-rw-r--r-- | meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq/dnsmasq.service | 13 | ||||
-rw-r--r-- | meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bbappend | 10 |
2 files changed, 23 insertions, 0 deletions
diff --git a/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq/dnsmasq.service b/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq/dnsmasq.service new file mode 100644 index 000000000..549e15e2b --- /dev/null +++ b/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq/dnsmasq.service | |||
@@ -0,0 +1,13 @@ | |||
1 | [Unit] | ||
2 | Description=DNS forwarder and DHCP server | ||
3 | After=network.target | ||
4 | |||
5 | [Service] | ||
6 | Type=forking | ||
7 | PIDFile=/run/dnsmasq.pid | ||
8 | ExecStart=/usr/bin/dnsmasq -x /run/dnsmasq.pid | ||
9 | ExecReload=/bin/kill -HUP $(/bin/cat /run/dnsmasq.pid) | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
13 | |||
diff --git a/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bbappend b/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bbappend new file mode 100644 index 000000000..0a9c77ec7 --- /dev/null +++ b/meta-systemd/meta-oe/recipes-connectivity/dnsmasq/dnsmasq_2.55.bbappend | |||
@@ -0,0 +1,10 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | PRINC := "${@int(PRINC) + 1}" | ||
4 | |||
5 | inherit systemd | ||
6 | |||
7 | SRC_URI += "file://dnsmasq.service" | ||
8 | |||
9 | SYSTEMD_PACKAGES = "${PN}-systemd" | ||
10 | SYSTEMD_SERVICE = "dnsmasq.service" | ||