diff options
author | Khem Raj <raj.khem@gmail.com> | 2012-08-04 20:05:32 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-08-08 09:02:31 +0200 |
commit | 6fd1caa623563f728d87434f5684cf1d3c9b6c53 (patch) | |
tree | 287331d566860e1d77062d04ccfc50609994de31 /meta-systemd | |
parent | b0032dca6939259409f9ea3c925c3af2f757c0b0 (diff) | |
download | meta-openembedded-6fd1caa623563f728d87434f5684cf1d3c9b6c53.tar.gz |
busybox-syslog.service.in: Create alias for syslog.service
The default syslog implementation should make syslog.service a
symlink to itself, so that this socket activates the right actual
syslog service.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
-rw-r--r-- | meta-systemd/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in | 1 | ||||
-rw-r--r-- | meta-systemd/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend | 2 |
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-systemd/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in b/meta-systemd/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in index c6c625ec5..2e0432138 100644 --- a/meta-systemd/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in +++ b/meta-systemd/meta-oe/recipes-core/busybox/busybox/busybox-syslog.service.in | |||
@@ -10,3 +10,4 @@ Sockets=syslog.socket | |||
10 | [Install] | 10 | [Install] |
11 | WantedBy=multi-user.target | 11 | WantedBy=multi-user.target |
12 | Also=busybox-klogd.service | 12 | Also=busybox-klogd.service |
13 | Alias=syslog.service | ||
diff --git a/meta-systemd/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend b/meta-systemd/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend index 915a50ebf..bb1155074 100644 --- a/meta-systemd/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend +++ b/meta-systemd/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend | |||
@@ -1,6 +1,6 @@ | |||
1 | inherit systemd | 1 | inherit systemd |
2 | 2 | ||
3 | PRINC := "${@int(PRINC) + 2}" | 3 | PRINC := "${@int(PRINC) + 3}" |
4 | 4 | ||
5 | # look for files in the layer first | 5 | # look for files in the layer first |
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 6 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |