diff options
author | Khem Raj <raj.khem@gmail.com> | 2012-08-24 14:49:30 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-08-27 14:42:44 +0200 |
commit | 525ac87a315ba9149c4add4cec89db50b0a33068 (patch) | |
tree | 1bf948976aa7b75c45c97aef53c2475037b8901c /meta-systemd | |
parent | 8d55a7f24fa25fbe8efd19db5c2af97e27dc369c (diff) | |
download | meta-openembedded-525ac87a315ba9149c4add4cec89db50b0a33068.tar.gz |
systemd: Refresh the uclibc specific patches
Make sure that patches apply on top of latest systemd
some source files have moved around.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
3 files changed, 32 insertions, 37 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd/format-replace-m-uclibc.patch b/meta-systemd/recipes-core/systemd/systemd/format-replace-m-uclibc.patch index dd86121bb..a2885fa2c 100644 --- a/meta-systemd/recipes-core/systemd/systemd/format-replace-m-uclibc.patch +++ b/meta-systemd/recipes-core/systemd/systemd/format-replace-m-uclibc.patch | |||
@@ -9,9 +9,9 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
9 | 9 | ||
10 | Index: git/src/mount-setup.c | 10 | Index: git/src/mount-setup.c |
11 | =================================================================== | 11 | =================================================================== |
12 | --- git.orig/src/mount-setup.c 2012-01-26 21:15:12.573084007 -0800 | 12 | --- git.orig/src/mount-setup.c 2012-06-23 17:48:06.153735209 -0700 |
13 | +++ git/src/mount-setup.c 2012-01-26 21:15:16.005084174 -0800 | 13 | +++ git/src/mount-setup.c 2012-06-23 17:48:07.109735255 -0700 |
14 | @@ -182,10 +182,10 @@ | 14 | @@ -184,10 +184,10 @@ |
15 | (void) fgets(buf, sizeof(buf), f); | 15 | (void) fgets(buf, sizeof(buf), f); |
16 | 16 | ||
17 | for (;;) { | 17 | for (;;) { |
@@ -24,7 +24,7 @@ Index: git/src/mount-setup.c | |||
24 | 24 | ||
25 | if (feof(f)) | 25 | if (feof(f)) |
26 | break; | 26 | break; |
27 | @@ -196,14 +196,12 @@ | 27 | @@ -198,14 +198,12 @@ |
28 | } | 28 | } |
29 | 29 | ||
30 | if (!enabled) { | 30 | if (!enabled) { |
@@ -39,7 +39,7 @@ Index: git/src/mount-setup.c | |||
39 | goto finish; | 39 | goto finish; |
40 | } | 40 | } |
41 | } | 41 | } |
42 | @@ -273,7 +271,6 @@ | 42 | @@ -275,7 +273,6 @@ |
43 | p.fatal = false; | 43 | p.fatal = false; |
44 | 44 | ||
45 | r = mount_one(&p, true); | 45 | r = mount_one(&p, true); |
@@ -49,8 +49,8 @@ Index: git/src/mount-setup.c | |||
49 | if (r < 0) { | 49 | if (r < 0) { |
50 | Index: git/src/socket-util.c | 50 | Index: git/src/socket-util.c |
51 | =================================================================== | 51 | =================================================================== |
52 | --- git.orig/src/socket-util.c 2012-01-26 21:15:12.593084008 -0800 | 52 | --- git.orig/src/socket-util.c 2012-06-23 17:48:06.177735209 -0700 |
53 | +++ git/src/socket-util.c 2012-01-26 21:15:16.005084174 -0800 | 53 | +++ git/src/socket-util.c 2012-06-23 17:48:07.109735255 -0700 |
54 | @@ -192,7 +192,7 @@ | 54 | @@ -192,7 +192,7 @@ |
55 | int socket_address_parse_netlink(SocketAddress *a, const char *s) { | 55 | int socket_address_parse_netlink(SocketAddress *a, const char *s) { |
56 | int family; | 56 | int family; |
@@ -81,9 +81,9 @@ Index: git/src/socket-util.c | |||
81 | 81 | ||
82 | Index: git/src/swap.c | 82 | Index: git/src/swap.c |
83 | =================================================================== | 83 | =================================================================== |
84 | --- git.orig/src/swap.c 2012-01-26 21:15:12.593084008 -0800 | 84 | --- git.orig/src/swap.c 2012-06-23 17:48:06.181735209 -0700 |
85 | +++ git/src/swap.c 2012-01-26 21:15:16.005084174 -0800 | 85 | +++ git/src/swap.c 2012-06-23 17:48:07.113735256 -0700 |
86 | @@ -1049,11 +1049,12 @@ | 86 | @@ -1060,11 +1060,12 @@ |
87 | (void) fscanf(m->proc_swaps, "%*s %*s %*s %*s %*s\n"); | 87 | (void) fscanf(m->proc_swaps, "%*s %*s %*s %*s %*s\n"); |
88 | 88 | ||
89 | for (i = 1;; i++) { | 89 | for (i = 1;; i++) { |
@@ -98,7 +98,7 @@ Index: git/src/swap.c | |||
98 | "%*s " /* type of swap */ | 98 | "%*s " /* type of swap */ |
99 | "%*s " /* swap size */ | 99 | "%*s " /* swap size */ |
100 | "%*s " /* used */ | 100 | "%*s " /* used */ |
101 | @@ -1064,12 +1065,10 @@ | 101 | @@ -1075,12 +1076,10 @@ |
102 | break; | 102 | break; |
103 | 103 | ||
104 | log_warning("Failed to parse /proc/swaps:%u.", i); | 104 | log_warning("Failed to parse /proc/swaps:%u.", i); |
@@ -113,8 +113,8 @@ Index: git/src/swap.c | |||
113 | return -ENOMEM; | 113 | return -ENOMEM; |
114 | Index: git/src/tmpfiles.c | 114 | Index: git/src/tmpfiles.c |
115 | =================================================================== | 115 | =================================================================== |
116 | --- git.orig/src/tmpfiles.c 2012-01-26 21:15:12.617084010 -0800 | 116 | --- git.orig/src/tmpfiles.c 2012-06-23 17:48:06.189735211 -0700 |
117 | +++ git/src/tmpfiles.c 2012-01-26 23:17:01.185437712 -0800 | 117 | +++ git/src/tmpfiles.c 2012-06-24 12:52:14.857057613 -0700 |
118 | @@ -73,8 +73,8 @@ | 118 | @@ -73,8 +73,8 @@ |
119 | typedef struct Item { | 119 | typedef struct Item { |
120 | ItemType type; | 120 | ItemType type; |
@@ -126,15 +126,7 @@ Index: git/src/tmpfiles.c | |||
126 | uid_t uid; | 126 | uid_t uid; |
127 | gid_t gid; | 127 | gid_t gid; |
128 | mode_t mode; | 128 | mode_t mode; |
129 | @@ -822,7 +822,6 @@ | 129 | @@ -858,8 +858,6 @@ |
130 | case CREATE_CHAR_DEVICE: | ||
131 | case CREATE_BLOCK_DEVICE: | ||
132 | case IGNORE_PATH: | ||
133 | - case RELABEL_PATH: | ||
134 | case RECURSIVE_RELABEL_PATH: | ||
135 | case WRITE_FILE: | ||
136 | break; | ||
137 | @@ -858,8 +857,6 @@ | ||
138 | static void item_free(Item *i) { | 130 | static void item_free(Item *i) { |
139 | assert(i); | 131 | assert(i); |
140 | 132 | ||
@@ -143,7 +135,7 @@ Index: git/src/tmpfiles.c | |||
143 | free(i); | 135 | free(i); |
144 | } | 136 | } |
145 | 137 | ||
146 | @@ -906,7 +903,7 @@ | 138 | @@ -906,7 +904,7 @@ |
147 | 139 | ||
148 | static int parse_line(const char *fname, unsigned line, const char *buffer) { | 140 | static int parse_line(const char *fname, unsigned line, const char *buffer) { |
149 | Item *i, *existing; | 141 | Item *i, *existing; |
@@ -152,7 +144,7 @@ Index: git/src/tmpfiles.c | |||
152 | char type; | 144 | char type; |
153 | Hashmap *h; | 145 | Hashmap *h; |
154 | int r, n = -1; | 146 | int r, n = -1; |
155 | @@ -923,18 +920,18 @@ | 147 | @@ -923,18 +921,18 @@ |
156 | 148 | ||
157 | if (sscanf(buffer, | 149 | if (sscanf(buffer, |
158 | "%c " | 150 | "%c " |
@@ -180,7 +172,7 @@ Index: git/src/tmpfiles.c | |||
180 | &n) < 2) { | 172 | &n) < 2) { |
181 | log_error("[%s:%u] Syntax error.", fname, line); | 173 | log_error("[%s:%u] Syntax error.", fname, line); |
182 | r = -EIO; | 174 | r = -EIO; |
183 | @@ -944,7 +941,7 @@ | 175 | @@ -944,7 +942,7 @@ |
184 | if (n >= 0) { | 176 | if (n >= 0) { |
185 | n += strspn(buffer+n, WHITESPACE); | 177 | n += strspn(buffer+n, WHITESPACE); |
186 | if (buffer[n] != 0 && (buffer[n] != '-' || buffer[n+1] != 0)) { | 178 | if (buffer[n] != 0 && (buffer[n] != '-' || buffer[n+1] != 0)) { |
@@ -189,7 +181,7 @@ Index: git/src/tmpfiles.c | |||
189 | if (!i->argument) { | 181 | if (!i->argument) { |
190 | log_error("Out of memory"); | 182 | log_error("Out of memory"); |
191 | return -ENOMEM; | 183 | return -ENOMEM; |
192 | @@ -1096,11 +1093,6 @@ | 184 | @@ -1096,11 +1094,6 @@ |
193 | r = 0; | 185 | r = 0; |
194 | 186 | ||
195 | finish: | 187 | finish: |
@@ -203,8 +195,8 @@ Index: git/src/tmpfiles.c | |||
203 | 195 | ||
204 | Index: git/src/mount.c | 196 | Index: git/src/mount.c |
205 | =================================================================== | 197 | =================================================================== |
206 | --- git.orig/src/mount.c 2012-01-26 21:15:12.573084007 -0800 | 198 | --- git.orig/src/mount.c 2012-06-23 17:48:06.153735209 -0700 |
207 | +++ git/src/mount.c 2012-01-26 21:15:16.005084174 -0800 | 199 | +++ git/src/mount.c 2012-06-23 17:48:07.113735256 -0700 |
208 | @@ -24,6 +24,7 @@ | 200 | @@ -24,6 +24,7 @@ |
209 | #include <mntent.h> | 201 | #include <mntent.h> |
210 | #include <sys/epoll.h> | 202 | #include <sys/epoll.h> |
@@ -213,7 +205,7 @@ Index: git/src/mount.c | |||
213 | 205 | ||
214 | #include "unit.h" | 206 | #include "unit.h" |
215 | #include "mount.h" | 207 | #include "mount.h" |
216 | @@ -1561,7 +1562,13 @@ | 208 | @@ -1591,7 +1592,13 @@ |
217 | static int mount_load_proc_self_mountinfo(Manager *m, bool set_flags) { | 209 | static int mount_load_proc_self_mountinfo(Manager *m, bool set_flags) { |
218 | int r = 0; | 210 | int r = 0; |
219 | unsigned i; | 211 | unsigned i; |
@@ -228,7 +220,7 @@ Index: git/src/mount.c | |||
228 | 220 | ||
229 | assert(m); | 221 | assert(m); |
230 | 222 | ||
231 | @@ -1570,26 +1577,26 @@ | 223 | @@ -1600,26 +1607,26 @@ |
232 | for (i = 1;; i++) { | 224 | for (i = 1;; i++) { |
233 | int k; | 225 | int k; |
234 | 226 | ||
@@ -266,7 +258,7 @@ Index: git/src/mount.c | |||
266 | 258 | ||
267 | if (k == EOF) | 259 | if (k == EOF) |
268 | break; | 260 | break; |
269 | @@ -1613,22 +1620,12 @@ | 261 | @@ -1643,22 +1650,12 @@ |
270 | r = k; | 262 | r = k; |
271 | 263 | ||
272 | clean_up: | 264 | clean_up: |
@@ -291,8 +283,8 @@ Index: git/src/mount.c | |||
291 | free(o); | 283 | free(o); |
292 | Index: git/src/umount.c | 284 | Index: git/src/umount.c |
293 | =================================================================== | 285 | =================================================================== |
294 | --- git.orig/src/umount.c 2012-01-26 21:15:12.617084010 -0800 | 286 | --- git.orig/src/umount.c 2012-06-23 17:48:06.189735211 -0700 |
295 | +++ git/src/umount.c 2012-01-26 21:15:16.005084174 -0800 | 287 | +++ git/src/umount.c 2012-06-23 17:48:07.113735256 -0700 |
296 | @@ -60,7 +60,9 @@ | 288 | @@ -60,7 +60,9 @@ |
297 | 289 | ||
298 | static int mount_points_list_get(MountPoint **head) { | 290 | static int mount_points_list_get(MountPoint **head) { |
diff --git a/meta-systemd/recipes-core/systemd/systemd/paper-over-mkostemp.patch b/meta-systemd/recipes-core/systemd/systemd/paper-over-mkostemp.patch index ca10440a8..ae4f6def3 100644 --- a/meta-systemd/recipes-core/systemd/systemd/paper-over-mkostemp.patch +++ b/meta-systemd/recipes-core/systemd/systemd/paper-over-mkostemp.patch | |||
@@ -2,10 +2,10 @@ uclibc does not have mkostemp() so we redefine it to use mkstemp() | |||
2 | 2 | ||
3 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 3 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
4 | 4 | ||
5 | Index: git/src/macro.h | 5 | Index: git/src/shared/macro.h |
6 | =================================================================== | 6 | =================================================================== |
7 | --- git.orig/src/macro.h 2011-06-30 10:33:53.000000000 -0700 | 7 | --- git.orig/src/shared/macro.h 2012-08-23 22:13:18.618931300 -0700 |
8 | +++ git/src/macro.h 2011-06-30 15:07:28.285270006 -0700 | 8 | +++ git/src/shared/macro.h 2012-08-23 22:15:05.558935366 -0700 |
9 | @@ -27,6 +27,10 @@ | 9 | @@ -27,6 +27,10 @@ |
10 | #include <sys/uio.h> | 10 | #include <sys/uio.h> |
11 | #include <inttypes.h> | 11 | #include <inttypes.h> |
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb index b1cc9c394..549651268 100644 --- a/meta-systemd/recipes-core/systemd/systemd_git.bb +++ b/meta-systemd/recipes-core/systemd/systemd_git.bb | |||
@@ -32,8 +32,11 @@ SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \ | |||
32 | file://touchscreen.rules \ | 32 | file://touchscreen.rules \ |
33 | file://modprobe.rules \ | 33 | file://modprobe.rules \ |
34 | file://var-run.conf \ | 34 | file://var-run.conf \ |
35 | ${UCLIBCPATCHES} \ | ||
35 | " | 36 | " |
36 | 37 | UCLIBCPATCHES = "" | |
38 | UCLIBCPATCHES_libc-uclibc = "file://paper-over-mkostemp.patch \ | ||
39 | " | ||
37 | LDFLAGS_libc-uclibc_append = " -lrt" | 40 | LDFLAGS_libc-uclibc_append = " -lrt" |
38 | 41 | ||
39 | S = "${WORKDIR}/git" | 42 | S = "${WORKDIR}/git" |