summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-10-10 05:03:42 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-23 08:33:29 +0200
commitfb368b0790a2804080f28b75cf27dcffde763c37 (patch)
treecefd4b3021225f26255a6cd10ef37831da52baa6 /meta-systemd
parent2c1f670d731fb1c4a2167b110e9ae1c3288a8108 (diff)
downloadmeta-openembedded-fb368b0790a2804080f28b75cf27dcffde763c37.tar.gz
systemd: Upgrade past v194
Booted on eglibc i586, arm, ppc qemu systems Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/optional_secure_getenv.patch19
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/systemd-pam-fix-execvpe.patch39
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch31
-rw-r--r--meta-systemd/recipes-core/systemd/systemd_git.bb4
4 files changed, 61 insertions, 32 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd/optional_secure_getenv.patch b/meta-systemd/recipes-core/systemd/systemd/optional_secure_getenv.patch
new file mode 100644
index 000000000..35f1467c5
--- /dev/null
+++ b/meta-systemd/recipes-core/systemd/systemd/optional_secure_getenv.patch
@@ -0,0 +1,19 @@
1on uclibc secure_getenv is not available
2therefore default to using getenv instead
3
4Singed-off-by: Khem Raj <raj.khem@gmail.com>
5
6Upstream-Status: Pending
7Index: git/src/shared/missing.h
8===================================================================
9--- git.orig/src/shared/missing.h 2012-09-22 18:46:44.141282145 -0700
10+++ git/src/shared/missing.h 2012-09-22 18:48:44.081276570 -0700
11@@ -233,6 +233,8 @@
12 #ifndef HAVE_SECURE_GETENV
13 # ifdef HAVE___SECURE_GETENV
14 # define secure_getenv __secure_getenv
15+# elif defined __UCLIBC__
16+# define secure_getenv getenv
17 # else
18 # error neither secure_getenv nor __secure_getenv are available
19 # endif
diff --git a/meta-systemd/recipes-core/systemd/systemd/systemd-pam-fix-execvpe.patch b/meta-systemd/recipes-core/systemd/systemd/systemd-pam-fix-execvpe.patch
index ea8b3ffb1..449c27f88 100644
--- a/meta-systemd/recipes-core/systemd/systemd/systemd-pam-fix-execvpe.patch
+++ b/meta-systemd/recipes-core/systemd/systemd/systemd-pam-fix-execvpe.patch
@@ -1,29 +1,26 @@
1--- systemd-pam-185/src/nspawn/nspawn.c.orig 2012-06-21 05:31:24.000000000 -0400 1Index: git/src/nspawn/nspawn.c
2+++ systemd-pam-185/src/nspawn/nspawn.c 2012-06-21 05:29:50.000000000 -0400 2===================================================================
3@@ -61,6 +61,8 @@ 3--- git.orig/src/nspawn/nspawn.c 2012-09-22 17:57:05.000000000 -0700
4 #include "path-util.h" 4+++ git/src/nspawn/nspawn.c 2012-09-22 18:01:41.541405768 -0700
5 #include "loopback-setup.h" 5@@ -63,6 +63,8 @@
6 LINK_GUEST
7 } LinkJournal;
6 8
7+#include "config.h" 9+#include "config.h"
8+ 10+
9 static char *arg_directory = NULL; 11 static char *arg_directory = NULL;
10 static char *arg_user = NULL; 12 static char *arg_user = NULL;
11 static char **arg_controllers = NULL; 13 static char **arg_controllers = NULL;
12@@ -1315,9 +1317,14 @@ 14@@ -1373,7 +1375,12 @@
13 15 a[0] = (char*) "/sbin/init";
14 a[0] = (char*) "/sbin/init"; 16 execve(a[0], a, (char**) envp);
15 execve(a[0], a, (char**) envp); 17 } else if (argc > optind)
16- } else if (argc > optind)
17- execvpe(argv[optind], argv + optind, (char**) envp);
18- else {
19+ } else if (argc > optind) {
20+#ifdef HAVE_EXECVPE 18+#ifdef HAVE_EXECVPE
21+ execvpe(argv[optind], argv + optind, (char**) envp); 19 execvpe(argv[optind], argv + optind, (char**) envp);
22+#else 20+#else
23+ environ = (char **)envp; 21+ environ = (char **)envp;
24+ execvp(argv[optind], argv + optind); 22+ execvp(argv[optind], argv + optind);
25+#endif /* HAVE_EXECVPE */ 23+#endif /* HAVE_EXECVPE */
26+ } else { 24 else {
27 chdir(home ? home : "/root"); 25 chdir(home ? home : "/root");
28 execle("/bin/bash", "-bash", NULL, (char**) envp); 26 execle("/bin/bash", "-bash", NULL, (char**) envp);
29 }
diff --git a/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch b/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch
index 216721684..4c471b673 100644
--- a/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch
+++ b/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch
@@ -11,17 +11,19 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
11 11
12Index: git/Makefile.am 12Index: git/Makefile.am
13=================================================================== 13===================================================================
14--- git.orig/Makefile.am 2012-07-22 16:20:38.424405916 -0700 14--- git.orig/Makefile.am 2012-09-22 11:07:58.811981199 -0700
15+++ git/Makefile.am 2012-07-22 16:23:21.232406621 -0700 15+++ git/Makefile.am 2012-09-22 11:09:11.267983956 -0700
16@@ -61,23 +61,23 @@ 16@@ -64,25 +64,25 @@
17 17
18 # Our own, non-special dirs 18 # Our own, non-special dirs
19 pkgsysconfdir=$(sysconfdir)/systemd 19 pkgsysconfdir=$(sysconfdir)/systemd
20-userunitdir=$(prefix)/lib/systemd/user 20-userunitdir=$(prefix)/lib/systemd/user
21-userpresetdir=$(prefix)/lib/systemd/user-preset
21-tmpfilesdir=$(prefix)/lib/tmpfiles.d 22-tmpfilesdir=$(prefix)/lib/tmpfiles.d
22-sysctldir=$(prefix)/lib/sysctl.d 23-sysctldir=$(prefix)/lib/sysctl.d
23-usergeneratordir=$(prefix)/lib/systemd/user-generators 24-usergeneratordir=$(prefix)/lib/systemd/user-generators
24+userunitdir=$(prefix)/$(rootlibdir)/systemd/user 25+userunitdir=$(prefix)/$(rootlibdir)/systemd/user
26+userpresetdir=$(prefix)/$(rootlibdir)/systemd/user-preset
25+tmpfilesdir=$(prefix)/$(rootlibdir)/tmpfiles.d 27+tmpfilesdir=$(prefix)/$(rootlibdir)/tmpfiles.d
26+sysctldir=$(prefix)/$(rootlibdir)/sysctl.d 28+sysctldir=$(prefix)/$(rootlibdir)/sysctl.d
27+usergeneratordir=$(prefix)/$(rootlibdir)/systemd/user-generators 29+usergeneratordir=$(prefix)/$(rootlibdir)/systemd/user-generators
@@ -30,8 +32,10 @@ Index: git/Makefile.am
30 systemshutdowndir=$(rootlibexecdir)/system-shutdown 32 systemshutdowndir=$(rootlibexecdir)/system-shutdown
31 systemsleepdir=$(rootlibexecdir)/system-sleep 33 systemsleepdir=$(rootlibexecdir)/system-sleep
32-systemunitdir=$(rootprefix)/lib/systemd/system 34-systemunitdir=$(rootprefix)/lib/systemd/system
35-systempresetdir=$(rootprefix)/lib/systemd/system-preset
33-udevlibexecdir=$(rootprefix)/lib/udev 36-udevlibexecdir=$(rootprefix)/lib/udev
34+systemunitdir=$(rootprefix)/$(rootlibdir)/systemd/system 37+systemunitdir=$(rootprefix)/$(rootlibdir)/systemd/system
38+systempresetdir=$(rootprefix)/$(rootlibdir)/systemd/system-preset
35+udevlibexecdir=$(rootprefix)/$(rootlibdir)/udev 39+udevlibexecdir=$(rootprefix)/$(rootlibdir)/udev
36 udevhomedir = $(udevlibexecdir) 40 udevhomedir = $(udevlibexecdir)
37 udevrulesdir = $(udevlibexecdir)/rules.d 41 udevrulesdir = $(udevlibexecdir)/rules.d
@@ -42,9 +46,9 @@ Index: git/Makefile.am
42-rootlibexecdir=$(rootprefix)/lib/systemd 46-rootlibexecdir=$(rootprefix)/lib/systemd
43+rootlibexecdir=$(rootprefix)/$(rootlibdir)/systemd 47+rootlibexecdir=$(rootprefix)/$(rootlibdir)/systemd
44 48
45 CLEANFILES = 49 CLEANFILES = $(BUILT_SOURCES)
46 EXTRA_DIST = 50 EXTRA_DIST =
47@@ -126,7 +126,7 @@ 51@@ -132,7 +132,7 @@
48 -DSYSTEMD_STDIO_BRIDGE_BINARY_PATH=\"$(bindir)/systemd-stdio-bridge\" \ 52 -DSYSTEMD_STDIO_BRIDGE_BINARY_PATH=\"$(bindir)/systemd-stdio-bridge\" \
49 -DROOTPREFIX=\"$(rootprefix)\" \ 53 -DROOTPREFIX=\"$(rootprefix)\" \
50 -DRUNTIME_DIR=\"/run\" \ 54 -DRUNTIME_DIR=\"/run\" \
@@ -53,7 +57,7 @@ Index: git/Makefile.am
53 -DSYSTEMD_CRYPTSETUP_PATH=\"$(rootlibexecdir)/systemd-cryptsetup\" \ 57 -DSYSTEMD_CRYPTSETUP_PATH=\"$(rootlibexecdir)/systemd-cryptsetup\" \
54 -DSYSTEM_GENERATOR_PATH=\"$(systemgeneratordir)\" \ 58 -DSYSTEM_GENERATOR_PATH=\"$(systemgeneratordir)\" \
55 -DUSER_GENERATOR_PATH=\"$(usergeneratordir)\" \ 59 -DUSER_GENERATOR_PATH=\"$(usergeneratordir)\" \
56@@ -2535,7 +2535,7 @@ 60@@ -2692,7 +2692,7 @@
57 61
58 binfmt-install-data-hook: 62 binfmt-install-data-hook:
59 $(MKDIR_P) -m 0755 \ 63 $(MKDIR_P) -m 0755 \
@@ -62,7 +66,16 @@ Index: git/Makefile.am
62 $(DESTDIR)$(sysconfdir)/binfmt.d \ 66 $(DESTDIR)$(sysconfdir)/binfmt.d \
63 $(DESTDIR)$(systemunitdir)/sysinit.target.wants 67 $(DESTDIR)$(systemunitdir)/sysinit.target.wants
64 ( cd $(DESTDIR)$(systemunitdir)/sysinit.target.wants && \ 68 ( cd $(DESTDIR)$(systemunitdir)/sysinit.target.wants && \
65@@ -3165,7 +3165,7 @@ 69@@ -3107,7 +3107,7 @@
70
71 timedated-install-data-hook:
72 $(MKDIR_P) -m 0755 \
73- $(DESTDIR)$(prefix)/lib/systemd/ntp-units.d \
74+ $(DESTDIR)$(prefix)/$(rootlibdir)/systemd/ntp-units.d \
75 $(DESTDIR)$(sysconfdir)/systemd/ntp-units.d
76 ( cd $(DESTDIR)$(systemunitdir) && \
77 rm -f dbus-org.freedesktop.timedate1.service && \
78@@ -3337,7 +3337,7 @@
66 logind-install-data-hook: 79 logind-install-data-hook:
67 $(MKDIR_P) -m 0755 \ 80 $(MKDIR_P) -m 0755 \
68 $(DESTDIR)$(systemunitdir)/multi-user.target.wants \ 81 $(DESTDIR)$(systemunitdir)/multi-user.target.wants \
@@ -71,7 +84,7 @@ Index: git/Makefile.am
71 ( cd $(DESTDIR)$(systemunitdir) && \ 84 ( cd $(DESTDIR)$(systemunitdir) && \
72 rm -f dbus-org.freedesktop.login1.service && \ 85 rm -f dbus-org.freedesktop.login1.service && \
73 $(LN_S) systemd-logind.service dbus-org.freedesktop.login1.service) 86 $(LN_S) systemd-logind.service dbus-org.freedesktop.login1.service)
74@@ -3284,7 +3284,7 @@ 87@@ -3494,7 +3494,7 @@
75 -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \ 88 -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
76 -e 's,@PACKAGE_NAME\@,$(PACKAGE_NAME),g' \ 89 -e 's,@PACKAGE_NAME\@,$(PACKAGE_NAME),g' \
77 -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' \ 90 -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' \
@@ -80,7 +93,7 @@ Index: git/Makefile.am
80 -e 's,@prefix\@,$(prefix),g' \ 93 -e 's,@prefix\@,$(prefix),g' \
81 -e 's,@exec_prefix\@,$(exec_prefix),g' \ 94 -e 's,@exec_prefix\@,$(exec_prefix),g' \
82 -e 's,@libdir\@,$(libdir),g' \ 95 -e 's,@libdir\@,$(libdir),g' \
83@@ -3407,9 +3407,9 @@ 96@@ -3619,9 +3619,9 @@
84 $(MKDIR_P) -m 0755 \ 97 $(MKDIR_P) -m 0755 \
85 $(DESTDIR)$(tmpfilesdir) \ 98 $(DESTDIR)$(tmpfilesdir) \
86 $(DESTDIR)$(sysconfdir)/tmpfiles.d \ 99 $(DESTDIR)$(sysconfdir)/tmpfiles.d \
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb
index 337424eec..512f5d477 100644
--- a/meta-systemd/recipes-core/systemd/systemd_git.bb
+++ b/meta-systemd/recipes-core/systemd/systemd_git.bb
@@ -23,8 +23,7 @@ PR = "r7"
23 23
24inherit useradd pkgconfig autotools perlnative 24inherit useradd pkgconfig autotools perlnative
25 25
26SRCREV = "38a60d7112d33ffd596b23e8df53d75a7c09e71b" 26SRCREV = "a3eb665e0c12df35e807611582e7332ebed325b1"
27
28SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \ 27SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
29 file://use-rootlibdir.patch \ 28 file://use-rootlibdir.patch \
30 file://gtk-doc.make \ 29 file://gtk-doc.make \
@@ -40,6 +39,7 @@ UCLIBCPATCHES_libc-uclibc = "file://systemd-pam-configure-check-uclibc.patch \
40 file://systemd-pam-fix-getty-unit.patch \ 39 file://systemd-pam-fix-getty-unit.patch \
41 file://systemd-pam-fix-mkostemp.patch \ 40 file://systemd-pam-fix-mkostemp.patch \
42 file://systemd-pam-fix-msformat.patch \ 41 file://systemd-pam-fix-msformat.patch \
42 file://optional_secure_getenv.patch \
43 " 43 "
44LDFLAGS_libc-uclibc_append = " -lrt" 44LDFLAGS_libc-uclibc_append = " -lrt"
45 45