diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-03 14:41:14 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-11 01:52:55 +0100 |
commit | 6f6b66780acf161407bbc9f46f74e31fe215939d (patch) | |
tree | 43975293cff9913038d01857e346dfc071aa5d57 /meta-systemd | |
parent | 76ef4020368c7f50e05f2989691d1b6c0499ad46 (diff) | |
download | meta-openembedded-6f6b66780acf161407bbc9f46f74e31fe215939d.tar.gz |
systemd: reenable python and add python-systemd-journald
* we need inherit pythonnative to find right python-native
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r-- | meta-systemd/recipes-core/systemd/systemd_git.bb | 22 |
1 files changed, 15 insertions, 7 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb index 51d337157..341e85d0c 100644 --- a/meta-systemd/recipes-core/systemd/systemd_git.bb +++ b/meta-systemd/recipes-core/systemd/systemd_git.bb | |||
@@ -19,9 +19,15 @@ inherit gitpkgv | |||
19 | PKGV = "v${GITPKGVTAG}" | 19 | PKGV = "v${GITPKGVTAG}" |
20 | 20 | ||
21 | PV = "git" | 21 | PV = "git" |
22 | PR = "r10" | 22 | PR = "r11" |
23 | 23 | ||
24 | inherit useradd pkgconfig autotools perlnative | 24 | # need to export these variables for python-config to work |
25 | export BUILD_SYS | ||
26 | export HOST_SYS | ||
27 | export STAGING_INCDIR | ||
28 | export STAGING_LIBDIR | ||
29 | |||
30 | inherit useradd pkgconfig autotools perlnative pythonnative python-dir | ||
25 | 31 | ||
26 | SRCREV = "4d92e078e9d7e9a9d346065ea5e4afbafbdadb48" | 32 | SRCREV = "4d92e078e9d7e9a9d346065ea5e4afbafbdadb48" |
27 | SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \ | 33 | SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \ |
@@ -67,7 +73,7 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \ | |||
67 | --disable-tcpwrap \ | 73 | --disable-tcpwrap \ |
68 | --enable-split-usr \ | 74 | --enable-split-usr \ |
69 | --disable-microhttpd \ | 75 | --disable-microhttpd \ |
70 | --without-python \ | 76 | --with-python \ |
71 | " | 77 | " |
72 | 78 | ||
73 | # There's no docbook-xsl-native, so for the xsltproc check to false | 79 | # There's no docbook-xsl-native, so for the xsltproc check to false |
@@ -107,7 +113,7 @@ python populate_packages_prepend (){ | |||
107 | } | 113 | } |
108 | PACKAGES_DYNAMIC += "^lib(udev|gudev|systemd).*" | 114 | PACKAGES_DYNAMIC += "^lib(udev|gudev|systemd).*" |
109 | 115 | ||
110 | PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze" | 116 | PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze python-${PN}-journal" |
111 | 117 | ||
112 | USERADD_PACKAGES = "${PN}" | 118 | USERADD_PACKAGES = "${PN}" |
113 | GROUPADD_PARAM_${PN} = "-r lock" | 119 | GROUPADD_PARAM_${PN} = "-r lock" |
@@ -116,6 +122,9 @@ FILES_${PN}-analyze = "${bindir}/systemd-analyze" | |||
116 | RDEPENDS_${PN}-analyze = "python-dbus" | 122 | RDEPENDS_${PN}-analyze = "python-dbus" |
117 | RRECOMMENDS_${PN}-analyze = "python-pycairo" | 123 | RRECOMMENDS_${PN}-analyze = "python-pycairo" |
118 | 124 | ||
125 | FILES_python-${PN}-journal = "${PYTHON_SITEPACKAGES_DIR}/systemd/*.py* ${PYTHON_SITEPACKAGES_DIR}/systemd/*.so" | ||
126 | RDEPENDS_python-${PN}-journal = "python-core" | ||
127 | |||
119 | FILES_${PN}-initramfs = "/init" | 128 | FILES_${PN}-initramfs = "/init" |
120 | RDEPENDS_${PN}-initramfs = "${PN}" | 129 | RDEPENDS_${PN}-initramfs = "${PN}" |
121 | 130 | ||
@@ -168,9 +177,8 @@ FILES_${PN} = " ${base_bindir}/* \ | |||
168 | ${base_libdir}/udev/rules.d/73-seat-late.rules \ | 177 | ${base_libdir}/udev/rules.d/73-seat-late.rules \ |
169 | ${base_libdir}/udev/rules.d/99-systemd.rules \ | 178 | ${base_libdir}/udev/rules.d/99-systemd.rules \ |
170 | " | 179 | " |
171 | 180 | FILES_${PN}-dbg += "${systemd_unitdir}/.debug ${systemd_unitdir}/*/.debug ${base_libdir}/security/.debug/ ${PYTHON_SITEPACKAGES_DIR}/systemd/.debug/" | |
172 | FILES_${PN}-dbg += "${systemd_unitdir}/.debug ${systemd_unitdir}/*/.debug ${base_libdir}/security/.debug/" | 181 | FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ ${sysconfdir}/rpm/macros.systemd ${PYTHON_SITEPACKAGES_DIR}/systemd/*.la" |
173 | FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ ${sysconfdir}/rpm/macros.systemd" | ||
174 | 182 | ||
175 | RDEPENDS_${PN} += "dbus-systemd udev-systemd" | 183 | RDEPENDS_${PN} += "dbus-systemd udev-systemd" |
176 | 184 | ||