summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-08-10 17:14:44 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-13 23:28:05 +0200
commita07158fbe39e0bed9dbb376846ce6d3f181c00f5 (patch)
tree39ab3a6675dd090bfbb24b2b095988db7cc115fe /meta-systemd
parentace695c447bf6e216ebd0ca714d0013cab91a322 (diff)
downloadmeta-openembedded-a07158fbe39e0bed9dbb376846ce6d3f181c00f5.tar.gz
cronie: systemd support now in OE-Core
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service10
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend13
2 files changed, 0 insertions, 23 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service b/meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service
deleted file mode 100644
index 5ae193bfc..000000000
--- a/meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service
+++ /dev/null
@@ -1,10 +0,0 @@
1[Unit]
2Description=Periodic Command Scheduler
3
4[Service]
5ExecStart=/usr/sbin/crond -n
6ExecReload=/bin/kill -HUP $MAINPID
7Restart=always
8
9[Install]
10WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
index 8f45f3ee5..181b8784d 100644
--- a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
@@ -1,17 +1,4 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4inherit systemd
5
6RPROVIDES_${PN} += "${PN}-systemd" 1RPROVIDES_${PN} += "${PN}-systemd"
7RREPLACES_${PN} += "${PN}-systemd" 2RREPLACES_${PN} += "${PN}-systemd"
8RCONFLICTS_${PN} += "${PN}-systemd" 3RCONFLICTS_${PN} += "${PN}-systemd"
9SYSTEMD_SERVICE_${PN} = "crond.service"
10
11SRC_URI += "file://crond.service"
12
13do_install_append() {
14 install -d ${D}${systemd_unitdir}/system
15 install -m 0644 ${WORKDIR}/crond.service ${D}${systemd_unitdir}/system
16}
17 4