summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorShakeel, Muhammad <muhammad_shakeel@mentor.com>2013-09-12 15:28:53 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-17 19:06:27 +0200
commit03e6d3cba831c2de2dbfe2a869be706466122d12 (patch)
tree52fc320a50811e4755744d24cd8d718b08901e96 /meta-systemd
parentc837f8a883f1ff9aa6fd4a313b151e8967a1d9cc (diff)
downloadmeta-openembedded-03e6d3cba831c2de2dbfe2a869be706466122d12.tar.gz
lighttpd: Remove systemd support which is merged in oe-core
OE-Core has been updated to support lighttpd with systemd. Stuff here is not required anymore. Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service13
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend13
2 files changed, 0 insertions, 26 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service
deleted file mode 100644
index f4564f3f7..000000000
--- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service
+++ /dev/null
@@ -1,13 +0,0 @@
1[Unit]
2Description=Lightning Fast Webserver With Light System Requirements
3After=syslog.target
4
5[Service]
6Type=oneshot
7EnvironmentFile=-/etc/sysconfig/lighttpd
8ExecStart=/usr/sbin/lighttpd -D -f /etc/lighttpd.conf
9RemainAfterExit=yes
10
11[Install]
12WantedBy=multi-user.target
13
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
index 96fa989f1..5cb6bf434 100644
--- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
@@ -1,18 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC := "${@int(PRINC) + 2}" 1PRINC := "${@int(PRINC) + 2}"
4 2
5inherit systemd
6
7SRC_URI += "file://lighttpd.service"
8
9RPROVIDES_${PN} += "${PN}-systemd" 3RPROVIDES_${PN} += "${PN}-systemd"
10RREPLACES_${PN} += "${PN}-systemd" 4RREPLACES_${PN} += "${PN}-systemd"
11RCONFLICTS_${PN} += "${PN}-systemd" 5RCONFLICTS_${PN} += "${PN}-systemd"
12SYSTEMD_SERVICE_${PN} = "lighttpd.service"
13
14do_install_append() {
15 install -d ${D}${systemd_unitdir}/system
16 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
17}
18