diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2012-08-17 07:48:20 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-08-21 19:08:58 +0200 |
commit | d7553889e89a33c166c5d67411c4ffe7b4d6ed99 (patch) | |
tree | c37cc6b929791013271e784c6198add1c76bea06 /meta-systemd | |
parent | 443481fec3855476f60ee34358887d00368e6859 (diff) | |
download | meta-openembedded-d7553889e89a33c166c5d67411c4ffe7b4d6ed99.tar.gz |
wpa-supplicant: add systemd support
* native systemd support came in with v1.0 [1]
* needs [2] to work properly
* mends my wlan under control of networkmanager
[1] http://hostap.epitest.fi/gitweb/gitweb.cgi?p=hostap-1.git;a=blob_plain;f=wpa_supplicant/ChangeLog
[2] http://patches.openembedded.org/patch/34335/
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
-rw-r--r-- | meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_1.0.bbappend | 15 |
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_1.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_1.0.bbappend new file mode 100644 index 0000000000..a4dceb44d1 --- /dev/null +++ b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_1.0.bbappend | |||
@@ -0,0 +1,15 @@ | |||
1 | PRINC = "2" | ||
2 | |||
3 | inherit systemd | ||
4 | |||
5 | SYSTEMD_PACKAGES = "${PN}-systemd" | ||
6 | SYSTEMD_SERVICE = "wpa_supplicant.service" | ||
7 | SYSTEMD_AUTO_ENABLE = "disable" | ||
8 | |||
9 | do_install_append () { | ||
10 | install -d ${D}${systemd_unitdir}/system | ||
11 | install -m 644 ${S}/systemd/*.service ${D}${systemd_unitdir}/system | ||
12 | } | ||
13 | |||
14 | # systemd.bbclass does not catch all multiple-instance-service-files | ||
15 | FILES_${PN}-systemd += "${systemd_unitdir}/system/" | ||