diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 14:50:30 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:22:05 +0200 |
commit | a61c15efe444c8917da50264817b44cdcb775fc9 (patch) | |
tree | 816aef1c3c69b17f7e6740f20c6cf5195236e0b4 /meta-systemd | |
parent | fe76f1ab77c118e077d2c98f405b6b78ad35a124 (diff) | |
download | meta-openembedded-a61c15efe444c8917da50264817b44cdcb775fc9.tar.gz |
zram: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r-- | meta-systemd/meta-oe/recipes-extended/zram/zram/zram.service | 12 | ||||
-rw-r--r-- | meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend | 20 |
2 files changed, 0 insertions, 32 deletions
diff --git a/meta-systemd/meta-oe/recipes-extended/zram/zram/zram.service b/meta-systemd/meta-oe/recipes-extended/zram/zram/zram.service deleted file mode 100644 index 4a19367d93..0000000000 --- a/meta-systemd/meta-oe/recipes-extended/zram/zram/zram.service +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Enable zram compressed in-memory swap. | ||
3 | After=multi-user.target | ||
4 | |||
5 | [Service] | ||
6 | RemainAfterExit=yes | ||
7 | ExecStart=/usr/bin/zram-load.sh --load | ||
8 | ExecStop=/usr/bin/zram-load.sh --unload | ||
9 | Type=oneshot | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
diff --git a/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend b/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend deleted file mode 100644 index 227c1c7c6c..0000000000 --- a/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | PRINC := "${@int(PRINC) + 2}" | ||
4 | |||
5 | inherit systemd | ||
6 | |||
7 | SRC_URI += " \ | ||
8 | file://zram.service \ | ||
9 | " | ||
10 | |||
11 | RPROVIDES_${PN} += "${PN}-systemd" | ||
12 | RREPLACES_${PN} += "${PN}-systemd" | ||
13 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
14 | SYSTEMD_SERVICE_${PN} = "zram.service" | ||
15 | |||
16 | do_install_append() { | ||
17 | install -d ${D}${systemd_unitdir}/system | ||
18 | install -m 0644 ${WORKDIR}/zram.service ${D}${systemd_unitdir}/system | ||
19 | } | ||
20 | |||