summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-systemd
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/oe-core/recipes-bsp/keymaps/keymaps_1.0.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend10
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend8
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend12
-rw-r--r--meta-systemd/oe-core/recipes-core/dropbear/dropbear_2012.55.bbappend10
-rw-r--r--meta-systemd/oe-core/recipes-extended/at/at_3.1.13.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend4
11 files changed, 33 insertions, 33 deletions
diff --git a/meta-systemd/oe-core/recipes-bsp/keymaps/keymaps_1.0.bbappend b/meta-systemd/oe-core/recipes-bsp/keymaps/keymaps_1.0.bbappend
index 9d970254fa..36b83e05e9 100644
--- a/meta-systemd/oe-core/recipes-bsp/keymaps/keymaps_1.0.bbappend
+++ b/meta-systemd/oe-core/recipes-bsp/keymaps/keymaps_1.0.bbappend
@@ -10,7 +10,7 @@ RCONFLICTS_${PN} += "${PN}-systemd"
10SYSTEMD_SERVICE_${PN} = "${PN}.service" 10SYSTEMD_SERVICE_${PN} = "${PN}.service"
11 11
12do_install_append() { 12do_install_append() {
13 install -d ${D}${systemd_unitdir}/system 13 install -d ${D}${systemd_unitdir}/system
14 install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system 14 install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system
15} 15}
16 16
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
index 5fbe857065..22d412a25d 100644
--- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
@@ -26,11 +26,11 @@ RCONFLICTS_dhcp-client += "dhcp-client-systemd"
26SRC_URI += "file://dhcpd.service \ 26SRC_URI += "file://dhcpd.service \
27 file://dhclient.service \ 27 file://dhclient.service \
28 file://dhcrelay.service \ 28 file://dhcrelay.service \
29 " 29"
30do_install_append() { 30do_install_append() {
31 install -d ${D}${systemd_unitdir}/system 31 install -d ${D}${systemd_unitdir}/system
32 install -m 0644 ${WORKDIR}/dhcpd.service ${D}${systemd_unitdir}/system 32 install -m 0644 ${WORKDIR}/dhcpd.service ${D}${systemd_unitdir}/system
33 install -m 0644 ${WORKDIR}/dhclient.service ${D}${systemd_unitdir}/system 33 install -m 0644 ${WORKDIR}/dhclient.service ${D}${systemd_unitdir}/system
34 install -m 0644 ${WORKDIR}/dhcrelay.service ${D}${systemd_unitdir}/system 34 install -m 0644 ${WORKDIR}/dhcrelay.service ${D}${systemd_unitdir}/system
35} 35}
36 36
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
index d757c70964..4789ad06fe 100644
--- a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
@@ -13,9 +13,9 @@ inherit systemd
13 13
14SRC_URI += "file://sshd.socket file://sshd@.service file://sshdgenkeys.service" 14SRC_URI += "file://sshd.socket file://sshd@.service file://sshdgenkeys.service"
15do_install_append() { 15do_install_append() {
16 install -d ${D}${systemd_unitdir}/system 16 install -d ${D}${systemd_unitdir}/system
17 install -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system 17 install -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system
18 install -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system 18 install -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system
19 install -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system 19 install -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system
20} 20}
21 21
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
index b7ab2a4de5..5efba3ed9a 100644
--- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -12,7 +12,7 @@ SYSTEMD_AUTO_ENABLE = "disable"
12 12
13SRC_URI_append = " file://portmap.service" 13SRC_URI_append = " file://portmap.service"
14do_install_append() { 14do_install_append() {
15 install -d ${D}${systemd_unitdir}/system 15 install -d ${D}${systemd_unitdir}/system
16 install -m 0644 ${WORKDIR}/portmap.service ${D}${systemd_unitdir}/system 16 install -m 0644 ${WORKDIR}/portmap.service ${D}${systemd_unitdir}/system
17} 17}
18 18
diff --git a/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
index cd6acc826d..bdba2db3c0 100644
--- a/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
+++ b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
@@ -12,13 +12,13 @@ SYSTEMD_PACKAGES = "${PN}-syslog"
12SYSTEMD_SERVICE_${PN}-syslog = "busybox-syslog.service" 12SYSTEMD_SERVICE_${PN}-syslog = "busybox-syslog.service"
13 13
14do_install_append() { 14do_install_append() {
15 install -d ${D}${systemd_unitdir}/system 15 install -d ${D}${systemd_unitdir}/system
16 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \ 16 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \
17 > ${D}${systemd_unitdir}/system/busybox-syslog.service 17 > ${D}${systemd_unitdir}/system/busybox-syslog.service
18 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \ 18 sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \
19 > ${D}${systemd_unitdir}/system/busybox-klogd.service 19 > ${D}${systemd_unitdir}/system/busybox-klogd.service
20 20
21 ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service 21 ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service
22} 22}
23FILES_${PN}-syslog += "${systemd_unitdir}/system/syslog.service" 23FILES_${PN}-syslog += "${systemd_unitdir}/system/syslog.service"
24 24
diff --git a/meta-systemd/oe-core/recipes-core/dropbear/dropbear_2012.55.bbappend b/meta-systemd/oe-core/recipes-core/dropbear/dropbear_2012.55.bbappend
index 23e282000c..edaa66ed44 100644
--- a/meta-systemd/oe-core/recipes-core/dropbear/dropbear_2012.55.bbappend
+++ b/meta-systemd/oe-core/recipes-core/dropbear/dropbear_2012.55.bbappend
@@ -15,9 +15,9 @@ RCONFLICTS_${PN} += "${PN}-systemd"
15SYSTEMD_SERVICE_${PN} = "dropbear.socket" 15SYSTEMD_SERVICE_${PN} = "dropbear.socket"
16 16
17do_install_append() { 17do_install_append() {
18 install -d ${D}${systemd_unitdir}/system 18 install -d ${D}${systemd_unitdir}/system
19 install -m 0644 ${WORKDIR}/dropbearkey.service ${D}${systemd_unitdir}/system 19 install -m 0644 ${WORKDIR}/dropbearkey.service ${D}${systemd_unitdir}/system
20 install -m 0644 ${WORKDIR}/dropbear@.service ${D}${systemd_unitdir}/system 20 install -m 0644 ${WORKDIR}/dropbear@.service ${D}${systemd_unitdir}/system
21 install -m 0644 ${WORKDIR}/dropbear.socket ${D}${systemd_unitdir}/system 21 install -m 0644 ${WORKDIR}/dropbear.socket ${D}${systemd_unitdir}/system
22 ln -sf /dev/null ${D}${systemd_unitdir}/system/dropbear.service 22 ln -sf /dev/null ${D}${systemd_unitdir}/system/dropbear.service
23} 23}
diff --git a/meta-systemd/oe-core/recipes-extended/at/at_3.1.13.bbappend b/meta-systemd/oe-core/recipes-extended/at/at_3.1.13.bbappend
index 3d58a64c2e..cae078a4e4 100644
--- a/meta-systemd/oe-core/recipes-extended/at/at_3.1.13.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/at/at_3.1.13.bbappend
@@ -12,7 +12,7 @@ RREPLACES_${PN} += "${PN}-systemd"
12RCONFLICTS_${PN} += "${PN}-systemd" 12RCONFLICTS_${PN} += "${PN}-systemd"
13SYSTEMD_SERVICE_${PN} = "atd.service" 13SYSTEMD_SERVICE_${PN} = "atd.service"
14do_install_append() { 14do_install_append() {
15 install -d ${D}${systemd_unitdir}/system 15 install -d ${D}${systemd_unitdir}/system
16 install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system 16 install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system
17} 17}
18 18
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
index dd1eacff74..210c025b21 100644
--- a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
@@ -13,7 +13,7 @@ SYSTEMD_SERVICE_${PN} = "crond.service"
13SRC_URI += "file://crond.service" 13SRC_URI += "file://crond.service"
14 14
15do_install_append() { 15do_install_append() {
16 install -d ${D}${systemd_unitdir}/system 16 install -d ${D}${systemd_unitdir}/system
17 install -m 0644 ${WORKDIR}/crond.service ${D}${systemd_unitdir}/system 17 install -m 0644 ${WORKDIR}/crond.service ${D}${systemd_unitdir}/system
18} 18}
19 19
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
index 6dded402e0..96fa989f18 100644
--- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
@@ -12,7 +12,7 @@ RCONFLICTS_${PN} += "${PN}-systemd"
12SYSTEMD_SERVICE_${PN} = "lighttpd.service" 12SYSTEMD_SERVICE_${PN} = "lighttpd.service"
13 13
14do_install_append() { 14do_install_append() {
15 install -d ${D}${systemd_unitdir}/system 15 install -d ${D}${systemd_unitdir}/system
16 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system 16 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
17} 17}
18 18
diff --git a/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend b/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend
index 640fa371a7..5b9181bd6d 100644
--- a/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend
@@ -2,5 +2,5 @@ PRINC := "${@int(PRINC) + 2}"
2 2
3# Register with logind to make screen/tmux/etc work 3# Register with logind to make screen/tmux/etc work
4do_install_append() { 4do_install_append() {
5 echo "session required pam_systemd.so" >> ${D}${sysconfdir}/pam.d/common-session 5 echo "session required pam_systemd.so" >> ${D}${sysconfdir}/pam.d/common-session
6} 6}
diff --git a/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
index 6586809a2a..9f83f65d07 100644
--- a/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
@@ -13,7 +13,7 @@ RCONFLICTS_${PN} += "${PN}-systemd"
13SYSTEMD_SERVICE_${PN} = "rpcbind.service" 13SYSTEMD_SERVICE_${PN} = "rpcbind.service"
14 14
15do_install_append() { 15do_install_append() {
16 install -d ${D}${systemd_unitdir}/system 16 install -d ${D}${systemd_unitdir}/system
17 install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system 17 install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system
18} 18}
19 19