summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 13:49:05 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:03 +0200
commit5f26b009643d8a1a73aecb3aa0b7c5873943e7a1 (patch)
tree8e0954985027fab490e9cf1549c25455a6da9425 /meta-systemd
parent4188d725513fb660348df16c290618dd0e6198ba (diff)
downloadmeta-openembedded-5f26b009643d8a1a73aecb3aa0b7c5873943e7a1.tar.gz
yp-tools, ypbind-mt: move systemd support from meta-systemd back to meta-networking
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-networking/recipes-support/nis/files/domainname.service12
-rw-r--r--meta-systemd/meta-networking/recipes-support/nis/files/ypbind.service14
-rw-r--r--meta-systemd/meta-networking/recipes-support/nis/yp-tools_2.12.bbappend19
-rw-r--r--meta-systemd/meta-networking/recipes-support/nis/ypbind-mt_1.36.bbappend17
4 files changed, 0 insertions, 62 deletions
diff --git a/meta-systemd/meta-networking/recipes-support/nis/files/domainname.service b/meta-systemd/meta-networking/recipes-support/nis/files/domainname.service
deleted file mode 100644
index 21aa92cb3..000000000
--- a/meta-systemd/meta-networking/recipes-support/nis/files/domainname.service
+++ /dev/null
@@ -1,12 +0,0 @@
1[Unit]
2Description=NIS Domainname
3
4[Service]
5Type=oneshot
6EnvironmentFile=/etc/nisdomainname
7ExecStart=/usr/bin/domainname $NISDOMAINNAME
8RemainAfterExit=true
9
10[Install]
11WantedBy=multi-user.target
12
diff --git a/meta-systemd/meta-networking/recipes-support/nis/files/ypbind.service b/meta-systemd/meta-networking/recipes-support/nis/files/ypbind.service
deleted file mode 100644
index 1f8df42af..000000000
--- a/meta-systemd/meta-networking/recipes-support/nis/files/ypbind.service
+++ /dev/null
@@ -1,14 +0,0 @@
1[Unit]
2Description=YP Bind
3Requires=domainname.service
4After=domainname.service network.target
5Before=systemd-user-sessions.service
6
7[Service]
8Type=forking
9PIDFile=/var/run/ypbind.pid
10ExecStart=/usr/sbin/ypbind
11
12[Install]
13WantedBy=multi-user.target
14
diff --git a/meta-systemd/meta-networking/recipes-support/nis/yp-tools_2.12.bbappend b/meta-systemd/meta-networking/recipes-support/nis/yp-tools_2.12.bbappend
deleted file mode 100644
index d5ea1ca0b..000000000
--- a/meta-systemd/meta-networking/recipes-support/nis/yp-tools_2.12.bbappend
+++ /dev/null
@@ -1,19 +0,0 @@
1inherit systemd
2
3PRINC := "${@int(PRINC) + 2}"
4
5# look for files in the layer first
6FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
7
8SRC_URI += "file://domainname.service"
9
10RPROVIDES_${PN} += "${PN}-systemd"
11RREPLACES_${PN} += "${PN}-systemd"
12RCONFLICTS_${PN} += "${PN}-systemd"
13SYSTEMD_SERVICE_${PN} = "domainname.service"
14
15do_install_append() {
16 install -d ${D}${systemd_unitdir}/system
17 install -m 0644 ${WORKDIR}/domainname.service ${D}${systemd_unitdir}/system
18}
19
diff --git a/meta-systemd/meta-networking/recipes-support/nis/ypbind-mt_1.36.bbappend b/meta-systemd/meta-networking/recipes-support/nis/ypbind-mt_1.36.bbappend
deleted file mode 100644
index 8f11247a0..000000000
--- a/meta-systemd/meta-networking/recipes-support/nis/ypbind-mt_1.36.bbappend
+++ /dev/null
@@ -1,17 +0,0 @@
1inherit systemd
2
3PRINC := "${@int(PRINC) + 2}"
4
5# look for files in the layer first
6FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
7
8SRC_URI += "file://ypbind.service"
9
10RPROVIDES_${PN} += "${PN}-systemd"
11RREPLACES_${PN} += "${PN}-systemd"
12RCONFLICTS_${PN} += "${PN}-systemd"
13SYSTEMD_SERVICE_${PN} = "ypbind.service"
14do_install_append() {
15 install -d ${D}${systemd_unitdir}/system
16 install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
17}