summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 13:45:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:03 +0200
commit4188d725513fb660348df16c290618dd0e6198ba (patch)
treeec2b40788f77222c04eb1124afcccb6af74a5ee3 /meta-systemd
parent9858cfdb4868ba7ed90d8e46784b7723c30e12c1 (diff)
downloadmeta-openembedded-4188d725513fb660348df16c290618dd0e6198ba.tar.gz
ntp: move systemd support from meta-systemd back to meta-networking
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpd.service11
-rw-r--r--meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpdate.service11
-rw-r--r--meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend28
3 files changed, 0 insertions, 50 deletions
diff --git a/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpd.service b/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpd.service
deleted file mode 100644
index bd87b1ea2..000000000
--- a/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpd.service
+++ /dev/null
@@ -1,11 +0,0 @@
1[Unit]
2Description=Network Time Service
3After=network.target
4
5[Service]
6Type=forking
7PIDFile=/run/ntpd.pid
8ExecStart=/usr/bin/ntpd -p /run/ntpd.pid
9
10[Install]
11WantedBy=multi-user.target
diff --git a/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpdate.service b/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpdate.service
deleted file mode 100644
index 10cbd70f9..000000000
--- a/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpdate.service
+++ /dev/null
@@ -1,11 +0,0 @@
1[Unit]
2Description=Network Time Service (one-shot ntpdate mode)
3Before=ntpd.service
4
5[Service]
6Type=oneshot
7ExecStart=/usr/bin/ntpdate-sync silent
8RemainAfterExit=yes
9
10[Install]
11WantedBy=multi-user.target
diff --git a/meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend b/meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend
deleted file mode 100644
index 7f2a79616..000000000
--- a/meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend
+++ /dev/null
@@ -1,28 +0,0 @@
1inherit systemd
2
3PRINC := "${@int(PRINC) + 2}"
4
5FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
6
7SYSTEMD_PACKAGES = "${PN} ntpdate"
8SYSTEMD_SERVICE_${PN} = "ntpd.service"
9SYSTEMD_SERVICE_ntpdate = "ntpdate.service"
10RPROVIDES_${PN} += "${PN}-systemd"
11RREPLACES_${PN} += "${PN}-systemd"
12RCONFLICTS_${PN} += "${PN}-systemd"
13RPROVIDES_ntpdate += "ntpdate-systemd"
14RREPLACES_ntpdate += "ntpdate-systemd"
15RCONFLICTS_ntpdate += "ntpdate-systemd"
16
17FILES_ntpdate += "${systemd_unitdir}/system/ntpdate.service"
18
19SRC_URI += " \
20 file://ntpdate.service \
21 file://ntpd.service \
22"
23
24do_install_append() {
25 install -d ${D}${systemd_unitdir}/system
26 install -m 0644 ${WORKDIR}/ntpdate.service ${D}${systemd_unitdir}/system/
27 install -m 0644 ${WORKDIR}/ntpd.service ${D}${systemd_unitdir}/system/
28}