summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-14 17:37:08 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:07 +0200
commit9e192db23ae5424d135400025bc6ba9a25eb36a9 (patch)
tree505c624de711c3f0b96f4ab4c760904852d1ef5b /meta-systemd
parent65401d478557b6d65a7130bb9b371e06bf34a391 (diff)
downloadmeta-openembedded-9e192db23ae5424d135400025bc6ba9a25eb36a9.tar.gz
busybox: fix upgrade path
* check_data_file_clashes: Package busybox-syslog wants to install file /lib/systemd/system/busybox-syslog.service But that file is already provided by package * busybox-syslog-systemd * check_data_file_clashes: Package busybox-syslog wants to install file /lib/systemd/system/syslog.service But that file is already provided by package * busybox-syslog-systemd * check_data_file_clashes: Package busybox-syslog wants to install file /lib/systemd/system/busybox-klogd.service But that file is already provided by package * busybox-syslog-systemd Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
index 06993025f..cd6acc826 100644
--- a/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
+++ b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
@@ -1,6 +1,6 @@
1inherit systemd 1inherit systemd
2 2
3PRINC := "${@int(PRINC) + 2}" 3PRINC := "${@int(PRINC) + 3}"
4 4
5# look for files in the layer first 5# look for files in the layer first
6FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 6FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
@@ -21,3 +21,7 @@ do_install_append() {
21 ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service 21 ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service
22} 22}
23FILES_${PN}-syslog += "${systemd_unitdir}/system/syslog.service" 23FILES_${PN}-syslog += "${systemd_unitdir}/system/syslog.service"
24
25RPROVIDES_${PN}-syslog += "${PN}-syslog-systemd"
26RREPLACES_${PN}-syslog += "${PN}-syslog-systemd"
27RCONFLICTS_${PN}-syslog += "${PN}-syslog-systemd"