diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 13:49:05 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:22:03 +0200 |
commit | 5f26b009643d8a1a73aecb3aa0b7c5873943e7a1 (patch) | |
tree | 8e0954985027fab490e9cf1549c25455a6da9425 /meta-systemd | |
parent | 4188d725513fb660348df16c290618dd0e6198ba (diff) | |
download | meta-openembedded-5f26b009643d8a1a73aecb3aa0b7c5873943e7a1.tar.gz |
yp-tools, ypbind-mt: move systemd support from meta-systemd back to meta-networking
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
4 files changed, 0 insertions, 62 deletions
diff --git a/meta-systemd/meta-networking/recipes-support/nis/files/domainname.service b/meta-systemd/meta-networking/recipes-support/nis/files/domainname.service deleted file mode 100644 index 21aa92cb3..000000000 --- a/meta-systemd/meta-networking/recipes-support/nis/files/domainname.service +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=NIS Domainname | ||
3 | |||
4 | [Service] | ||
5 | Type=oneshot | ||
6 | EnvironmentFile=/etc/nisdomainname | ||
7 | ExecStart=/usr/bin/domainname $NISDOMAINNAME | ||
8 | RemainAfterExit=true | ||
9 | |||
10 | [Install] | ||
11 | WantedBy=multi-user.target | ||
12 | |||
diff --git a/meta-systemd/meta-networking/recipes-support/nis/files/ypbind.service b/meta-systemd/meta-networking/recipes-support/nis/files/ypbind.service deleted file mode 100644 index 1f8df42af..000000000 --- a/meta-systemd/meta-networking/recipes-support/nis/files/ypbind.service +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=YP Bind | ||
3 | Requires=domainname.service | ||
4 | After=domainname.service network.target | ||
5 | Before=systemd-user-sessions.service | ||
6 | |||
7 | [Service] | ||
8 | Type=forking | ||
9 | PIDFile=/var/run/ypbind.pid | ||
10 | ExecStart=/usr/sbin/ypbind | ||
11 | |||
12 | [Install] | ||
13 | WantedBy=multi-user.target | ||
14 | |||
diff --git a/meta-systemd/meta-networking/recipes-support/nis/yp-tools_2.12.bbappend b/meta-systemd/meta-networking/recipes-support/nis/yp-tools_2.12.bbappend deleted file mode 100644 index d5ea1ca0b..000000000 --- a/meta-systemd/meta-networking/recipes-support/nis/yp-tools_2.12.bbappend +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | inherit systemd | ||
2 | |||
3 | PRINC := "${@int(PRINC) + 2}" | ||
4 | |||
5 | # look for files in the layer first | ||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
7 | |||
8 | SRC_URI += "file://domainname.service" | ||
9 | |||
10 | RPROVIDES_${PN} += "${PN}-systemd" | ||
11 | RREPLACES_${PN} += "${PN}-systemd" | ||
12 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
13 | SYSTEMD_SERVICE_${PN} = "domainname.service" | ||
14 | |||
15 | do_install_append() { | ||
16 | install -d ${D}${systemd_unitdir}/system | ||
17 | install -m 0644 ${WORKDIR}/domainname.service ${D}${systemd_unitdir}/system | ||
18 | } | ||
19 | |||
diff --git a/meta-systemd/meta-networking/recipes-support/nis/ypbind-mt_1.36.bbappend b/meta-systemd/meta-networking/recipes-support/nis/ypbind-mt_1.36.bbappend deleted file mode 100644 index 8f11247a0..000000000 --- a/meta-systemd/meta-networking/recipes-support/nis/ypbind-mt_1.36.bbappend +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | inherit systemd | ||
2 | |||
3 | PRINC := "${@int(PRINC) + 2}" | ||
4 | |||
5 | # look for files in the layer first | ||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
7 | |||
8 | SRC_URI += "file://ypbind.service" | ||
9 | |||
10 | RPROVIDES_${PN} += "${PN}-systemd" | ||
11 | RREPLACES_${PN} += "${PN}-systemd" | ||
12 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
13 | SYSTEMD_SERVICE_${PN} = "ypbind.service" | ||
14 | do_install_append() { | ||
15 | install -d ${D}${systemd_unitdir}/system | ||
16 | install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system | ||
17 | } | ||