summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-systemd
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/README32
-rw-r--r--meta-systemd/conf/layer.conf31
-rw-r--r--meta-systemd/oe-core/recipes-bsp/keymaps/keymaps_1.0.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend9
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/connman/connman_%.bbappend3
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhclient.service13
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend24
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/ofono/ofono_%.bbappend5
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_%.bbappend3
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend5
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_%.bbappend3
-rw-r--r--meta-systemd/oe-core/recipes-core/busybox/busybox_%.bbappend3
-rw-r--r--meta-systemd/oe-core/recipes-core/dbus/dbus_%.bbappend3
-rw-r--r--meta-systemd/oe-core/recipes-core/dropbear/dropbear_%.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-core/systemd/systemd_%.bbappend3
-rw-r--r--meta-systemd/oe-core/recipes-core/util-linux/util-linux_%.bbappend3
-rw-r--r--meta-systemd/oe-core/recipes-extended/at/at/atd.service9
-rw-r--r--meta-systemd/oe-core/recipes-extended/at/at_%.bbappend16
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend4
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend3
-rw-r--r--meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend3
-rw-r--r--meta-systemd/recipes-core/systemd/systemd-machine-units_1.0.bb13
23 files changed, 200 insertions, 0 deletions
diff --git a/meta-systemd/README b/meta-systemd/README
new file mode 100644
index 000000000..5f42b99d4
--- /dev/null
+++ b/meta-systemd/README
@@ -0,0 +1,32 @@
1This layer depends on:
2
3URI: git://github.com/openembedded/oe-core.git
4branch: dizzy
5revision: HEAD
6
7And we're working to break the dependency on this one:
8
9URI: git://github.com/openembedded/meta-oe.git
10branch: dizzy
11revision: HEAD
12
13To make BBMASK'ing per layer possible the following directory structure is
14used:
15
16$[LAYERDIR}/<layer name>/recipes-<group-name>/<recipe-name>/<recipe-name>.bbappend
17
18Send pull requests to openembedded-devel@lists.openembedded.org with '[meta-oe][meta-systemd][dizzy]' in the subject'
19
20When sending single patches, please use something like:
21'git send-email -M -1 --to openembedded-devel@lists.openembedded.org --subject-prefix=meta-oe][meta-systemd][dizzy][PATCH'
22
23You are encouraged to fork the mirror on github https://github.com/openembedded/meta-oe/ to share your patches, this is preferred for patch sets consisting of more than one patch. Other services like gitorious, repo.or.cz or self hosted setups are of course accepted as well, 'git fetch <remote>' works the same on all of them. We recommend github because it is free, easy to use, has been proven to be reliable and has a really good web GUI.
24
25Main layer maintainer: Koen Kooi <koen@dominion.thruhere.net>
26 Martin Jansa <martin.jansa@gmail.com>
27
28Dizzy branch maintainers:
29 Otavio Salvador <otavio@ossystems.com.br>
30 Armin Kuster <akuster808@gmail.com>
31
32Prefix email subject with: [dizzy]
diff --git a/meta-systemd/conf/layer.conf b/meta-systemd/conf/layer.conf
new file mode 100644
index 000000000..f3fc45d00
--- /dev/null
+++ b/meta-systemd/conf/layer.conf
@@ -0,0 +1,31 @@
1# It really depends on order of the layers appearing in BBLAYERS
2# variable in toplevel bblayers.conf file, where bitbake will search
3# for .inc files and others where bitbake uses BBPATH since it will
4# search the directories from first to last as specified in BBPATH
5# Therefore if you want a given layer to be considered high priority
6# for the .inc and .conf etc. then consider it adding at the beginning
7# of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve
8# the recipe contention so the order of directories in BBFILES does
9# not matter.
10
11# We have a conf and classes directory, append to BBPATH
12BBPATH .= ":${LAYERDIR}"
13
14# We have a recipes directory, add to BBFILES
15BBFILES += "\
16 ${LAYERDIR}/recipes-*/*/*.bb \
17 ${LAYERDIR}/oe-core/recipes-*/*/*.bbappend \
18"
19
20BBFILE_COLLECTIONS += "systemd-layer"
21BBFILE_PATTERN_systemd-layer := "^${LAYERDIR}/"
22
23# Define the priority for recipes (.bb files) from this layer,
24# choosing carefully how this layer interacts with all of the
25# other layers.
26
27BBFILE_PRIORITY_systemd-layer = "7"
28
29SIGGEN_EXCLUDERECIPES_ABISAFE += " \
30 systemd-serialgetty \
31"
diff --git a/meta-systemd/oe-core/recipes-bsp/keymaps/keymaps_1.0.bbappend b/meta-systemd/oe-core/recipes-bsp/keymaps/keymaps_1.0.bbappend
new file mode 100644
index 000000000..181b8784d
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-bsp/keymaps/keymaps_1.0.bbappend
@@ -0,0 +1,4 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
4
diff --git a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
new file mode 100644
index 000000000..181b8784d
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
@@ -0,0 +1,4 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
4
diff --git a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
new file mode 100644
index 000000000..da01b0583
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
@@ -0,0 +1,9 @@
1inherit systemd
2
3EXTRA_OECONF += "--with-systemdunitdir=${systemd_unitdir}/system/"
4
5RPROVIDES_${PN} += "${PN}-systemd"
6RREPLACES_${PN} += "${PN}-systemd"
7RCONFLICTS_${PN} += "${PN}-systemd"
8SYSTEMD_SERVICE_${PN} = "bluetooth.service"
9SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-systemd/oe-core/recipes-connectivity/connman/connman_%.bbappend b/meta-systemd/oe-core/recipes-connectivity/connman/connman_%.bbappend
new file mode 100644
index 000000000..f006b3fb5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/connman/connman_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhclient.service b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhclient.service
new file mode 100644
index 000000000..c9620cf09
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhclient.service
@@ -0,0 +1,13 @@
1[Unit]
2Description=Dynamic Host Configuration Protocol (DHCP)
3After=syslog.target network.target
4
5[Service]
6Type=forking
7PIDFile=/var/run/dhclient.pid
8EnvironmentFile=-/etc/default/dhcp-client
9ExecStart=/sbin/dhclient -cf /etc/dhcp/dhclient.conf -q -lf /var/lib/dhcp/dhclient.leases $INTERFACES
10
11[Install]
12WantedBy=multi-user.target
13
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend
new file mode 100644
index 000000000..6c0fd0264
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend
@@ -0,0 +1,24 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SYSTEMD_PACKAGES += "dhcp-client"
5SYSTEMD_SERVICE_dhcp-client = "dhclient.service"
6SYSTEMD_AUTO_ENABLE_dhcp-client = "disable"
7
8FILES_dhcp-client += "${systemd_unitdir}/system/dhclient.service"
9RPROVIDES_dhcp-server += "dhcp-server-systemd"
10RREPLACES_dhcp-server += "dhcp-server-systemd"
11RCONFLICTS_dhcp-server += "dhcp-server-systemd"
12RPROVIDES_dhcp-relay += "dhcp-relay-systemd"
13RREPLACES_dhcp-relay += "dhcp-relay-systemd"
14RCONFLICTS_dhcp-relay += "dhcp-relay-systemd"
15RPROVIDES_dhcp-client += "dhcp-client-systemd"
16RREPLACES_dhcp-client += "dhcp-client-systemd"
17RCONFLICTS_dhcp-client += "dhcp-client-systemd"
18
19SRC_URI += "file://dhclient.service"
20
21do_install_append() {
22 install -m 0644 ${WORKDIR}/dhclient.service ${D}${systemd_unitdir}/system
23}
24
diff --git a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_%.bbappend b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_%.bbappend
new file mode 100644
index 000000000..17a312459
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_%.bbappend
@@ -0,0 +1,5 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
4
5SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_%.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_%.bbappend
new file mode 100644
index 000000000..dadbc1499
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN}-sshd += "${PN}-sshd-systemd"
2RREPLACES_${PN}-sshd += "${PN}-sshd-systemd"
3RCONFLICTS_${PN}-sshd += "${PN}-sshd-systemd"
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
new file mode 100644
index 000000000..6ce6e70d9
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -0,0 +1,5 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
4SYSTEMD_AUTO_ENABLE = "disable"
5
diff --git a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_%.bbappend b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_%.bbappend
new file mode 100644
index 000000000..f006b3fb5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/oe-core/recipes-core/busybox/busybox_%.bbappend b/meta-systemd/oe-core/recipes-core/busybox/busybox_%.bbappend
new file mode 100644
index 000000000..642d450a5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-core/busybox/busybox_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN}-syslog += "${PN}-syslog-systemd"
2RREPLACES_${PN}-syslog += "${PN}-syslog-systemd"
3RCONFLICTS_${PN}-syslog += "${PN}-syslog-systemd"
diff --git a/meta-systemd/oe-core/recipes-core/dbus/dbus_%.bbappend b/meta-systemd/oe-core/recipes-core/dbus/dbus_%.bbappend
new file mode 100644
index 000000000..f006b3fb5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-core/dbus/dbus_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/oe-core/recipes-core/dropbear/dropbear_%.bbappend b/meta-systemd/oe-core/recipes-core/dropbear/dropbear_%.bbappend
new file mode 100644
index 000000000..181b8784d
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-core/dropbear/dropbear_%.bbappend
@@ -0,0 +1,4 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
4
diff --git a/meta-systemd/oe-core/recipes-core/systemd/systemd_%.bbappend b/meta-systemd/oe-core/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 000000000..f5aa547f1
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_udev += "udev-systemd"
2RREPLACES_udev += "udev-systemd"
3RCONFLICTS_udev += "udev-systemd"
diff --git a/meta-systemd/oe-core/recipes-core/util-linux/util-linux_%.bbappend b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_%.bbappend
new file mode 100644
index 000000000..f006b3fb5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/oe-core/recipes-extended/at/at/atd.service b/meta-systemd/oe-core/recipes-extended/at/at/atd.service
new file mode 100644
index 000000000..64a901550
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/at/at/atd.service
@@ -0,0 +1,9 @@
1[Unit]
2Description=Job spooling tools
3After=syslog.target
4
5[Service]
6ExecStart=/usr/sbin/atd -f
7
8[Install]
9WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend b/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
new file mode 100644
index 000000000..3a22fe3bd
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend
@@ -0,0 +1,16 @@
1inherit systemd
2
3# look for files in the layer first
4FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
5
6SRC_URI += "file://atd.service"
7
8RPROVIDES_${PN} += "${PN}-systemd"
9RREPLACES_${PN} += "${PN}-systemd"
10RCONFLICTS_${PN} += "${PN}-systemd"
11SYSTEMD_SERVICE_${PN} = "atd.service"
12do_install_append() {
13 install -d ${D}${systemd_unitdir}/system
14 install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system
15}
16
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
new file mode 100644
index 000000000..181b8784d
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
@@ -0,0 +1,4 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
4
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend
new file mode 100644
index 000000000..f006b3fb5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend
new file mode 100644
index 000000000..f006b3fb5
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_%.bbappend
@@ -0,0 +1,3 @@
1RPROVIDES_${PN} += "${PN}-systemd"
2RREPLACES_${PN} += "${PN}-systemd"
3RCONFLICTS_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/recipes-core/systemd/systemd-machine-units_1.0.bb b/meta-systemd/recipes-core/systemd/systemd-machine-units_1.0.bb
new file mode 100644
index 000000000..6a66ac214
--- /dev/null
+++ b/meta-systemd/recipes-core/systemd/systemd-machine-units_1.0.bb
@@ -0,0 +1,13 @@
1SUMMARY = "Machine specific systemd units"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
5
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8PR = "r18"
9
10inherit systemd
11SYSTEMD_SERVICE_${PN} = ""
12NATIVE_SYSTEMD_SUPPORT = "1"
13ALLOW_EMPTY_${PN} = "1"