summaryrefslogtreecommitdiffstats
path: root/meta-systemd/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-04 20:05:30 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-08-08 09:02:30 +0200
commit980b338fb5100ff4c779335a86f3d9450ea8c54a (patch)
tree1d6db1881f20819cbee0e8dcf9de37ad55478bd0 /meta-systemd/recipes-core
parent3ce8db6d187b864fa59206d4efa93b8f952b534e (diff)
downloadmeta-openembedded-980b338fb5100ff4c779335a86f3d9450ea8c54a.tar.gz
systemd: Upgrade to 187 tag
Dont inherit vala not needed anymore Fix build for ppc64 Consider /lib64 and /usr/lib64 Some 64bit architectures chose lib64 instead of lib for default library dirnames. So we dig this from metadata vars base_libdir and libdir instead of hardcoding 'lib' ppc64 in OE uses lib64 for default libdir and this leaves lot of udev/systemd files unpackaged since 'lib' was hardcoded Additionally use --split-usr option since in OE-Core now we want to treat /usr mounted sepatately. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd/recipes-core')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch94
-rw-r--r--meta-systemd/recipes-core/systemd/systemd_git.bb15
2 files changed, 103 insertions, 6 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch b/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch
new file mode 100644
index 000000000..216721684
--- /dev/null
+++ b/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch
@@ -0,0 +1,94 @@
1Upstream-Status: Undecided
2
3This patch removes some of hardcoded references to /lib
4and /usr/lib since on some architectures it should be
5/lib64 and /usr/lib64 atleast in OE
6
7I am not sure about the intention of hardcoded values
8thats why status is undecided
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11
12Index: git/Makefile.am
13===================================================================
14--- git.orig/Makefile.am 2012-07-22 16:20:38.424405916 -0700
15+++ git/Makefile.am 2012-07-22 16:23:21.232406621 -0700
16@@ -61,23 +61,23 @@
17
18 # Our own, non-special dirs
19 pkgsysconfdir=$(sysconfdir)/systemd
20-userunitdir=$(prefix)/lib/systemd/user
21-tmpfilesdir=$(prefix)/lib/tmpfiles.d
22-sysctldir=$(prefix)/lib/sysctl.d
23-usergeneratordir=$(prefix)/lib/systemd/user-generators
24+userunitdir=$(prefix)/$(rootlibdir)/systemd/user
25+tmpfilesdir=$(prefix)/$(rootlibdir)/tmpfiles.d
26+sysctldir=$(prefix)/$(rootlibdir)/sysctl.d
27+usergeneratordir=$(prefix)/$(rootlibdir)/systemd/user-generators
28 pkgincludedir=$(includedir)/systemd
29 systemgeneratordir=$(rootlibexecdir)/system-generators
30 systemshutdowndir=$(rootlibexecdir)/system-shutdown
31 systemsleepdir=$(rootlibexecdir)/system-sleep
32-systemunitdir=$(rootprefix)/lib/systemd/system
33-udevlibexecdir=$(rootprefix)/lib/udev
34+systemunitdir=$(rootprefix)/$(rootlibdir)/systemd/system
35+udevlibexecdir=$(rootprefix)/$(rootlibdir)/udev
36 udevhomedir = $(udevlibexecdir)
37 udevrulesdir = $(udevlibexecdir)/rules.d
38
39 # And these are the special ones for /
40 rootprefix=@rootprefix@
41 rootbindir=$(rootprefix)/bin
42-rootlibexecdir=$(rootprefix)/lib/systemd
43+rootlibexecdir=$(rootprefix)/$(rootlibdir)/systemd
44
45 CLEANFILES =
46 EXTRA_DIST =
47@@ -126,7 +126,7 @@
48 -DSYSTEMD_STDIO_BRIDGE_BINARY_PATH=\"$(bindir)/systemd-stdio-bridge\" \
49 -DROOTPREFIX=\"$(rootprefix)\" \
50 -DRUNTIME_DIR=\"/run\" \
51- -DRANDOM_SEED=\"$(localstatedir)/lib/random-seed\" \
52+ -DRANDOM_SEED=\"$(localstatedir)/$(rootlibdir)/random-seed\" \
53 -DSYSTEMD_CRYPTSETUP_PATH=\"$(rootlibexecdir)/systemd-cryptsetup\" \
54 -DSYSTEM_GENERATOR_PATH=\"$(systemgeneratordir)\" \
55 -DUSER_GENERATOR_PATH=\"$(usergeneratordir)\" \
56@@ -2535,7 +2535,7 @@
57
58 binfmt-install-data-hook:
59 $(MKDIR_P) -m 0755 \
60- $(DESTDIR)$(prefix)/lib/binfmt.d \
61+ $(DESTDIR)$(prefix)/$(rootlibdir)/binfmt.d \
62 $(DESTDIR)$(sysconfdir)/binfmt.d \
63 $(DESTDIR)$(systemunitdir)/sysinit.target.wants
64 ( cd $(DESTDIR)$(systemunitdir)/sysinit.target.wants && \
65@@ -3165,7 +3165,7 @@
66 logind-install-data-hook:
67 $(MKDIR_P) -m 0755 \
68 $(DESTDIR)$(systemunitdir)/multi-user.target.wants \
69- $(DESTDIR)$(localstatedir)/lib/systemd
70+ $(DESTDIR)$(localstatedir)/$(rootlibdir)/systemd
71 ( cd $(DESTDIR)$(systemunitdir) && \
72 rm -f dbus-org.freedesktop.login1.service && \
73 $(LN_S) systemd-logind.service dbus-org.freedesktop.login1.service)
74@@ -3284,7 +3284,7 @@
75 -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
76 -e 's,@PACKAGE_NAME\@,$(PACKAGE_NAME),g' \
77 -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' \
78- -e 's,@RANDOM_SEED\@,$(localstatedir)/lib/random-seed,g' \
79+ -e 's,@RANDOM_SEED\@,$(localstatedir)/$(rootlibdir)/random-seed,g' \
80 -e 's,@prefix\@,$(prefix),g' \
81 -e 's,@exec_prefix\@,$(exec_prefix),g' \
82 -e 's,@libdir\@,$(libdir),g' \
83@@ -3407,9 +3407,9 @@
84 $(MKDIR_P) -m 0755 \
85 $(DESTDIR)$(tmpfilesdir) \
86 $(DESTDIR)$(sysconfdir)/tmpfiles.d \
87- $(DESTDIR)$(prefix)/lib/modules-load.d \
88+ $(DESTDIR)$(prefix)/$(rootlibdir)/modules-load.d \
89 $(DESTDIR)$(sysconfdir)/modules-load.d \
90- $(DESTDIR)$(prefix)/lib/sysctl.d \
91+ $(DESTDIR)$(prefix)/$(rootlibdir)/sysctl.d \
92 $(DESTDIR)$(sysconfdir)/sysctl.d \
93 $(DESTDIR)$(systemshutdowndir) \
94 $(DESTDIR)$(systemsleepdir) \
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb
index 39b883a23..5d1c28b31 100644
--- a/meta-systemd/recipes-core/systemd/systemd_git.bb
+++ b/meta-systemd/recipes-core/systemd/systemd_git.bb
@@ -19,18 +19,20 @@ inherit gitpkgv
19PKGV = "v${GITPKGVTAG}" 19PKGV = "v${GITPKGVTAG}"
20 20
21PV = "git" 21PV = "git"
22PR = "r4" 22PR = "r5"
23 23
24inherit useradd pkgconfig autotools vala perlnative 24inherit useradd pkgconfig autotools perlnative
25 25
26SRCREV = "cd96b3b86abb4a88cac2722bdfb6e5d4413f6831" 26SRCREV = "3fd89536883ea9e24e69f28de0d11cd7cffb42ce"
27 27
28SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \ 28SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
29 file://use-rootlibdir.patch \
29 file://gtk-doc.make \ 30 file://gtk-doc.make \
30 file://touchscreen.rules \ 31 file://touchscreen.rules \
31 file://modprobe.rules \ 32 file://modprobe.rules \
32 file://var-run.conf \ 33 file://var-run.conf \
33 " 34 "
35
34LDFLAGS_libc-uclibc_append = " -lrt" 36LDFLAGS_libc-uclibc_append = " -lrt"
35 37
36S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"
@@ -38,6 +40,9 @@ S = "${WORKDIR}/git"
38SYSTEMDDISTRO ?= "debian" 40SYSTEMDDISTRO ?= "debian"
39SYSTEMDDISTRO_angstrom = "angstrom" 41SYSTEMDDISTRO_angstrom = "angstrom"
40 42
43CACHED_CONFIGUREVARS = "ac_cv_file__usr_share_pci_ids=no \
44 ac_cv_file__usr_share_hwdata_pci_ids=no \
45 ac_cv_file__usr_share_misc_pci_ids=yes"
41# The gtk+ tools should get built as a separate recipe e.g. systemd-tools 46# The gtk+ tools should get built as a separate recipe e.g. systemd-tools
42EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \ 47EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
43 --with-rootprefix=${base_prefix} \ 48 --with-rootprefix=${base_prefix} \
@@ -50,11 +55,9 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
50 --disable-coredump \ 55 --disable-coredump \
51 --disable-introspection \ 56 --disable-introspection \
52 --with-pci-ids-path=/usr/share/misc \ 57 --with-pci-ids-path=/usr/share/misc \
53 ac_cv_file__usr_share_pci_ids=no \
54 ac_cv_file__usr_share_hwdata_pci_ids=no \
55 ac_cv_file__usr_share_misc_pci_ids=yes \
56 --disable-gtk-doc-html \ 58 --disable-gtk-doc-html \
57 --disable-tcpwrap \ 59 --disable-tcpwrap \
60 --enable-split-usr \
58 " 61 "
59 62
60# There's no docbook-xsl-native, so for the xsltproc check to false 63# There's no docbook-xsl-native, so for the xsltproc check to false