summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 13:32:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 18:50:15 +0200
commit1482cfe735de97eec6bc87cb653c92aef002bc10 (patch)
tree20fdc86810b01f2f461aa124b41baf172b54ece4 /meta-systemd/oe-core
parentf195081bd0d52f72e0a8b54dc48d47624a1ebbbe (diff)
downloadmeta-openembedded-1482cfe735de97eec6bc87cb653c92aef002bc10.tar.gz
meta-systemd: bump PRINC in all .bbappends
* opkg upgrade will fail to upgrade every package PN when PN-system is installed * check_data_file_clashes: Package xserver-nodm-init wants to install file /lib/systemd/system/xserver-nodm.service But that file is already provided by package * xserver-nodm-init-systemd You need to manually remove all PN-systemd packages on your target opkg remove -force-depends -force-remove `opkg list-installed | grep "\-systemd"` be careful with stuff like openssh-sshd-systemd or wpa-supplicant-systemd when you have access to target only over network * this PRINC bump will force you to do it now even for people not using OEBasicHash or PR service Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend2
12 files changed, 12 insertions, 12 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
index 987c510c3..13a2ee453 100644
--- a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
@@ -1,4 +1,4 @@
1PRINC := "${@int(PRINC) + 1}" 1PRINC := "${@int(PRINC) + 2}"
2 2
3inherit systemd 3inherit systemd
4 4
diff --git a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
index e4dcabb3f..752e6c195 100644
--- a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
@@ -1,4 +1,4 @@
1PRINC := "${@int(PRINC) + 1}" 1PRINC := "${@int(PRINC) + 2}"
2 2
3inherit systemd 3inherit systemd
4 4
diff --git a/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend b/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
index 0ba99b5d8..96a428f1d 100644
--- a/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
@@ -1,4 +1,4 @@
1PRINC := "${@int(PRINC) + 1}" 1PRINC := "${@int(PRINC) + 2}"
2 2
3RPROVIDES_${PN} += "${PN}-systemd" 3RPROVIDES_${PN} += "${PN}-systemd"
4SYSTEMD_SERVICE_${PN} = "connman.service" 4SYSTEMD_SERVICE_${PN} = "connman.service"
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
index aec1dfbe9..d3a322ae7 100644
--- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3 3
4inherit systemd 4inherit systemd
5 5
6PRINC := "${@int(PRINC) + 1}" 6PRINC := "${@int(PRINC) + 2}"
7 7
8SYSTEMD_PACKAGES = "dhcp-server dhcp-relay dhcp-client" 8SYSTEMD_PACKAGES = "dhcp-server dhcp-relay dhcp-client"
9SYSTEMD_SERVICE_dhcp-server = "dhcpd.service" 9SYSTEMD_SERVICE_dhcp-server = "dhcpd.service"
diff --git a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
index e0e8f2829..94fce48a5 100644
--- a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
@@ -1,4 +1,4 @@
1PRINC := "${@int(PRINC) + 1}" 1PRINC := "${@int(PRINC) + 2}"
2 2
3inherit systemd 3inherit systemd
4 4
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
index fe5c91906..0d1bb56e8 100644
--- a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PRINC := "${@int(PRINC) + 1}" 3PRINC := "${@int(PRINC) + 2}"
4 4
5SYSTEMD_PACKAGES = "openssh-sshd" 5SYSTEMD_PACKAGES = "openssh-sshd"
6SYSTEMD_SERVICE_openssh-sshd = "sshd.socket" 6SYSTEMD_SERVICE_openssh-sshd = "sshd.socket"
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
index 73709e8a6..784fc1f47 100644
--- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS := "${THISDIR}/${PN}" 1FILESEXTRAPATHS := "${THISDIR}/${PN}"
2 2
3PRINC := "${@int(PRINC) + 1}" 3PRINC := "${@int(PRINC) + 2}"
4 4
5inherit systemd 5inherit systemd
6 6
diff --git a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
index d0ce87eb0..dcd9b84e8 100644
--- a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
@@ -1,3 +1,3 @@
1PRINC := "${@int(PRINC) + 3}" 1PRINC := "${@int(PRINC) + 4}"
2 2
3RPROVIDES_${PN} += "${PN}-systemd" 3RPROVIDES_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
index 0447f511b..12a9823c8 100644
--- a/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
+++ b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
@@ -1,6 +1,6 @@
1inherit systemd 1inherit systemd
2 2
3PRINC := "${@int(PRINC) + 1}" 3PRINC := "${@int(PRINC) + 2}"
4 4
5SYSTEMD_UNITDIR = "${systemd_unitdir}/system" 5SYSTEMD_UNITDIR = "${systemd_unitdir}/system"
6EXTRA_OECONF += "--enable-socket-activation --with-systemdsystemunitdir=${SYSTEMD_UNITDIR}" 6EXTRA_OECONF += "--enable-socket-activation --with-systemdsystemunitdir=${SYSTEMD_UNITDIR}"
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
index 418836fc2..dc06af9a5 100644
--- a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
@@ -1,7 +1,7 @@
1# look for files in the layer first 1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3 3
4PRINC := "${@int(PRINC) + 3}" 4PRINC := "${@int(PRINC) + 4}"
5 5
6inherit systemd 6inherit systemd
7 7
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
index 0c7548a86..b6ec2aa01 100644
--- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PRINC := "${@int(PRINC) + 1}" 3PRINC := "${@int(PRINC) + 2}"
4 4
5inherit systemd 5inherit systemd
6 6
diff --git a/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend b/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend
index 7c4bcd88f..640fa371a 100644
--- a/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/pam/libpam_1.1.6.bbappend
@@ -1,4 +1,4 @@
1PRINC := "${@int(PRINC) + 1}" 1PRINC := "${@int(PRINC) + 2}"
2 2
3# Register with logind to make screen/tmux/etc work 3# Register with logind to make screen/tmux/etc work
4do_install_append() { 4do_install_append() {