diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 14:14:51 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:22:02 +0200 |
commit | 7baa466291ecdce5d36fb6cfa17689d2419549ba (patch) | |
tree | 2dbdb78672eec0d0c63642bdce4e01bff48ce3a8 /meta-systemd/oe-core | |
parent | c39daf6e361adb929764f911fdbc583534d44cd4 (diff) | |
download | meta-openembedded-7baa466291ecdce5d36fb6cfa17689d2419549ba.tar.gz |
at: move bbappend to oe-core subdirectory
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r-- | meta-systemd/oe-core/recipes-extended/at/at/atd.service | 9 | ||||
-rw-r--r-- | meta-systemd/oe-core/recipes-extended/at/at_3.1.13.bbappend | 18 |
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/at/at/atd.service b/meta-systemd/oe-core/recipes-extended/at/at/atd.service new file mode 100644 index 000000000..64a901550 --- /dev/null +++ b/meta-systemd/oe-core/recipes-extended/at/at/atd.service | |||
@@ -0,0 +1,9 @@ | |||
1 | [Unit] | ||
2 | Description=Job spooling tools | ||
3 | After=syslog.target | ||
4 | |||
5 | [Service] | ||
6 | ExecStart=/usr/sbin/atd -f | ||
7 | |||
8 | [Install] | ||
9 | WantedBy=multi-user.target | ||
diff --git a/meta-systemd/oe-core/recipes-extended/at/at_3.1.13.bbappend b/meta-systemd/oe-core/recipes-extended/at/at_3.1.13.bbappend new file mode 100644 index 000000000..3d58a64c2 --- /dev/null +++ b/meta-systemd/oe-core/recipes-extended/at/at_3.1.13.bbappend | |||
@@ -0,0 +1,18 @@ | |||
1 | inherit systemd | ||
2 | |||
3 | PRINC := "${@int(PRINC) + 2}" | ||
4 | |||
5 | # look for files in the layer first | ||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
7 | |||
8 | SRC_URI += "file://atd.service" | ||
9 | |||
10 | RPROVIDES_${PN} += "${PN}-systemd" | ||
11 | RREPLACES_${PN} += "${PN}-systemd" | ||
12 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
13 | SYSTEMD_SERVICE_${PN} = "atd.service" | ||
14 | do_install_append() { | ||
15 | install -d ${D}${systemd_unitdir}/system | ||
16 | install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system | ||
17 | } | ||
18 | |||