summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-11-21 23:36:38 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-11-29 11:03:34 +0100
commit0c398b0c7997dc2fce0c681899872345fb56a117 (patch)
treee4191c837b083dfcbfa0acbee0beb338ecc00dbd /meta-systemd/oe-core
parent24289982628563ce6c49a8dc207c2a1cbd9167b3 (diff)
downloadmeta-openembedded-0c398b0c7997dc2fce0c681899872345fb56a117.tar.gz
dhcp: rename bbappend to match new version from oe-core and move to oe-core prefix
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcpd.service12
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcrelay.service10
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.4-P2.bbappend13
3 files changed, 35 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcpd.service b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcpd.service
new file mode 100644
index 000000000..70beee92e
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcpd.service
@@ -0,0 +1,12 @@
1[Unit]
2Description=Dynamic Host Configuration Protocol (DHCP)
3After=syslog.target network.target
4
5[Service]
6Type=forking
7PIDFile=/var/run/dhcpd.pid
8EnvironmentFile=-/etc/default/dhcp-server
9ExecStart=/usr/sbin/dhcpd -cf /etc/dhcp/dhcpd.conf -q $INTERFACES
10
11[Install]
12WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcrelay.service b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcrelay.service
new file mode 100644
index 000000000..f68f468ee
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp/dhcrelay.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=DHCP Relay Agent Daemon
3After=syslog.target network.target
4
5[Service]
6EnvironmentFile=/etc/default/dhcp-relay
7ExecStart=/usr/sbin/dhcrelay -d $DHCRELAYARGS
8
9[Install]
10WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.4-P2.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.4-P2.bbappend
new file mode 100644
index 000000000..a18fda802
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.4-P2.bbappend
@@ -0,0 +1,13 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4inherit systemd
5
6PRINC := "${@int(PRINC) + 1}"
7
8SYSTEMD_PACKAGES = "dhcp-server-systemd dhcp-relay-systemd"
9SYSTEMD_SERVICE_dhcp-server-systemd = "dhcpd.service"
10SYSTEMD_SERVICE_dhcp-relay-systemd = "dhcrelay.service"
11
12SRC_URI += "file://dhcpd.service \
13 file://dhcrelay.service"